Amavis / Postfix - Komische Fehlermeldung

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
stefano
Posts: 27
Joined: 2003-04-07 21:04

Amavis / Postfix - Komische Fehlermeldung

Post by stefano » 2004-10-16 00:47

Ich habe auf meinem SuSE 8.1 Server mit Postfix nun Amavis 0.3.12 und AntiVir installiert. Es scheint alles zu funktionieren, eingehende Mails mit Viren werden geblockt und Benachrichtigungen verschickt.
Was mich nur beunruhigt: In /var/log/warn und /var/log/mail taucht jetzt exakt jede Minute (manchmal auch öfter) eine Fehlermeldung auf:

pxxxxxxxx postfix/qmgr[738]: warning: connect to transport vscan;: No such file or directory

In meinen Postfix-Konfigurationsdateien habe ich nirgends etwas von vscan;: drinstehen, ich habe lediglich hinzugefügt:

main.cf:
content_filter = vscan:

master.cf:
vscan unix - n n - 10 pipe
user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}

localhost:10025 inet n - n - - smtpd -o content_filter=

Wie werde ich diese Meldungen wieder los bzw. was wollen sie mir sagen?

Bin dankbar für jeden Tipp.

athlux
Posts: 61
Joined: 2004-08-20 13:53

Re: Amavis / Postfix - Komische Fehlermeldung

Post by athlux » 2004-10-16 03:00

StefanO wrote: In meinen Postfix-Konfigurationsdateien habe ich nirgends etwas von vscan;: drinstehen, ich habe lediglich hinzugefügt:

main.cf:
content_filter = vscan:
Doch. Das "vscan" in der main.cf wird es sein über das postfix meckert. Mich wundert etwas das es doch funktioniert. Aber nun gut.

Ersetzt es mal durch folgendes
content_filter = smtp:127.0.0.1:10024

könnte sein das Er mit folgender Einstellung "vscan" in der master.cf nicht ganz klar kommt.

Code: Select all

vscan unix - n n - 10 pipe
user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
bei mir reicht diese Zeile hier in der master.cf schon aus.

Code: Select all

localhost:10025 inet    n       -       n       -       -       smtpd -o content_filter=

stefano
Posts: 27
Joined: 2003-04-07 21:04

Re: Amavis / Postfix - Komische Fehlermeldung

Post by stefano » 2004-10-16 13:56

Ich denke die Konfiguration ist schon korrekt. Was Du schreibst ist die Konfiguration für amavisd-new, ich setze aber amavis ein.

An der Fehlermeldung wundert mich, daß er vscan;: schreibt. Woher kommt das Semikolon?

Hat noch jemand eine Idee?

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Amavis / Postfix - Komische Fehlermeldung

Post by sascha » 2004-10-16 14:45

Evtl. hattest du das vorher mal falsch in der main.cf stehen und jetzt gammelt dir eine Mail in der Queue rum, die unbdingt durch "vscan;" laufen möchte. Tippe mal auf der shell "mailq" ein und lösche dann ggf. mit "postsuper -d" die entsprechende Mail.

stefano
Posts: 27
Joined: 2003-04-07 21:04

Re: Amavis / Postfix - Komische Fehlermeldung

Post by stefano » 2004-10-16 15:24

Super, das war's! Zu Beginn hatte ich tatsächlich fälschlicherweise vscan; geschrieben, dann aber geändert. Hätte nicht gedacht, daß Postfix sich das für jede Mail merkt, da hingen tatsächlich noch ein paar in der Queue die damit behandelt werden wollten...

Vielen Dank Sascha!

stefano
Posts: 27
Joined: 2003-04-07 21:04

Re: Amavis / Postfix - Komische Fehlermeldung

Post by stefano » 2004-10-16 16:17

Möchte noch kurz anmerken, daß man auch mit

Code: Select all

postsuper -r ALL
alle Mails im Queue neu queuen lassen kann, wobei dann die neuen Einstellungen für den content_filter herangezogen werden. Ist praktisch wenn man die Mails nicht einfach löschen kann.