SSH Server Debian Problem

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
h0nig
Posts: 51
Joined: 2004-07-14 17:03
Location: /dev/null

SSH Server Debian Problem

Post by h0nig » 2004-08-10 01:50

Ich hab Debian auf meinem Server mit dem Script installiert: http://linux.roothell.org/debian-s4f/ .
Ich wurde bei der Installation gefragt ob ich SSH installieren will , hab ich ausgewählt ,
blos nur wenn ich auf meinen Server connecten will schliest sich sofort mein Putty Fenster bzw er mein connection closed.

Hier mal ein Debug:
webserver:~# ssh -vvv 217.172.178.241
OpenSSH_3.4p1 Debian 1:3.4p1-1.woody.3, SSH protocols 1.5/2.0, OpenSSL 0x0090603f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: ssh_connect: needpriv 0
debug1: Connecting to 217.172.178.241 [217.172.178.241] port 22.
debug1: Connection established.
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.4p1
debug1: match: OpenSSH_3.4p1 pat OpenSSH*
Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.4p1 Debian 1:3.4p1-1.woody.3
debug1: SSH2_MSG_KEXINIT sent
Connection closed by 217.172.178.241
debug1: Calling cleanup 0x8063aac(0x0)



Und hier meine Ssh Config:
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes
ListenAddress 217.172.178.241
# ...but breaks Pam auth via kbdint, so we have to turn it off
# Use PAM authentication via keyboard-interactive so PAM modules can
# properly interface with the user (off due to PrivSep)
PAMAuthenticationViaKbdInt no
# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 600
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile%h/.ssh/authorized_keys

# rhosts authentication should not be used
RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Uncomment to disable s/key passwords
#ChallengeResponseAuthentication no

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes


# To change Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#AFSTokenPassing no
#KerberosTicketCleanup no

# Kerberos TGT Passing does only work with the AFS kaserver
#KerberosTgtPassing yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
#PrintLastLog no
KeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net
#ReverseMappingCheck yes

Subsystemsftp/usr/lib/sftp-server

Woran könnte es liegen? Ich hab ehrlich gesagt Keine Ahnung...

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: SSH Server Debian Problem

Post by sascha » 2004-08-11 11:03

Putty mal so einstellen, dass es sich nicht schließt und in den Einstellungen SSH2 aktivieren.

h0nig
Posts: 51
Joined: 2004-07-14 17:03
Location: /dev/null

Re: SSH Server Debian Problem

Post by h0nig » 2004-08-11 12:27

Alles schon versucht... Bringt nichts.

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: SSH Server Debian Problem

Post by sascha » 2004-08-11 12:45

Dann lies die Logs auf dem Server...

h0nig
Posts: 51
Joined: 2004-07-14 17:03
Location: /dev/null

Re: SSH Server Debian Problem

Post by h0nig » 2004-08-11 13:12

Die sind ja leider leer...

arnee
Posts: 54
Joined: 2003-09-30 21:32

Re: SSH Server Debian Problem

Post by arnee » 2004-08-11 16:20

Benutze nmap um zu gucken, ob überhaupt Dienste laufen. Unterstützt dein Kernel das von dir gewählte FS?

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: SSH Server Debian Problem

Post by oxygen » 2004-08-11 17:48

hm scheint eigentlich alles normal zu sein:
christian@oxygen-mobile ~ $ ssh -v root@217.172.178.24
OpenSSH_3.8.1p1, OpenSSL 0.9.7d 17 Mar 2004
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to 217.172.178.24 [217.172.178.24] port 22.
debug1: Connection established.
debug1: identity file /home/christian/.ssh/identity type -1
debug1: identity file /home/christian/.ssh/id_rsa type 1
debug1: identity file /home/christian/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.5p1
debug1: match: OpenSSH_3.5p1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
The authenticity of host '217.172.178.24 (217.172.178.24)' can't be established.
RSA key fingerprint is 7c:28:26:e7:7e:2b:8b:ca:b1:36:21:70:66:7a:c8:fb.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '217.172.178.24' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received

debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering public key: /home/christian/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/christian/.ssh/identity
debug1: Trying private key: /home/christian/.ssh/id_dsa
debug1: Next authentication method: password
root@217.172.178.24's password: