Nameserver: Email-Problem

Bind, PowerDNS
eisbär
Posts: 14
Joined: 2002-10-06 18:10

Nameserver: Email-Problem

Post by eisbär » 2004-08-05 23:06

Moin.

Ich hab ein kleines Problemchen mit Pop3 und meinem Nameserver (denke ich mal)

System:
* 1&1 Rootserver L
* SuSe 9.1
* Confixx 3.x
* BIND 9.2.3

Meine Zone-Datei für meinedomain.tld:
$TTL 1W
@ IN SOA ns.hauptdomain.tld. root.meinedomain.tld. (
2004080301 ; serial
8H ; refresh
2H ; retry
1W ; expiry
11h) ; minimum


IN NS ns.hauptdomain.tld.
IN NS ns.schlund.de.
IN MX 10 mail.meinedomain.tld.
IN MX 20 mx00.schlund.de.
IN A 123.456.78.9
* IN A 123.456.78.9
So, jetzt mal endlich mein Problem:

Ich habe per confixx eine Pop3-Box und Emailadresse angelegt:

test@meinedomain.tld -->> webxpy -->> meineemail@provider.tld

Die Email sol also in einem Pop3 Postfach gespeichert werden, sowie an eine weitere Emailadresse verschickt werden..

Allerdings bekomme ich die Mail "nur" an meineemail@provider.tld geschickt.
Das Pop3 Postfach bleibt leer :o(

Woran kann das liegen?!??!

evtl. daran:
IN MX 10 mail.meinedomain.tld.
IN MX 20 mx00.schlund.de.
muss es viellicht mx??.schlund.de heissen?!?!

Das komische daran ist nur, das ich jetzt 2 Rootserver habe, und bei dem einem funktioniert das so.... :?: :!: :?: :cry:


Danke für Eure Hilfe

eisbär
Posts: 14
Joined: 2002-10-06 18:10

Re: Nameserver: Email-Problem

Post by eisbär » 2004-08-05 23:10

Achso:

Subdomains klappen.. Also so ganz falsch kann der Nameserver nicht konfiguriert sein... Providerdomain hat auch keine Fehler gebracht...

eisbär
Posts: 14
Joined: 2002-10-06 18:10

Re: Nameserver: Email-Problem

Post by eisbär » 2004-08-05 23:29

Ich glaub, das es NICHTS mit dem Nameserver zu tun hat..

Wenn ich mir eigene Mails von test@meinedomain.de an blubber@meinedomain.de schicke, dann kommen die an..

Verschicke cih sie aber von GMX, Web.de, oder sonst einem Anbieter, dann gehen die verloren!?!?!

Hä?!?!?

Anonymous

Re: Nameserver: Email-Problem

Post by Anonymous » 2004-08-06 04:03

wie kommst du darauf, es hat was mit dem Nameserver zu tun? der 2. MX eintrag mit prio 20 ist einfach nur der mailserver an den die mails gehen wenn prio 10 ausfällt.
Wenn du an Emailaddresse (a) was schicken willst und das soll auch an (b) gehen dann ist das ne mailD configsache

eisbär
Posts: 14
Joined: 2002-10-06 18:10

Re: Nameserver: Email-Problem

Post by eisbär » 2004-08-06 10:27

eisbär wrote:Ich glaub, das es NICHTS mit dem Nameserver zu tun hat..
Hab mich ja selber verbessert.. Kann es aber ja nicht in "Mailserver - Installation & Konfiguration" verschieben und das Thema editieren..

Hat denn keiner einen Rat für mein Problem?!?!

Will nämlich auch von extern Mails empfangen können

wgot
Posts: 1675
Joined: 2003-07-06 02:03

Re: Nameserver: Email-Problem

Post by wgot » 2004-08-06 12:11

solange Du mit hauptdomain.tld und meinedomain.de rumhantierst bestimmt nicht.

Glaskugel: möglicherweise reichen schon ein paar Tage Geduld.

Gruß, Wolfgang

eisbär
Posts: 14
Joined: 2002-10-06 18:10

Re: Nameserver: Email-Problem

Post by eisbär » 2004-08-06 12:16

hautdomain.tld = xxx
meinedomain = yyy (keine Angst, is nur ne Testdomain... ;) )

==> mail.yyy

SMPT AUTH und POP3 funktionieren mit mail.waddehadde.de

Nur kann ich eben von web.de gmx.de oder ähnlichen keine Mails empfangen..

Edit: mit gmx gehts mittlerweile auch.. aber eben ncoh nciht von jedem Anbieter..
Kann das sein, das die einzelnen Provider ihre DNS server nicht täglich updaten?!?!
Last edited by eisbär on 2004-08-16 10:48, edited 1 time in total.

perlitz
Posts: 202
Joined: 2003-11-01 12:25

Re: Nameserver: Email-Problem

Post by perlitz » 2004-08-12 17:15

... Kann das sein, das die einzelnen Provider ihre DNS server nicht täglich updaten?!?!
Die Erfahrung musste ich auch schon machen ;)

wgot
Posts: 1675
Joined: 2003-07-06 02:03

Re: Nameserver: Email-Problem

Post by wgot » 2004-08-12 23:04

Hallo,
eisbär wrote:mit gmx gehts mittlerweile auch.. aber eben ncoh nciht von jedem Anbieter..
sobald es mit einem Anbieter geht ist die Konfiguration in Ordnung.
Kann das sein, das die einzelnen Provider ihre DNS server nicht täglich updaten?!?!
Ja, dauert bis zu einer Woche, dann läuft es mit allen Anbietern.

Wichtig (da 1&1-Server): Im 1&1-Config muß auf eigener Mailserver gestellt sein und alle im 1&1-Config angelegten Emailadressen müssen gelöscht sein, d.h. dort darf keine Emailadresse angelegt sein, auch keine Weiterleitung. Sonst klappt es nach der Woche mit allen Providern außer 1&1.

Gruß, Wolfgang

kasi4u
Posts: 116
Joined: 2002-08-12 22:34
Location: Leipzig

Re: Nameserver: Email-Problem

Post by kasi4u » 2004-08-14 09:38

der

Code: Select all

mx00.schlund.de
wieso steht der in deinem zone-file?

hast du deine domain über 1&1 registriert oder über schlundtec? wenn du sie über 1&1 registriert hast, dann ist das okay, wenn aber über schlundtec, dann kennt der mx00.schlund.de gar nicht deine domain und wird mails, die dein mx prio 10 nicht annehmen kann, weswegen auch immer, einfach ablehnen mit "550". der mx00.schlund.de ist ein mx-backup für 1&1-domains. schlundtec bietet solch einen mx-backup nicht an.

gruß
karsten

eisbär
Posts: 14
Joined: 2002-10-06 18:10

Re: Nameserver: Email-Problem

Post by eisbär » 2004-08-16 10:51

Bestelle über Ex-Providerdomain..

Heisst, das Zonefile sollte nur so aussehen:

Code: Select all

$TTL 1W 
@ IN SOA ns.hauptdomain.tld. root.meinedomain.tld. ( 
2004080301 ; serial 
8H ; refresh 
2H ; retry 
1W ; expiry 
11h) ; minimum 


IN NS ns.hauptdomain.tld. 
IN NS ns.schlund.de. 
IN MX 10 mail.meinedomain.tld. 
IN A 123.456.78.9 
* IN A 123.456.78.9 
Aber warum war das "früher" anderst, und warum klappt das so auf dem "alten" Rootserver?!?!

kasi4u
Posts: 116
Joined: 2002-08-12 22:34
Location: Leipzig

Re: Nameserver: Email-Problem

Post by kasi4u » 2004-08-16 11:11

das würde mich jetzt interessieren: bestelle über ex-providerdomain. sende mir doch einma eine pn, damit wir nicht gegen die boardregeln verstoßen "keine werbung", damit ich über ex-prov bestellen kann... wenn das dort schneller geht, mache ich schluss mit schlundtec...

danke schon mal im voraus,
karsten

wgot
Posts: 1675
Joined: 2003-07-06 02:03

Re: Nameserver: Email-Problem

Post by wgot » 2004-08-16 11:57

Hallo,
eisbär wrote:Aber warum war das "früher" anderst, und warum klappt das so auf dem "alten" Rootserver?!?!
"klappen" (die Domainregistrierung) tut es auch bei den neuen. Ob der Mailverkehr dann zuverlässig funktioniert ist eine andere Frage.

Schlundtec bietet für seine Domainkunden keinen Backup-MX an. Soll früher anders gewesen sein (ich hab's nicht ausprobiert).

@Karsten: Providerdomain wurde in Schlundtec umbenannt, ist also die selbe Firma gemeint.

Gruß, Wolfgang

eisbär
Posts: 14
Joined: 2002-10-06 18:10

Re: Nameserver: Email-Problem

Post by eisbär » 2004-08-16 12:28

Na, dann bin cih ja froh, das ich es doch ins DNS Forum geschrieben hab.. ;o)

Schlundtec = "Ex" - Providerdomain

Danke Euch!!