Debian&S4Y

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Debian&S4Y

Post by 3-ranger » 2004-08-02 07:32

Hi,

wolle per Recoveryconsole Debian installieren. Alles hat wieder gut funkttionniert, bis auf den Ausstieg...rebooot und nicht ging mehr.

1.Script gestartet
2. Alles nach debiahhowto.de ausgeführt
3. erste Ungerreimtheiten in Netzerkkonfikuration (habe beide Werte probiert gehabt).Rechts die, sins vorher von mir aus Yast ausgelesen worden.

Code: Select all

Servername:     denver070.server4you.de denver070.server4you.de
Base-IP:        217.172.178.70                  217.172.178.70
Network:        217.172.178.0                   217.172.178.0
Broadcast:      217.172.178.255                 217.172.178.255
Netmask:        255.255.255.0                   255.255.254.0
Gateway:        217.172.179.1                   217.172.178.1
4. dann ein

Code: Select all

mkdir /mnt/debian 
mount /dev/hda3 /mnt/debian 
mount /dev/hda1 /mnt/debian/boot 
mount /dev/hda5 /mnt/debian/usr
mount /dev/hda6 /mnt/debian/home
chroot /mnt/debian
5. so sah die /etc/network/interfaces aus

Code: Select all

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address   217.172.178.70
        netmask   255.255.255.0
        network   217.172.178.0
        broadcast 217.172.178.255
        gateway   217.172.179.1
        up      /sbin/route delete -net 217.172.178.0/24

6. so die vi /etc/modules

Code: Select all

echo unix
af_packet
rtl8139
via-rhine
7. in der /etc/modules.conf
stand kein
alias eth0...via-rhine...hatte es selber nachgetragen gehabt

8. exit und Reboot angefordert. Beim ersten mal REcovery beendet und aus dem DEbian shutdown -rn now gemacht.

Beide mal konnte ich nicht connecten per SSH.

Was mache ich falsch..bitte helft mir. Die ganze Nacht durchgemacht. pl

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Debian&S4Y

Post by captaincrunch » 2004-08-02 07:49

Hast du die Netzwerkconfig selbst eingetragen, oder dich auf die Informationen des Scripts verlassen?
gateway 217.172.179.1
sieht mir (in Bezug auf den Rest) nämlich irgendwie ziemlich merkwürdig aus. Ich für meinen Teil würd's dann einfach mal mit der 178 statt der 179 versuchen.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 07:59

hi,

danke erstmal für die schnelle Antwort. Das war die Angabe vom Script. Auch , daß mit 255.255.255.0 war etwas komisch (für mich normal), aber unter SuSe stand bei mir 255.255.254.0 !?
Habe beide Versionen ausprobiert und zuletzt die, die ich vorher auch aus meiner alten SuSe Installation ausgelesen hatte. Die war wie folgt.

Code: Select all

IP: 217.172.178.70
Netmask: 255.255.254.0
Broadcast: 217.172.178.255
standardgateway: 217.172.178.1
Network:217.172.178.0

rechnername: denver070
hostname; server4you.de
nameserver1: 217.172.166.7
nameserver2: 217.172.191.7
Habe soeben nochmal die Recovery beantragt um zu sehen, wie boot messages unter /var/log/messages aussahen.

Edit (1)
Keine Messages, die ich gebrauchen kann, zu sehen. Wo stehen die noch? ups

Danke

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 10:53

hi,

ich gebs auf. Insgesamt 6 mal seit heute Nacht die Recoveryconsole bestellt und leider hauts immer noch nicht hin.

Komme per SSH nicht rein. Schade :oops: :cry:

trotzdem Danke

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Debian&S4Y

Post by captaincrunch » 2004-08-02 10:56

Um das ganze noch mal zusammenzufassen: du kannst den Server nach dem reboot anpingen, kommst aber nicht per ssh drauf? Hast du ssh denn mitinstalliert. Wird ssh automatisch gestartet?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 11:01

hallo,

ja genau. Er lässt sich anpingen, bekomme als Meldung über Putty leider

Code: Select all

Connection refused
Habe soeben wieder eine Installation ausgeführt und warte auf den Reboot. :?:

Falls ich wieder nicht reinkommen sollte, geh ich noch mal per Recoveryconsole rein und schaue mir die logs an.
In welche soll ich genau reinschauen, bin nähmlich bis jetzt etwas SuSe verwöhnt?
--------------------------------------------------------------
Edit

leider kommt jetzt kein Ping mehr zurück....
S4Y will geschlagene 160 Euro für eine Installation haben Oo.......
Hoffentlich geschieht die Recovery automatisch, falls jemand immer hinlaufen muss..tut er mir jetzt schon leid!


danke

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 11:29

Hi,

ein modprobe via-rhine gibt mir folgendes aus

Code: Select all

localhost:/# modprobe via-rhine
modprobe: Can't open dependencies file /lib/modules/2.4.21/modules.dep (No such file or directory)

thorsten
RSAC
Posts: 732
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: Debian&S4Y

Post by thorsten » 2004-08-02 12:07

Wenn du den Server anpingen kannst, wird das Netzwerk wohl oben sein.
Aber dein SSHD kommt wohl nicht in die Hufe.
Sieh mal zu, dass der richtig installiert ist :)

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 12:33

hi,

ok der Ping ist wieder da, also wie du schon sagst...der SSH...
habe den manuell nicht nachinstalliert...

wie kann ich bereits unter dem rescue system sehen, ob tatsächlich ssh mitstartet? :cry:

Danke

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Debian&S4Y

Post by captaincrunch » 2004-08-02 13:07

man netstat
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 13:09

hi,

als ich netatat -rn eingab hatte er mir einige Fehler mit Modulabhängigkeiten gebracht. /lib/modules/2.4.21/....

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 13:19

so, will Euch nicht mehr auf den Geist gehen :roll: , bin aber trotzdem über meine Unfähigkeit sehr überrascht.
Anscheinend soll es einfach ned sein.

cu

beantrage jetzt nach 10 Stunden erfolglosem Kampf wieder suse 9.0, die 160 Euro für einen Studenten sind doch etwas happig.

Danke nochmals an alle

3-ranger
Posts: 64
Joined: 2004-03-23 16:17

Re: Debian&S4Y

Post by 3-ranger » 2004-08-02 17:35

So,

es hat geklappt :lol: :-D :) 8O :?:

wie? ich weiss es nicht

1. Script ausgeführt
2. Konsole im Webinterface deaktivert
3. shutdown -rn now
4. reboot angefordert und es ging
Last edited by 3-ranger on 2004-08-07 12:00, edited 1 time in total.

h0nig
Posts: 51
Joined: 2004-07-14 17:03
Location: /dev/null

Re: Debian&S4Y

Post by h0nig » 2004-08-06 14:28

hm habe auch ein prob: script ausgeführt etc dann reboot aber bei mir bootet er leider nicht mehr ;( ping bringt auch nichts