Mail() extrem langsam

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
günter
Posts: 38
Joined: 2002-10-03 12:32

Mail() extrem langsam

Post by günter » 2004-07-31 13:37

Hi,

ich hab' zwei maschinen: "absolut" gleich Konfiguriert, von Debian GNU/Linux bis hin "PHP Version 4.3.3RC3".

auf eine Maschine wird mail() in

"Rendering Time: 0.00021195411682"

ausgeführt.(ist OK)


auf andere dauert gleiche mail():

Rendering Time: 20.0859217644

????
es ist extrem lahm.!

Hat jemand eine Idee? woran es liegt? was mache ich falsch?

Anonymous

Re: Mail() extrem langsam

Post by Anonymous » 2004-07-31 14:33

bleibt evtl vielleich was im paketfilter hängen ?
oooder ist der dns-server zu langsam ?

mach mal nen entsprechenden tcpdump, dann wird sichs schon zeigen.
gruß,
steady

günter
Posts: 38
Joined: 2002-10-03 12:32

Re: Mail() extrem langsam

Post by günter » 2004-07-31 20:04

Da ist leider absolut nix auffälliges :(
Auch das Update auf eine neue PHPversion hat nichts gebracht :((((

suntzu
RSAC
Posts: 698
Joined: 2002-12-20 19:47
Location: Mönchengladbach

Re: Mail() extrem langsam

Post by suntzu » 2004-08-01 19:17

Hi,

wie lange dauern denn DNS-Lookups? Einfach mal mit host zieldomain-der-emails.com ausprobieren.

günter
Posts: 38
Joined: 2002-10-03 12:32

Re: Mail() extrem langsam

Post by günter » 2004-08-01 23:34

Hmm... es scheint an sendmail zu liegen.

Mein testscript gibt mir folgendes aus:

defer send: 1.1531071662903
queue send: 5.6457221508026
background send: 0.6189558506012
normal send: 2.671501159668

Und das immer mit zu hohen Werten, teilweise bis 8 sekunden... andere Nameserver hab ich auch schon versucht :(

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Mail() extrem langsam

Post by floschi » 2004-08-02 07:26

Andere Nameserver sind egal, evtl. hat dein Rechner Probleme mit der Auflösung, d.h. spielst du in irgendeiner Form mit Firewallregeln?

günter
Posts: 38
Joined: 2002-10-03 12:32

Re: Mail() extrem langsam

Post by günter » 2004-08-02 13:43

Auch keine.... bzw. alle rausgenommen.

Nameserver sind getestet, da keine Probleme.

Kann es an einer allgemein hohen Last des Servers liegen ? Ich denke mal das 2.9 im Schnitt allerdings niht viel sind