Wake On Lan - Server startet von selbst neu nach Poweroff!

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
root_tux_linux
Posts: 8
Joined: 2004-07-24 03:07

Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by root_tux_linux » 2004-07-26 09:11

Hi

Ich hab ein Problem mit WOL und meinem Backup-Server.

Ich hab im BIOS WOL aktiv, hab eine WOL Realtek NIC, Kabel natürlich eingesteckt, habe die modprobe.conf editiert:

Code: Select all

alias eth0 8139
options 8139too enable_wol=1
.

Den Befehl

Code: Select all

ethtool -s eth0 wol g
eingetippt, danach die Kiste runtergefahren und hier beginnt das Höllenspielchen!

Der Server startet sich ständig neu und ich finde einfach den Fehler nicht!

Es wird nirgends ein Paket an die Mac des Server gesendet, dennoch startet er neu.

Nun wüsste ich gern was falsch ist und wie ich das Kistchen zum laufen bekomme!



Hat jemand schon damit erfahrung gemacht?
Weiss jemand eine Lösung?


Infos:
Mandrake Linux 10
Kernel 2.6.5*
Realtec 8139 WOL (Planet ENW-9503/9504)
Treiber 8139too
ethtool

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Wake On Lan - Server startet von selbst neu nach Powerof

Post by sascha » 2004-07-26 09:18

root_tux_linux wrote: Der Server startet sich ständig neu und ich finde einfach den Fehler nicht!

Es wird nirgends ein Paket an die Mac des Server gesendet, dennoch startet er neu.
Bist du dir da sicher? Zieh doch mal das Ethernet Kabel ab.

root_tux_linux
Posts: 8
Joined: 2004-07-24 03:07

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by root_tux_linux » 2004-07-26 09:52

Wenn ich das Kabel abzieh startet er nicht neu aber...


1. Wenn alle Rechner im Netzwerk aus sind, startet er dennoch
2. Wenn ich den Switch durch einen Hub ersetzt, startet er auch
3. tcpdump spuckt nichts aus. es wird kein Magic Paket geschickt!

Da ich bei ethtool -s eth0 wol g eingetippt hab sollte er nur auf Magic Paket reagieren, aber er reagiert anscheinend auf alles, egal ob Rechner oder HUB, Router, Switch, egal ob man Magic Paket abschickt oder nicht.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by Joe User » 2004-07-26 10:33

Stecker und Kabel auf Beschädigungen (Wackelkontakt/Kabelbruch/etc) geprüft?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

root_tux_linux
Posts: 8
Joined: 2004-07-24 03:07

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by root_tux_linux » 2004-07-26 10:56

Das RJ45 hab ich schon ausgetauscht test weise, das NIC zu WOL Anschluss kann ich nicht austauschen weil ich keins zur Hand hab. Aber es sollte i.o. sein da es neu ist und ich nichts dran sehe was auf einen Defekt schliessen lässt.

Ich werd nachher kurz die NIC unter Windows teste um zu sehen ob die NIC i.o ist.

helios24
Posts: 8
Joined: 2004-07-15 12:46

WOL

Post by helios24 » 2004-07-26 10:58

Mein debian server benötigt keinerlei modul parameter um über WOL startbar zu sein. Probiers mal ohne den command und die modul parameter ob es nicht geht.

Gruss helios

thorsten
RSAC
Posts: 732
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by thorsten » 2004-07-26 11:00

Genau dieses Problem hatte auch ein Kumpel mit einer dieser _billigen_ RTL 8139 Karten.
Er hat sie gegen eine 3COM getauscht und nun funktioniert es wie gewollt.

Wenn du einen Server betreibst, dann tu dir einen Gefallen und hol dir eine 3COM, Netgear oder Intel NIC - damit hast du i.d.R. weniger Probleme.

root_tux_linux
Posts: 8
Joined: 2004-07-24 03:07

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by root_tux_linux » 2004-07-26 11:18

Werd ich nachher auch versuchen danke für den Tipp.


@Thorsten hast du mir auch ein Modellname einer 3COM mit WOL?

Finde keine einzige Intel noch 3Com bei den Online-Shops wo ich immer bestelle :(

helios24
Posts: 8
Joined: 2004-07-15 12:46

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by helios24 » 2004-07-26 11:22

hey root_tux_linux wo wohnst du?
ich hab hier noch eine 3com irgendwas rumliegen :)

thorsten
RSAC
Posts: 732
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: Wake On Lan - Server startet von selbst neu nach Poweroff!

Post by thorsten » 2004-07-26 11:30

Ich meine die 3c905 können das alle seit einigen Jahren.
Wenn du jetzt allerdings wirklich was neues kaufst, würde ich eher eine Gigabit Karte kaufen - die kosten auch nicht mehr die Welt und du bist für kommende Anforderungen gerüstet...

google hat das auf die schnelle rausgeworfen:
http://secure.nurtec.de/cgi-bin/nurtec/ ... l?mv_pc=sm