Problem nach Postfix Installation

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
cyberline
Posts: 97
Joined: 2003-01-28 10:11
Location: Hürth

Problem nach Postfix Installation

Post by cyberline » 2004-07-23 07:17

Hallo, habe einem Kollegen auf seinem Redhat9 Server Postfix-2.1.4 vom Source installiert zusammen mit SASL2 und Confixx2.

postconf -m:

static
cidr
pcre
nis
regexp
environ
proxy
btree
unix
hash

postconf -n:

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
disable_vrfy_command = yes
html_directory = no
mail_spool_directory = /var/spool/mail
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
maps_rbl_domains = relays.ordb.org combined.njabl.org list.dsbl.org sbl.spamhaus.org opm.blitzed.org
maximal_queue_lifetime = 4d
message_size_limit = 36700160
mydestination = $myhostname, localhost.$mydomain, localhost, XXX.XXX.XXX.XXX, $mydomain
myhostname = mail.XXXXXXXXXX.de
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-1.1.12/README_FILES
sample_directory = /usr/share/doc/postfix-1.1.12/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_always_send_ehlo = yes
smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)
smtpd_client_restrictions = permit_sasl_authenticated
smtpd_delay_reject = yes
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_rbl_client,reject_unauth_pipelining,reject_unauth_destination
smtpd_sasl_application_name = smtpd
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = permit_sasl_authenticated
unknown_local_recipient_reject_code = 450
virtual_alias_maps = hash:/etc/postfix/confixx_localDomains, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/virtual

Das Problem ist nun, das Mails an bestimmte Provider nicht verschickt werden mit folgender Fehlermeldung:

Jul 21 01:15:23 mail postfix/qmgr[19300]: 56EA4674006: from=<XXXXXX@XXXXXXX.XX>, size=1743, nrcpt=1 (queue active)
Jul 21 01:15:23 mail postfix/smtp[25087]: 56EA4674006: to=<webmaster@XXXXXXX.com>, relay=none, delay=1788, status=bounced (Host or domain name not found. Name service error for name=XXXXXXX.com type=A: Host found but no data record of requested type)

Die redolv.conf ist auch ok, weil ich habe nur diesen Kunden auf einen Extra Server im gleichen RZ ausgelagert und da er im gleichen IP Bereich ist, die NS übernommen. Vorher auf dem anderen Server ging das einwandfrei, aber ich konnte die Config nicht 1:1 übernehmen weil auf dem alten Server noch ein älteres Postfix1 läuft. Mir ist aufgefallen das auch grosse Provider wie T-Online abgelehnt werden. Paradoxerweise habe ich jedoch einmal eine Lesebestätigung bekommen, obwohl ich mir an meine Addresse keine Mails schicken kann wegen eben diesem Fehler.
Währe schön wenn jemand eine Lösung wüßte. Per Ping sind die Domains übrigens alle erreichbar.

cyberline
Posts: 97
Joined: 2003-01-28 10:11
Location: Hürth

Re: Problem nach Postfix Installation

Post by cyberline » 2004-07-23 07:32

Hmm, also wenn ich den Eintrag

myhostname = mail.XXXXXX.de

deaktiviere, gehts, aber dann landen beim
Mail empfangen alle Mails im Postfach web1p1

Ich kriege die Krise!

dig findet übrigens alle MX Hosts.