Postfix mit SASL Auth funktioniert nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
moppi
Posts: 368
Joined: 2003-02-15 11:16

Postfix mit SASL Auth funktioniert nicht

Post by moppi » 2004-07-14 09:48

Hallo,

Postfix mit SASL Auth funktioniert bei mir nicht. Da die Auth ja mit SASL getätigt wird habe ich beim compilieren PAM weggelassen, ich hoffe das ist kein Fehler gewesen.

diese Schritte habe ich ausgeführt nach der compilierung:
http://sxs.thexdershome.com/internet_se ... stfix.html

Vielen Dank für jede Hilfe.

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: Postfix mit SASL Auth funktioniert nicht

Post by duergner » 2004-07-14 09:52

Wie immer: Logfiles, was genau geht nicht, ...

nimer
Posts: 42
Joined: 2003-11-20 15:08

Re: Postfix mit SASL Auth funktioniert nicht

Post by nimer » 2004-07-14 13:30

hm, das Howto von http://www.workaround.org legt aber nahe das man pam braucht oder verstehe ich das falsch?

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: Postfix mit SASL Auth funktioniert nicht

Post by duergner » 2004-07-14 14:24

Nein muss nicht so sein. Das Howto dort nutzt als pwcheck Methode für den Saslauthd PAM. Muss man aber AFAIK nicht unbedingt machen.

moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: Postfix mit SASL Auth funktioniert nicht

Post by moppi » 2004-07-20 09:40

ich habe es nun unter gentoo zum laufen gebracht:

Code: Select all

USE ="-pam sasl" emerge postfix
emerge qpopper
source /etc/profiles
dann habe ich die binärdatenbanken rüberkopiert und die konfiguration von der suse postfixinstallation ein wenig zusammengeführt.

in der suse postfix main.cf glaube ich am ende werden dort die db's gehasht? die mit postmap erstellt werden. Aber wie in drei teufels namen erhalten die die informationen von confixx?
und wozu genau dienen die transport dbs die sind nämlich leer?