ezmlm

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
bytemare
Posts: 28
Joined: 2002-06-06 18:03

ezmlm

Post by bytemare » 2002-09-28 10:28

Hallo,

ich hoffe mir kann jemand helfen. Google und das Forum zeigt mir leider nichts an, was man Problem lösen könnte.

Leider lässt sich ezmlm nicht compilieren und bricht ab:

Code: Select all

./load ezmlm-make auto_bin.o open.a getopt.a substdio.a 
strerr.a stralloc.a alloc.a error.a str.a 
ezmlm-make.o: In function `main':
ezmlm-make.o(.text+0x8df): undefined reference to `lock_ex'
ezmlm-make.o(.text+0x9b4): undefined reference to `getln'
ezmlm-make.o(.text+0x1130): undefined reference to `getln'
ezmlm-make.o(.text+0x1a4b): undefined reference to `getln'
collect2: ld returned 1 exit status
make: *** [ezmlm-make] Error 1
Deshalb installiert mir auch qinstall1.1 den qmailadmin nicht da ja zwischen beiden eine Abhängigkeit besteht.

Wer kennt sich hier soweit aus, entweder das Problem mit ezmlm zu lösen, oder qmailadmin via ./configure-Anweisung zu sagen das ich kein ezmlm haben möchte.

Mit besten Grüssen
Andre P.

P.S. vpopmail läuft prächtig und sqwebmail3 ist auch installiert. :)

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 10:39

oki ich versuchs mal:

gehe ins Verzeichnis /usr/local/src/qinstall

lösche dort die beiden ezmlm Verzeichniss. Lade dir dann die beiden Versionen nochmal direkt runter:
http://gd.tuwien.ac.at/infosys/mail/qma ... .53.tar.gz
http://gd.tuwien.ac.at/infosys/mail/qma ... .40.tar.gz

entpacken und dann folgendes:

mv -f ezmlm-idx-0.40/* ezmlm-0.53/ (achtung bei einem Fehler einfach diese Zeile nochmal ausführen)
cd ezmlm-0.53
patch < idx.patch
make clean
make; make man
make de
make std
make
make setup

so, dannach gehst du ins qmailadmin Verzeichnis und machst ein ./configure

Wenn net geht nochmal schreien ;)


Gruß

bytemare
Posts: 28
Joined: 2002-06-06 18:03

Re: ezmlm

Post by bytemare » 2002-09-28 10:54

Hallo sartre,

danke für Deine Hilfe.

Mein Problem fängt aber schon beim entpacken an. Wenn ich der INSTALL folge, erhalte ich folgenden Fehler:

Code: Select all

local:~/files # zcat ezmlm-0.53.tar.gz | tar -xvf
tar: option requires an argument -- f
Wenn ich das dann nochmal mit:

zcat ezmlm-0.53.tar.gz | tar -xv

versuche geht es.

Allerdings kommt dann das:

local:~/files/ezmlm-0.53 # patch < idx.patch
bash: patch: command not found

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 10:56

dann lösche nochmals beide Verzeichnisse!!!
enpacke beide Files mit dem Befehl:
tar -zxf ezmlm-0.53.tar.gz
tar -zxf ezmlm-idx-0.40.tar.gz

und dann nochmal wie beschrieben


Gruß

bytemare
Posts: 28
Joined: 2002-06-06 18:03

Re: ezmlm

Post by bytemare » 2002-09-28 11:03

:(

local:~/files/ezmlm-0.53 # patch < idx.patch
bash: patch: command not found

Warum denn das???

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 11:06

sieht so was als hättest du kein patch installiert. wenn du suse7.2 hast, dann installier folgendes:
http://libre.oit.umass.edu/suse/i386/7. ... /patch.rpm

Gruß

bytemare
Posts: 28
Joined: 2002-06-06 18:03

DANKE!!!

Post by bytemare » 2002-09-28 11:16

Vielen Dank,

sartre ich bin zu ewigen Dank verpflichtet.


Es funktioniert!!!!!!!!!!!!

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 11:24

na das freut mich doch :)

Viel Spass mit QMail


Gruß

bytemare
Posts: 28
Joined: 2002-06-06 18:03

Re: ezmlm

Post by bytemare » 2002-09-28 11:44

Leider hab ich micht zu früh gefreut.

Also ich hab jetzt eine Domain und einen User angelegt.
Das Einloggen funktioniert auch, aber es werden keine Grafiken angezeigt.

Hast Du auch noch ne Idee, wie ich dieses Problem lösen kann??

Wie logge ich mich als postmaster ein??

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 11:49

also hast du schon einen vhost für qmailadmin angelegt? Wenn nicht mach das mal und füge dann folgende Zeilen hinzu:

ScriptAlias /cgi-bin /var/www/cgi-bin/
SetEnv QMAILADMIN_TEMPLATEDIR /usr/local/share/qmailadmin/html

dann legst du in deinem Verzeichnis (hauptverzeichnis des Vhost) das Verzeichnis imgages/qmailadmin an
Dann kopierst du einfach die vorhandenen Graphiken

cp /var/www/html/images/qmailadmin/* /hier/ist/dein/verzeichnis/images/qmailadmin/

danach noch mal den apachen neu starten

Gruß

bytemare
Posts: 28
Joined: 2002-06-06 18:03

Re: ezmlm

Post by bytemare » 2002-09-28 11:59

yo den vhost hatte ich schon angelegt.
mit den tip image-verzeichnis anlegen haste wieder goldrichtig gelegen :-D

jetzt hab ich nur noch das problem mich als postmaster einzuloggen.
ich hab doch bisher kein passwort bzw. domain vergeben?!?!

wie verhält es sich mit sqwebmail, installiert ist es. wie kann ich denn darauf zugreifen.

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 12:05

also zum anlegen von maildomains und user nimmst du am besten vqadmin http://www.inter7.com/vqadmin/vqadmin-2.3.2.tar.gz

ansonsten:

/home/vpopmail/bin/vadddomain meinedomain.de passwort (dies ist der Postmasteraccount und muss auf jedenfall angelet werden)
Um einen Benutzer anzulegen einfach:
/home/vpopmail/bin/vadduser ich@meinedomain.de passwort


Gruß

bytemare
Posts: 28
Joined: 2002-06-06 18:03

Re: ezmlm

Post by bytemare » 2002-09-28 12:15

kapiert!!! :-D

funktioniert alles wunderprächtig, nur sqwbmail nicht.

http://domain.tld/cgi-bin/sqwebmail

bringt 404 :(

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: ezmlm

Post by sartre » 2002-09-28 12:18


bytemare
Posts: 28
Joined: 2002-06-06 18:03

Re: ezmlm

Post by bytemare » 2002-09-28 12:21

:oops:

Sorry, ich stell mich an wie ein Idiot. Da hätte man auch selber drauf kommen können. :roll:

Also für die kleine Lehrstunde werd ich mal für Deine kleine Tochter was springen lassen. 8)

t-son
Posts: 18
Joined: 2002-10-18 09:22
Location: Stuttgart

Re: ezmlm

Post by t-son » 2003-05-05 19:41

habt ihr auch ne Lösung fuer:
./load ezmlm-make auto_bin.o open.a getopt.a substdio.a
strerr.a stralloc.a alloc.a error.a str.a
ezmlm-make.o: In function `main':
ezmlm-make.o(.text+0x8df): undefined reference to `lock_ex'
ezmlm-make.o(.text+0x9b4): undefined reference to `getln'
ezmlm-make.o(.text+0x1130): undefined reference to `getln'
ezmlm-make.o(.text+0x1a4b): undefined reference to `getln'
collect2: ld returned 1 exit status
make: *** [ezmlm-make] Error 1
wenn es ein suse 8.1 system ist und per bigQ (siehe http://www.rootforum.de/forum/viewtopic ... 1141#51141 installiert wird?!

T-Son