kein boot nach Kernel Update (&und ich bin heute dämlich

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
einherjer
Posts: 24
Joined: 2002-06-05 05:11
Location: München

kein boot nach Kernel Update (&und ich bin heute dämlich

Post by einherjer » 2004-06-22 21:51

Ã?h, irgendwie bin ich glaub ich heute nicht auf der Höhe.

Hab grad wie schon öfter vorher auf meinen Rootie (alter 1&1 L, SuSE 8.1) nen neuern Kernel von update.pureserver.info installiert (2.4.26)

Gut - reboot
Schlecht - kommt nicht mehr hoch

Naja, denkt man sich kein Problem, wozu hat mich vorher /boot und /lib/modules gesichert

Also Ã?nderungen rückgängig gemacht (backup wieder drübergebügelt) und gebootet.

Tja, shit happens - er bleibt immer noch am Boden.

Der selbe Kernel lief schon - der vmlinuz Symlink sollte richtig sein - der grub eintrag sollte auch ok sein...

Ins Bootlog schreibt er nix mehr, soweit kommt er wohl gar nicht *snief*

Irgendwas überseh ich, aber was?
Hat mal wer den Denkanstoß bitte?

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: kein boot nach Kernel Update (&und ich bin heute dämlich

Post by wgot » 2004-06-22 22:48

Hallo,

wenn er kein Bootlog mehr schreibt könnte der Bootloader (grub) selbst defekt sein.

Reparatur:
http://www.rootforum.org/forum/viewtop ... 7707#97707
die letzten vier Zeilen von Punkt 11.

Oder beim Verlassen des Rescuesystems die Umounts vergessen?

Gruß, Wolfgang

einherjer
Posts: 24
Joined: 2002-06-05 05:11
Location: München

Re: kein boot nach Kernel Update (&und ich bin heute dämlich

Post by einherjer » 2004-06-22 23:13

Danke, ich glaub das war der richtige Hinweis ;-)

Hab noch ein paar files aus dem backup restored, den grub gestreichelt und jetzt gehts wieder.

Den neuen Kernel mach ich morgen wenn ich ausgeschlafen bin und nach ausreichend Kaffee *g*

lordrobe
Posts: 36
Joined: 2002-09-29 03:02
Location: Berlin, Germany

Re: kein boot nach Kernel Update (&und ich bin heute dämlich

Post by lordrobe » 2004-07-03 00:48

Hi.

Ich habe auf anraten meinen Kernel geupdated auf "2.4.26-040421" und Suse 8.2 (nach diesem Howto: http://www.rootforum.org/forum/viewtop ... date+howto )
Leider habe ich nun auch diesen Fehler dass mein Rootie nicht mehr normal hochfährt. Ich habe auch schon alles ausprobiert was dort geposted wurde, auch habe ich abwechseln Grub und Lilo installiert und deinstalliert und dabei die verschiedensten Konfigurationen getestet. Leider kein Erfolg.

Logfiles werden nicht erstellt. Das boot.log bleibt mit 0 byte auf dem Server. Ein anzeichen dafür dass der Bootloader nicht läuft?

Danke für evtl. Antworten (:

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: kein boot nach Kernel Update (&und ich bin heute dämlich

Post by captaincrunch » 2004-07-03 08:27

Wie ich bereits im anderen Thread schon sagte: lass die Kiste reinitialisieren, da sie in ihrem geknackten Zustand eine Gefahr für dich (was mir ja noch egal wäre) und andere darstellt.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

jakob2002
Posts: 34
Joined: 2004-01-01 13:38

Re: kein boot nach Kernel Update (&und ich bin heute dämlich

Post by jakob2002 » 2004-07-04 23:02

Hi,

Ich habe grad ein dickes Problem: Ich habe gerade eine Yast Online Update bei SUSE 9.1 gemacht und habe auch den Sicherheitspatch für den Kernel ausgewählt. Normal klappt ja alles deswegen habe ich auch nicht lange gedacht und kein Backup vom Kernel erstellt.

Problem ist jetzt, dass der Server mit dem Kernel nicht bootet. Hinzu kommt noch, dass Strato mal wieder Probs macht und die Serielle Konsole nicht ganz funktioniert (ich kann mich nicht einloggen).

Kann mir jemand sagen ob YOU ein automatisches Backup erstellt oder wie ich die Kiste wieder zum Laufen bekomme?

jakob2002
Posts: 34
Joined: 2004-01-01 13:38

Re: kein boot nach Kernel Update (&und ich bin heute dämlich

Post by jakob2002 » 2004-07-05 15:46

So, ich habe jetzt über das Rescue Sytem einen neuen Kernel kompiliert. Allerdings werden bei mir in der Seriellen Konsole gar keine Boot-Messages mehr angezeigt und in der boot-Logdatei steht auch nichts mehr von Programmen die gestertet wurden.

Hat da jemand ein gutes Kernel HowTo bzw. weiß wer, warum die Serielle Konsole nichts mehr anzeigt?