rpm fehler beim installieren

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
lines
Posts: 55
Joined: 2002-10-05 20:38

rpm fehler beim installieren

Post by lines » 2004-06-12 15:00

hallo

ich schätze mal ich habe was mit meinen RPM Dateien verbockt

wenn ich ein Pcket installieren will kommt:

rantanplan:~/yast # rpm -i yast2-agent-any-2.5.9-36.i386.rpm
error: failed dependencies:
ld-linux.so.2 is needed by yast2-agent-any-2.5.9-36
libc.so.6 is needed by yast2-agent-any-2.5.9-36
libc.so.6(GLIBC_2.0) is needed by yast2-agent-any-2.5.9-36
libc.so.6(GLIBC_2.1) is needed by yast2-agent-any-2.5.9-36
libc.so.6(GLIBC_2.1.3) is needed by yast2-agent-any-2.5.9-36

rantanplan:~/yast # locate libc.so.6
/lib/libc.so.6
/usr/lib/libc.so.6
rantanplan:~/yast #

wieso kann er z.b. die libc.so.6 nicht finden ?


also die Vorgeschichte ist das ich Yast neu installieren wollte, aber nur fehlermeldungen bekam, also habe ich alles deinstalliert. und nun bekomme ich yast nicht wieder drauf.
unmöglich
auch habe ich apt drauf installiert um damit mehr Erfolg zu haben.
dem war nicht so.

rantanplan:~/yast # apt-get install yast2
Reading Package Lists... Done
Collecting File Provides... Error!
E: could not open RPM package list file /var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_8.0-i386_base_pkglist.packman-i386:
E: Problem opening /var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_8.0-i386_base_pkglist.packman-i386
E: The package lists or status file could not be parsed or opened.


hat den wer ein rat?

achja rpm --initdb und rebuild habe isch schon durch

danke.lines

lines
Posts: 55
Joined: 2002-10-05 20:38

Re: rpm fehler beim installieren

Post by lines » 2004-06-12 15:25

nanu

kein perl mehr oben ?!

rantanplan:~/yast/neu # rpm -Uhv glibc-2.2.5-177.i386.rpm
error: failed dependencies:
/bin/sh is needed by glibc-2.2.5-177
/usr/bin/perl is needed by glibc-2.2.5-177
rantanplan:~/yast/neu # which perl
/usr/bin/perl


wo ist denn da der Hund begraben ?

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: rpm fehler beim installieren

Post by oxygen » 2004-06-12 16:20

Deine Paketdatenbank ist kaputt.

lines
Posts: 55
Joined: 2002-10-05 20:38

Re: rpm fehler beim installieren

Post by lines » 2004-06-13 21:25

hmmm.. aha dachte ich mir.

und wie könnte ich es wieder herstellen ?
ist denn dafür nicht rpm --initdb und rebuild zuständig ?

danke.lines

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: rpm fehler beim installieren

Post by captaincrunch » 2004-06-13 23:07

Code: Select all

rm -f /var/lib/rpm/__* ; rpm -vv --rebuilddb
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

splacknuck
Posts: 22
Joined: 2003-10-31 19:46
Location: München

Yast / RPM DB im Eimer

Post by splacknuck » 2005-01-17 14:30

CaptainCrunch wrote:

Code: Select all

rm -f /var/lib/rpm/__* ; rpm -vv --rebuilddb
Gnn. Hab nicht richtig gelesen und alles aus /var/lib/rpm gelöscht.

Jetzt wissen weder Yast noch RPM was alles installiert ist. Vergleiche ich die Dateien in /var/lib/rpm vorher und nachher, fällt mir auf, dass packages.rpm viel zu klein ist.

Wie krieg ich das wieder hingebogen? Krieg ich das wieder hingebogen?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: rpm fehler beim installieren

Post by captaincrunch » 2005-01-17 14:33

Wohl dem, der regelmäßig Backups anlegt...
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

splacknuck
Posts: 22
Joined: 2003-10-31 19:46
Location: München

Re: rpm fehler beim installieren

Post by splacknuck » 2005-01-17 15:15

CaptainCrunch wrote:Wohl dem, der regelmäßig Backups anlegt...
Danke!

Backups lege ich täglich an, aber nicht von /var/lib.

Also futsch?

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: rpm fehler beim installieren

Post by chris76 » 2005-01-17 15:25

splacknuck wrote:Also futsch?
Ja, außer es war eine Virutelle Maschine mit Undo Laufwerk.
Gruß Christian

BofH excuses: YOU HAVE AN I/O ERROR -> Incompetent Operator error