php, `phpize' failed (beim Installieren eines PECL Moduls)

Bash, Shell, PHP, Python, Perl, CGI
webs
Posts: 16
Joined: 2004-05-28 14:26

php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by webs »

Hallo Leute!

keine Ahnung ob das wirklich hierhin gehört. Ich schreibe mal und Mods könne ja sehen ob das richtig ist. :wink:

Folgendes Problem:
Bin schon seit einigen Tagen nach einer Lösung unterwegs. Und zwar, als Anfangsziel war eine Horde-Installation. Wie man so weiss Horde braucht PEAR und einige Module.
Eines davon ist z. B. Auth welches ebenfalls ein paar andere PECL Module braucht unter anderem "radius".
Nun nach einem Kommando "pear install radius" meckert er plötzlich:

running: phpize
Configuring for:
PHP Api Version: xxxxxxxx
Zend Module Api No: xxxxxxxx
Zend Extension Api No: xxxxxxxx
`phpize' failed

Ok, ich habe google abgeklapper und ein paar Bemerkungen aber keine wirkliche Lösung gefunden. Einige meinten die PHP 4.3.3 (cgi) soll ein fehler in phpize haben. Andere meinen es ist das Extension-Directory, was richtig gesetzt werden soll...

Bisher habe ich mir nicht getraut PHP neuzuübersetzen da es ein laufendes System ist.

Die Extension-Directory steht in der php.ini auf:
extension_dir = "./"
extension_dir = /usr/share/extensions/no-debug-non-zts-20020429

Welches extension_dir soll bei PEAR eingetragen werden? Also das PEAR-Pfad (bei mir /usr/share/php) bewirkt gar nichts. Genauso /usr/include/php/ext
Liegt es überhaupt an diesem Pfad?
Wie kann ich phpize überreden dass sie gesprächiger wird und mir bisschen mehr Info ausgibt?

Viele Dank für's Zuhören, hm, Lesen meine ich :-D
Roman

PS: habe übrigens SuSE 9.0 am Laufen
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by Joe User »

Code: Select all

include_path = ".:/usr/share/php"
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
webs
Posts: 16
Joined: 2004-05-28 14:26

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by webs »

daran liegt es nicht...
caddata
Posts: 5
Joined: 2004-06-13 02:35
Location: Bremerhaven

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by caddata »

Hallo webs,

probiers mal so:

Code: Select all

pear download radius
tar xvfz radius-1.2.4.tgz
cd radius-1.2.4
phpize
./configure
make
make install
Bei mir hat pear install auch immer gemeckert - aber zu Fuß ging es dann... :-D

Grüße,
Marco
webs
Posts: 16
Joined: 2004-05-28 14:26

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by webs »

Caddata wrote:Hallo webs,

probiers mal so:

Code: Select all

pear download radius
tar xvfz radius-1.2.4.tgz
cd radius-1.2.4
phpize
./configure
make
make install
Bei mir hat pear install auch immer gemeckert - aber zu Fuß ging es dann... :-D

Grüße,
Marco
jo, danke Marco, ich habe dies genauso schon gelöst :-D
noch ein Problem war bei mir das Pear es nicht fand, dann half nur das eine:
"pear install --register-only radius" ausführen.

Gruß,
Roman
umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by umbroboy »

Hallo,

wollte dies auf dem selben weg installieren.

Bei mir findet er allerdings phpize nicht.

Code: Select all

-bash: phpize: command not found
:-(
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by Joe User »

php-devel installiert?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: php, `phpize' failed (beim Installieren eines PECL Moduls)

Post by umbroboy »

Hallo,

hatte zuvor Debian, da wusst ich wo ich nachschau bzw. wie ich es installier.

aber jetzt hab ich Suse 9.

Ich denk das müsst ich in Yast2 finden oder?