Apt-Get zickt rum

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
braincrusher
Posts: 4
Joined: 2004-06-08 20:48

Apt-Get zickt rum

Post by braincrusher » 2004-06-08 20:56

Also ich habe jetzt meinen rootserver so einigermassend fertig eingerichtet
php mysql und das sorgenkind mailserver laufen...zuerst mit exim gespielt dann letztendlich doch mittels qmailrocks installiert...beim de-installieren von exim und postfix (beides getestet) wurde ich bei apt-get gewzungen die courier-imap und ssl mit zu entfernen, gut hab ich sie eben neu installiert...

Nun wollte ich für ein Programm namens mywitch womit man beqäum auch grössere datenbank sichern und woanders einspielen kann, bräuchte meine php version das myrypt modul...siehe hier suchfunktion apt-get blablala...
jo

Ich wollte es dann auch per apt-get install installieren da kam folgende fehlermeldung:
debian:~# apt-get install php4-mcrypt
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
courier-imap: Depends: exim or
mail-transport-agent
courier-imap-ssl: Depends: exim or
mail-transport-agent
php4-mcrypt: Depends: libltdl3 (>= 1.5.2-2) but it is not going to be installed
Depends: libmcrypt4 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
debian:~#

Der ist schon lustig, erstens ist courier-imap instalilert zweitens mit qmail ich brauche also kein exim oder mail-transport-agent und driggens möchte ich doch nur das php-modul und nicht irgendwelche ausweich pakete wie libtdl3 die er dann doch nicht per apt-get installieren möchte...

Wenn ich apt-get upgrade starte möchte er auch immer wieder exim und sein mailtransportagent mitinstallieren, das nervt, wie kann ich das abstellen?

braincrusher
Posts: 4
Joined: 2004-06-08 20:48

Re: Apt-Get zickt rum

Post by braincrusher » 2004-06-08 21:02

Wenn ich exim (garnicht installiert) auf hold setzen möchte in der hoffnung, er würde das paket nichtmehr beachten, möchte er dann gleich courier-imap und ssl deinstalieren, :(

braincrusher
Posts: 4
Joined: 2004-06-08 20:48

Re: Apt-Get zickt rum

Post by braincrusher » 2004-06-08 21:05

Ich hab ihm sein exim mal installieren, lassen lol nun konnte ich zwar libmcrypt4 per apt-get installieren, aber habe wieder exim und per dpkg --remove bekomme ich es nicht entfernt :(.

Naja solange ich es nicht sarte und es nicht in der init.d eingetragen ist, liegt es nur dumm rum (ich habe bei der installation no configuration gewählt)

wirsing
RSAC
Posts: 611
Joined: 2002-11-20 21:32
Location: Vaihingen und Karlsruhe

Re: Apt-Get zickt rum

Post by wirsing » 2004-06-08 21:17

Da du einen MTA (qmail) installiert hast, aber nicht über die Paketverwaltung eingetragen hast, musst du das eben derselben noch bekannt machen.
Schau dir equivs an und baue ein Paket mit

Code: Select all

Provides: mail-transport-agent