yast Fehler nach Systemabsturz (Suse 9.0)

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
der_kommander
Posts: 7
Joined: 2004-03-26 11:40

yast Fehler nach Systemabsturz (Suse 9.0)

Post by der_kommander »

Habe in Yast das Modul screen nachinstalliert. Während der Installation ist der Server abgestürzt und mir blieb nichts anderes als ein Reset per Adminoberfläche übrig.
Nach dem Reset ist ein Aufruf von Yast nicht mehr möglich.

Fehlermeldung: /sbin/yast: line 184: 1436 Speicherzugriffsfehler $ybindir/y2base menu ncurses


Kennt jemand eine Möglichkeit wie deises Problem zu lösen ist?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11147
Joined: 2003-02-27 01:00
Location: Hamburg

Re: yast Fehler nach Systemabsturz (Suse 9.0)

Post by Joe User »

YaST und gegebenenfalls auch ncurses reinstallieren.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

der_kommander
Posts: 7
Joined: 2004-03-26 11:40

Re: yast Fehler nach Systemabsturz (Suse 9.0)

Post by der_kommander »

thx, hat funktioniert.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

suse 9.1 Fehler -> $ybindir/y2base menu ncurses

Post by blnsnoopy26 »

Hi,

Sorry das ich den Thread noch einmal rauskrame, aber man sagt ja man soll die Suchfunktion nutzen und da habe ich diesen Thread hier gefunden und Antworte auch einmal darauf.

Und zwar auf meinem SuSE 9.1 system kommt nun auch der Fehler:

$ybindir/y2base menu ncurses

Nachdem ich seit 6 stunden zich foren durchgelesen habe und ich yast mind. 5 mal neu installiert habe ohne jegliche veränderung - so wende ich mich an euch, um zu fragen, was man da jetzt noch machen kann?

System ist ein Server von 1&1 mit Suse 9.1.

Hier die installierten packages:

Code: Select all

 rpm -qa | sort | grep yast2
autoyast2-installation-2.9.34-1
yast2-2.9.60-5
yast2-bootloader-2.9.22-1
yast2-control-center-2.9.11-3
yast2-core-2.9.79-3
yast2-core-devel-2.9.79-3
yast2-country-2.9.19-9
yast2-debugger-2.9.2-11
yast2-devel-2.9.60-5
yast2-installation-2.9.57-1
yast2-kerberos-client-2.9.8-14
yast2-ldap-2.9.10-10
yast2-mouse-2.9.10-10
yast2-ncurses-2.9.20-3
yast2-network-2.9.32-1
yast2-nis-client-2.9.15-11
yast2-online-update-2.9.11-3
yast2-packagemanager-2.9.37-0
yast2-packagemanager-devel-2.9.37-0
yast2-packager-2.9.43-3
yast2-pam-2.9.10-9
yast2-perl-bindings-2.9.25-8
yast2-printer-2.9.23-1
yast2-profile-manager-2.9.7-11
yast2-qt-2.9.21-0
yast2-slp-2.9.9-2
yast2-sound-2.9.19-4
yast2-storage-2.9.37-0
yast2-sysconfig-2.9.14-10
yast2-theme-SuSELinux-2.9.9-6
yast2-trans-de-2.9.15-1
yast2-trans-en_US-2.9.5-5
yast2-transfer-2.9.2-10
yast2-trans-zh_CN-2.9.3-5
yast2-trans-zh_TW-2.9.1-5
yast2-tune-2.9.20-10
yast2-update-2.9.23-2
yast2-users-2.9.27-1
yast2-x11-2.9.9-10
yast2-xml-2.9.8-10
Also es ist alles da was benötigt wird, aber wie gesagt erscheint diese Fehlermeldung nur, wenn ich über yast software installieren oder deinstallieren möchte.

suseconfig lief auch ohne fehler durch:

Code: Select all

 SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.alljava...
Executing /sbin/conf.d/SuSEconfig.apache2...
Looking for multi-processing modules (MPM)...
  3 MPM installed (prefork prefork_old worker)
  APACHE_MPM is unset (/etc/sysconfig/apache2), picked "prefork"
  create symbolic link `/usr/sbin/httpd2' to `/usr/sbin/httpd2-prefork'
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft ...............
Creating fonts.{scale,dir} files .....
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.named...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Executing /sbin/conf.d/SuSEconfig.postfix...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.scpm...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Finished.
Wie gesagt habe jetzt paar stunden auf dem buckel und bin google einmal hoch und einmal runter, aber ohne Erfolg. Ihr seit jetzt die letzte Hoffnung.

thx im voraus.