problem bei build von imap-server

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
palme
Posts: 16
Joined: 2004-04-26 20:49

problem bei build von imap-server

Post by palme » 2004-06-03 22:19

Hi,

ich habe mehrfach versucht den IMAP-Server nach dem Debian-Howto aufzusetzen.
(http://www.debianhowto.de/howtos/de/qma ... il_MTA.htm)
Leider klappt das Compilieren nicht. Es kommt immer folgende Fehlermeldung:
rootserver:/usr/local/sourcendebs/courier-ssl-0.37.3# dpkg-buildpackage -us -uc -rfakeroot
....
dh_shlibdeps
dh_gencontrol -Ncourier-imap-ssl -- -VRELUP="0.37.3"
dpkg-gencontrol: warning: unknown substitution variable ${shlibs:Depends}
dh_gencontrol -pcourier-imap-ssl -- -VRELUP="0.37.3" -v1.4.3-3
dh_md5sums
dh_builddeb
dpkg-deb: building package `courier-ssl' in `../courier-ssl_0.37.3-3_i386.deb'.
dpkg-deb: building package `courier-mta-ssl' in `../courier-mta-ssl_0.37.3-3_i386.deb'.
dpkg-deb: building package `courier-pop-ssl' in `../courier-pop-ssl_0.37.3-3_i386.deb'.
dpkg-deb: building package `courier-imap-ssl' in `../courier-imap-ssl_1.4.3-3_i386.deb'.
dpkg-deb: building package `courier-authpostgresql' in `../courier-authpostgresql_0.37.3-3_i386.deb'.
dpkg-genchanges
dpkg-genchanges: not including original source code in upload
dpkg-buildpackage: binary and diff upload (original source NOT included)

Die nötigen Packages werden zwar erstellt, aber eine Authentifizierung ist nicht möglich. Dan dies die einzige Fehlermeldung ist, scheint es hieran zu liegen.
Woran kann das liegen?

Gruß
Palme

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: problem bei build von imap-server

Post by captaincrunch » 2004-06-03 22:24

Blöde Frage: Hast du die Pakete denn überhaupt installiert?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

palme
Posts: 16
Joined: 2004-04-26 20:49

Re: problem bei build von imap-server

Post by palme » 2004-06-03 22:42

ich denke doch.
Die Pakete habe ich soweit im howto erwähnt installiert. Die Pakete zum compilieren habe ich laut howto die sourcen installiert und die Pakete erstellt.
Diese werden auch compiliert, jedoch läuft die authentifizierung nicht, was auf einen Fehler hindeutet. Die gepostete Fehlermeldung ist die einzige, die mir auffällt.
Diese tritt ähnlich auf, wenn ich laut Howto den 2. Teil baue.