Mehrere Pearl versionen.

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
snatch
Posts: 19
Joined: 2004-02-25 17:49

Mehrere Pearl versionen.

Post by snatch » 2004-06-02 18:41

Hallo,

Ich habe bei der Installation von Spamassassin diesen Fehler

Code: Select all

Wo liegt das SpamAssassin stop/start Script? [/etc/init.d/spamd]: /usr/local/bin/spamd
Auswahl: /usr/local/bin/spamd


Erstelle Datei: "/root/confixx/confixx_main.conf"
Kopiere Datei: "/etc/mail/spamassassin/local.cf" --> "/root/confixx/backup/spamassassin/local.cf"
HTML::Parser version 3.24 required--this is only version 3.10 at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/HTML.pm line 7.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/HTML.pm line 7.
Compilation failed in require at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/PerMsgStatus.pm line 42.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/PerMsgStatus.pm line 42.
Compilation failed in require at /usr/local/share/perl/5.6.1/Mail/SpamAssassin.pm line 62.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.6.1/Mail/SpamAssassin.pm line 62.
Compilation failed in require at /usr/local/bin/spamd line 33.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 33.
HTML::Parser version 3.24 required--this is only version 3.10 at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/HTML.pm line 7.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/HTML.pm line 7.
Compilation failed in require at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/PerMsgStatus.pm line 42.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.6.1/Mail/SpamAssassin/PerMsgStatus.pm line 42.
Compilation failed in require at /usr/local/share/perl/5.6.1/Mail/SpamAssassin.pm line 62.
BEGIN failed--compilation aborted at /usr/local/share/perl/5.6.1/Mail/SpamAssassin.pm line 62.
Compilation failed in require at /usr/local/bin/spamd line 33.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 33.

Erstelle Datei: "/root/confixx/confixx_main.conf"
Es ist aber eindeutig Version 3.25 Inslattiert. Nun habe ich aber so wie es aussieht zug Perl versionen drauf jedoch wird genau diese Verwendet die nicht von APT-GET UPGRADE auf den neusten Stand gebracht wurde.

Wie und wo kann ich einstellen das Debian eben eine andere Perl version aus einem anderen Verzeichniss nimmt ?

Wie ?

Danke euch.

snatch
Posts: 19
Joined: 2004-02-25 17:49

Re: Mehrere Pearl versionen.

Post by snatch » 2004-06-03 12:48

Weiß denn echt keiner Rat ?

Wo steht wenn warauf Debian zugreift wenn man einen perl befehl benutzt ?