Zwei qmail Sachen (symlinks + qmailmrtg7/SpamAssassin)

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
funnydingo
Posts: 160
Joined: 2002-12-07 14:40
Location: Münster

Zwei qmail Sachen (symlinks + qmailmrtg7/SpamAssassin)

Post by funnydingo » 2004-05-22 21:07

Hallo zusammen,

ich habe in den letzten Tagen ein wenig an meinem qmail geändert. netqmail-1.05 mit ein paar Patches installiert, von "einfachen" tcpserver auf daemontools umgestellt, qmail-scanner rein und SpamAssassin rein.

Das funktioniert bisher auch alles wunderbar. Nun vollte ich ein paar kleine Ã?nderungen an der Verzeichnisstruktur machen. ./controls ist schon immer symlink nach /etc/qmail gewesen. Zudem habe ich heute ./queue nach /var/spool/qmailqueue verschoben und ./queue als symlink eingerichtet. Wenn ich jetzt aber qmail-qread aufrufe, bekomme ich keine Ausgabe, obwohl qmail-qstat mir sagt, das 2 Mails in der queue sind. Das verstehe ich nicht so ganz. Hat jemand eine Idee was es sein kann?

Außerdem habe ich qmailmrtg7 installiert. Ich hätte auch gerne die Auswertung für Spam, aber die Werte bleiben immer auf 0! Ich habe SpamAssassin zur Zeit mit --debug laufen und schicke den Output nach /var/log/spamd.log. Ich habe für qmailmrtg7 ein Verzeichnis "spamd" erstellt mit "current" als symlink auf "../spamd.log". Leider gibt sich qmailmrtg7 damit nicht zu frieden. Es ist das falschen Log? Die Doku zu qmailmrtg7 ist da ja ziemlich sperlich :-/

Gruß, Danke schon mal im voraus!


Funny

funnydingo
Posts: 160
Joined: 2002-12-07 14:40
Location: Münster

Re: Zwei qmail Sachen (symlinks + qmailmrtg7/SpamAssassin)

Post by funnydingo » 2004-05-23 05:23

Also das Problem mit der queue hat sich erledigt. Mir ist aufgefallen das die queue nur ca. alle 30 min ausgeführt wird. Habe den symlink gelöscht und vom installer das Verzeichnis neu anlegen lassen und alles funktioniert.

Das Problem mit SpamAssassin und qmailmrtg7 besteht jedoch weiterhin. Ich habe auch ein neues Problem mit SpamAssassin.
debug: mkdir Error: unable to setuid/.spamassassin failed: Insecure dependency in mkdir while running with -T switch at /usr/lib/perl5/5.8.0/File/Path.pm line 147, <GEN3> line 151.
No such file or directory

debug: open of AWL file failed: lock: 13868 cannot create tmp lockfile Error: unable to setuid/.spamassassin/auto-whitelist.lock.SERVERNAME.13868 for Error: unable to setuid/.spamassassin/auto-whitelist.lock: No such file or directory
Auf welches Verzeichnis will der denn da zugreifen? Ich hatte das Problem heute Mittag schon mal. Da konnte ich es lösen in dem ich für den User spamd (--username=spamd) ein HomeDir definiert und angelegt habe. Aber irgendwann tauchte die Meldung wieder auf :-(