Postfix leitet Mails nicht weiter

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
xyloid
Posts: 27
Joined: 2003-11-16 09:27

Postfix leitet Mails nicht weiter

Post by xyloid » 2004-05-20 09:49

Hallo

Ich wollte Postfix so einrichten, dass wenn man eine Mail an nico@meinedomain.de sendet, Postfix diese an meine @web.de Adresse weiterleitet nur irgendwie funktioniert das nicht so recht.

meine /etc/aliases:

Code: Select all

nico: meineadresse@web.de
root: meineadresse@web.de
postconf -n

Code: Select all

allow_untrusted_routing = no
append_at_myorigin = yes
append_dot_mydomain = yes
bounce_size_limit = 10000
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
default_recipient_limit = 100
disable_dns_lookups = no
html_directory = no
mail_owner = postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/local/man
minimal_backoff_time = 600s
mydestination = $myhostname, localhost.$mydomain
mydomain = meinedomain.de
myhostname = meinedomain.de
mynetworks = 127.0.0.1
myorigin = $myhostname
newaliases_path = /usr/bin/newaliases
qmgr_fudge_factor = 70
qmgr_message_active_limit = 3000
queue_directory = /var/spool/postfix
readme_directory = no
sample_directory = /etc/postfix
sendmail_path = /usr/sbin/sendmail
setgid_group = postdrop
smtp_destination_concurrency_limit = 4
smtpd_banner = $myhostname ESMTP
smtpd_recipient_restrictions = reject_unknown_hostname, reject_unknown_sender_domain, reject_non_fqdn_sender, reject_unauth_destination
unknown_local_recipient_reject_code = 450
die entsprechen zeilen im log dazu:

Code: Select all

May 20 09:30:05 m8s27 postfix/smtpd[12656]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
May 20 09:30:05 m8s27 postfix/smtpd[12656]: connect from smtp05.web.de[217.72.192.209]
May 20 09:30:05 m8s27 postfix/smtpd[12656]: 1A7CF6E: client=smtp05.web.de[217.72.192.209]
May 20 09:30:05 m8s27 postfix/cleanup[12659]: 1A7CF6E: message-id=<40AC5F47.9010706@web.de>
May 20 09:30:05 m8s27 postfix/qmgr[12474]: 1A7CF6E: from=<meineadresse@web.de>, size=858, nrcpt=1 (queue active)
May 20 09:30:05 m8s27 postfix/local[12660]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
May 20 09:30:05 m8s27 postfix/cleanup[12659]: 20B429F: message-id=<40AC5F47.9010706@web.de>
May 20 09:30:05 m8s27 postfix/qmgr[12474]: 20B429F: from=<meineadresse@web.de>, size=987, nrcpt=1 (queue active)
May 20 09:30:05 m8s27 postfix/local[12660]: 1A7CF6E: to=<nico@meinedomain.de>, relay=local, delay=0, status=sent (forwarded as 20B429F)
May 20 09:30:05 m8s27 postfix/qmgr[12474]: 1A7CF6E: removed
May 20 09:30:05 m8s27 postfix/smtpd[12656]: disconnect from smtp05.web.de[217.72.192.209]
May 20 09:30:05 m8s27 postfix/smtp[12661]: 20B429F: to=<meineadresse@web.de>, orig_to=<nico@meinedomain.de>, relay=mx-ha01.web.de[217.72.192.149], delay=0, status=sent (250 OK id=)
May 20 09:30:05 m8s27 postfix/qmgr[12474]: 20B429F: removed
nach den logmeldungen hätte ich vermutet, das alles klappen würde, es kömmen aber keine mails bei meiner @web.de adresse an.

mails, die ich direkt auf dem system abgeschickt werden, z.b. von cron kommen komischerweise an...

Nico

xyloid
Posts: 27
Joined: 2003-11-16 09:27

Re: Postfix leitet Mails nicht weiter

Post by xyloid » 2004-05-21 19:53

Ich habe jetzt durch Zufall herausgefunden, dass nur Mails, die über web.de geschickt werden, nicht ankommen.

Wenn ich von Yahoo oder Hotmail eine Mail an nico@meinedomain.de schicke, kommt diese Mail wie gewünscht in meinem web.de Postfach an.

Insofern vermute ich mal, liegt das Problem nicht an meiner Postfix Konfiguration und Postfix leitet die Mail wie gewünscht weiter.

Aber warum kommen die über web.de abgeschickten Mails nicht an?
Blockiert web.de Mails, die von web.de abgeschickt wurden und durch meinen Server wiederum an eine web.de adresse weitergeleitet werden sollen?

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Postfix leitet Mails nicht weiter

Post by wgot » 2004-05-21 23:26


Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Postfix leitet Mails nicht weiter

Post by Matthias Diehl » 2004-05-22 01:59

Evtl. hat web.de SPF laufen und Dein Rechner ist bestimt kein offizieller Host um mit dem Absender @web.de versenden zu dürfen.

xyloid
Posts: 27
Joined: 2003-11-16 09:27

Re: Postfix leitet Mails nicht weiter

Post by xyloid » 2004-05-22 07:39

hab die lösung gestern abend schon herausgefunden:

http://freemail.web.de/reject/

Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Postfix leitet Mails nicht weiter

Post by Matthias Diehl » 2004-05-22 12:55

sag ich doch :)