Server "hängt"

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
pf4
Posts: 91
Joined: 2002-12-09 10:27

Server "hängt"

Post by pf4 » 2004-05-16 09:42

Hallo,

folgendes Problem:

seit kurzen Zeigt der Server ein "komisches" verhalten. Er läuft zwar noch d.h Pingpar und die Dienste antworten zwar noch auf einen Connect brechen dann aber die Verb. ab. Genau zu diesem Zeitpunkt hören ALLE Logs einfach auf. Das ganze ist jetzt genau 2 Mal innerhalb von 3 Tagen passiert. Der Server ist sonst noch nie abgeschmiert.

Debian 3.0_r2
Rootforums CC 2.4.26_ipv6 Kernel lief voher auch schon ein weilchen

Logs o.ä

allmessages (alle Logs in einem)

Code: Select all

May 16 05:00:01 vadp /USR/SBIN/CRON[7927]: (root) CMD (wget -q http://localhost/split/split_tsc.php -O /var/www/html/split/muell)
May 16 05:00:01 vadp PAM_unix[7925]: (cron) session opened for user root by (uid=0)
May 16 05:00:01 vadp /USR/SBIN/CRON[7928]: (root) CMD (/etc/webmin/webalizer/webalizer.pl /home/apache_user/logs/access_log)
May 16 05:00:01 vadp PAM_unix[7926]: (cron) session opened for user root by (uid=0)
May 16 05:00:01 vadp /USR/SBIN/CRON[7929]: (root) CMD (yasuc)
May 16 05:00:01 vadp /USR/SBIN/CRON[7930]: (root) CMD (/etc/webmin/webalizer/webalizer.pl /var/log/apache/access_log)
May 16 05:00:02 vadp PAM_unix[7924]: (cron) session closed for user root
May 16 05:00:03 vadp yasuc[7929]: Transfer successful
May 16 05:00:03 vadp PAM_unix[7925]: (cron) session closed for user root
May 16 05:00:08 vadp PAM_unix[7926]: (cron) session closed for user root
May 16 05:00:18 vadp PAM_unix[7923]: (cron) session closed for user root
May 16 05:03:42 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:08:43 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:13:45 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:15:01 vadp PAM_unix[8084]: (cron) session opened for user root by (uid=0)
May 16 05:15:01 vadp /USR/SBIN/CRON[8085]: (root) CMD (wget -q http://localhost/split/split_tsc.php -O /var/www/html/split/muell)
May 16 05:15:16 vadp PAM_unix[8084]: (cron) session closed for user root
May 16 05:18:46 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:23:47 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:28:48 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:30:01 vadp PAM_unix[8212]: (cron) session opened for user root by (uid=0)
May 16 05:30:01 vadp /USR/SBIN/CRON[8213]: (root) CMD (wget -q http://localhost/split/split_tsc.php -O /var/www/html/split/muell)
May 16 05:30:16 vadp PAM_unix[8212]: (cron) session closed for user root
May 16 05:33:50 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:37:01 vadp PAM_unix[8259]: (cron) session opened for user root by (uid=0)
May 16 05:37:01 vadp /USR/SBIN/CRON[8260]: (root) CMD (/usr/lib/AntiVir/antivir --update -q)
May 16 05:37:02 vadp antivir[8260]: AntiVir is up-to-date
May 16 05:37:02 vadp PAM_unix[8259]: (cron) session closed for user root
May 16 05:38:51 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:43:52 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
May 16 05:45:01 vadp PAM_unix[8352]: (cron) session opened for user root by (uid=0)
May 16 05:45:01 vadp /USR/SBIN/CRON[8353]: (root) CMD (wget -q http://localhost/split/split_tsc.php -O /var/www/html/split/muell)
May 16 05:45:16 vadp PAM_unix[8352]: (cron) session closed for user root
May 16 05:48:53 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
Dann noch nen lspci

Code: Select all

  Bus  0, device   0, function  0:
    Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 5).
      Master Capable.  Latency=8.
      Prefetchable 32 bit memory at 0xe0000000 [0xe3ffffff].
  Bus  0, device   1, function  0:
    PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP] (rev 0).
      Master Capable.  No bursts.  Min Gnt=12.
  Bus  0, device   7, function  0:
    ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 64).
  Bus  0, device   7, function  1:
    IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 6).
      Master Capable.  Latency=32.
      I/O at 0xe000 [0xe00f].
  Bus  0, device   7, function  4:
    Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 64).
      IRQ 9.
  Bus  0, device  13, function  0:
    Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 16).
      IRQ 15.
      Master Capable.  Latency=32.  Min Gnt=32.Max Lat=64.
      I/O at 0xec00 [0xecff].
      Non-prefetchable 32 bit memory at 0xe7000000 [0xe70000ff].
  Bus  1, device   0, function  0:
    VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 106).
      IRQ 11.
      Master Capable.  Latency=32.
      Non-prefetchable 32 bit memory at 0xe5800000 [0xe5ffffff].
      Non-prefetchable 32 bit memory at 0xe6000000 [0xe601ffff].
      Non-prefetchable 32 bit memory at 0xe5000000 [0xe57fffff].
PS: Rootserver Start

THX in vorraus

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Server "hängt"

Post by sascha » 2004-05-16 15:02

Könnte (neben allem anderen *g*) die Festplatte sein. Hast du diesbezüglich Warnungen in den Logs? Ich würde mal Smartmontools installieren (apt-get install smartsuite). Evtl. auch noch mbmon / lm-sensors.

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Server "hängt"

Post by oxygen » 2004-05-16 15:06

Das häufige auftreten von:
May 16 05:48:53 vadp init: Id "SV" respawning too fast: disabled for 5 minutes
find ich seltsam, vorallem sagt mir persönlich SV nichts.

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Server "hängt"

Post by sascha » 2004-05-16 15:14

Das ist afaik so ein seltsames Script in den alten 1&1 Images welches in der inittab eingetragen ist.

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-16 15:21

Sascha wrote:Das ist afaik so ein seltsames Script in den alten 1&1 Images welches in der inittab eingetragen ist.
Auf einem Debian rooty ?. 1und1 hat da null mit zu tun
Ne das hat irgendwas mti Qmail zu tun. Steht ja hier irgenwo im Forum.
An die Platte dachte ich auch erst, aber im Logs ist 0 zu finden.

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Server "hängt"

Post by sascha » 2004-05-16 15:32

Jo sorry, das hatte ich verwechselt... du hast ja gar kein 1&1 Image ;) Auf den SuSE Images gabs hin und wieder diese Meldung

Code: Select all

nit: Id "T0" respawning too fast: disabled for 5 minutes

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-23 19:17

Also nach etwas Laufzeit, trat doch glatt das auf was ich befürchtete

M

Code: Select all

ay 22 09:36:32 vadp kernel: hda: dma_timer_expiry: dma status == 0x20
May 22 09:36:32 vadp kernel: hda: (__ide_dma_test_irq) called while not waiting
May 22 09:36:32 vadp kernel: hda: status timeout: status=0xd0 { Busy }
May 22 09:36:32 vadp kernel:
May 22 09:36:32 vadp kernel: ide0: reset: success
May 22 09:37:02 vadp antivir[18474]: AntiVir is up-to-date
May 22 09:38:16 vadp kernel: hda: dma_timer_expiry: dma status == 0x21
May 22 09:38:26 vadp kernel: hda: dma timeout retry: status=0xd0 { Busy }
May 22 09:38:26 vadp kernel:
May 22 09:38:26 vadp kernel: hda: DMA disabled
May 22 09:38:49 vadp kernel: ide0: reset: success
May 22 09:42:27 vadp kernel: hda: dma_timer_expiry: dma status == 0x20
May 22 09:42:27 vadp kernel: hda: (__ide_dma_test_irq) called while not waiting
May 22 09:42:27 vadp kernel: hda: status timeout: status=0xd0 { Busy }
May 22 09:42:27 vadp kernel:
May 22 09:42:57 vadp kernel: ide0: reset timed-out, status=0xd0
May 22 09:42:57 vadp kernel: hda: status timeout: status=0xd0 { Busy }
May 22 09:42:57 vadp kernel:
May 22 09:43:07 vadp kernel: ide0: reset: success
Um der Sache vorzubeugen nein um die Zeit laufen keine Crons.
Na dann wars wohl doch die Platte.

Um die Zeiten war nix besonderes auf dem Server los.

Gerade mal 20 Querys pro Sec in der DB

Load 0.05

Na mal bei 1und1 Anfragen. Sollte jemmand nen anderen Grund kennen, nur raus damit

compositiv
Posts: 193
Joined: 2003-01-22 14:58
Location: Hamburg

Re: Server "hängt"

Post by compositiv » 2004-05-24 12:34

Platte tauschen lassen, ist vermutlich gerade am abrauchen.

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-24 12:51

Jo ich mache nen Komplett Backup und lasse tauschen.

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-26 12:40

Toll, was muss man den tun das die ihren .......... bewegen und die Platte tauschen ?

Was würdet ihr sagen was diese Meldungen alle bedeuten

Code: Select all

kern.log:May 26 10:53:23 vadp kernel: hda: irq timeout: status=0xd0 { Busy }
kern.log:May 26 10:53:23 vadp kernel: hda: status timeout: status=0xd0 { Busy }
kern.log:May 26 10:53:23 vadp kernel: hda: DMA disabled
kern.log:May 26 10:53:23 vadp kernel: hda: drive not ready for command
kern.log.0:May 22 09:36:32 vadp kernel: hda: dma_timer_expiry: dma status == 0x20
kern.log.0:May 22 09:36:32 vadp kernel: hda: timeout waiting for DMA
kern.log.0:May 22 09:36:32 vadp kernel: hda: timeout waiting for DMA
kern.log.0:May 22 09:36:32 vadp kernel: hda: (__ide_dma_test_irq) called while not waiting
kern.log.0:May 22 09:36:32 vadp kernel: hda: status timeout: status=0xd0 { Busy }
kern.log.0:May 22 09:36:32 vadp kernel: hda: drive not ready for command
kern.log.0:May 22 09:38:16 vadp kernel: hda: dma_timer_expiry: dma status == 0x21
kern.log.0:May 22 09:38:26 vadp kernel: hda: error waiting for DMA
kern.log.0:May 22 09:38:26 vadp kernel: hda: dma timeout retry: status=0xd0 { Busy }
kern.log.0:May 22 09:38:26 vadp kernel: hda: DMA disabled
kern.log.0:May 22 09:42:27 vadp kernel: hda: dma_timer_expiry: dma status == 0x20
kern.log.0:May 22 09:42:27 vadp kernel: hda: timeout waiting for DMA
kern.log.0:May 22 09:42:27 vadp kernel: hda: timeout waiting for DMA
kern.log.0:May 22 09:42:27 vadp kernel: hda: (__ide_dma_test_irq) called while not waiting
kern.log.0:May 22 09:42:27 vadp kernel: hda: status timeout: status=0xd0 { Busy }
kern.log.0:May 22 09:42:27 vadp kernel: hda: drive not ready for command
kern.log.0:May 22 09:42:57 vadp kernel: hda: status timeout: status=0xd0 { Busy }
kern.log.0:May 22 09:42:57 vadp kernel: hda: drive not ready for command
messages:May 24 18:57:24 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed 1
messages:May 24 19:57:24 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed 1
messages:May 24 20:57:24 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed -1
messages:May 24 23:27:25 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed 1
messages:May 25 00:27:25 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed -1
messages:May 25 03:27:26 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed 1
messages:May 25 05:57:26 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed -1
messages:May 25 23:27:30 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed -1
messages:May 26 10:53:23 vadp kernel: hda: irq timeout: status=0xd0 { Busy }
messages:May 26 10:53:23 vadp kernel: hda: status timeout: status=0xd0 { Busy }
messages:May 26 10:53:23 vadp kernel: hda: DMA disabled
messages:May 26 10:57:33 vadp smartd: Device: /dev/hda, S.M.A.R.T. Attribute: 1 Changed 1

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Server "hängt"

Post by oxygen » 2004-05-26 12:43

Schick denen den Log und die wechseln die Platte innerhalb von wenigen Stunden. Aber vorher ein Backup machen, 1&1 macht das nicht sondern du bekommst ein frisches Image.

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-26 12:48

Ich hab dehen genau das geschickt !
Zitat: "Nein, as könnte andere Ursachen haben !"

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Server "hängt"

Post by oxygen » 2004-05-26 13:01

Hm. Also hab bei einem Plattenschaden mal da angrufen und derartige Dinge vorgelesen und noch hinzugefügt das sich die platte auch mit Rescue Modus trotz fsck nicht mounten lässt und das hat problemlos geklappt, innerhalb von 2 Stunden hatte ich eine neue Platte.
Last edited by oxygen on 2004-05-26 13:28, edited 1 time in total.

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-26 13:10

Das Problem ist u.a auch das ich ab nächster Woche 2 Monate nicht an den Server kann. Nen Ersatzadmin ist zwar immer parat aber dieser kann bei einem Plattenschaden sicher nicht alles so wiederherstellen.
z.b Qmail mit Antivir und Spamassassin.
1und1 war auch auf der Kiste und hat selbst nachgesehen.


PS: Laut Telefonsupport ist der einzige Grund für einen Tausch der Platte nen I/O Fehler oder wenn garnixmehr geht.

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: Server "hängt"

Post by chris76 » 2004-05-26 13:25

Dann hast du halt I/O Fehler :wink:
Gruß Christian

BofH excuses: YOU HAVE AN I/O ERROR -> Incompetent Operator error

thorsten
RSAC
Posts: 732
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: Server "hängt"

Post by thorsten » 2004-05-26 13:28

Es könnte Leute geben, die sich hier im Forum, oder per google solche I/O Fehlermeldungen suchen würden und dann ihre eigenen Logs faken.
Denn falls die 1&1 Leute auf die Maschine schauen, sollen sie ja auch das richtige sehen.

Solch ein Vorgehen würde ich aber nie empfehlen, da es ja nicht ganz legal ist :!:

pf4
Posts: 91
Joined: 2002-12-09 10:27

Re: Server "hängt"

Post by pf4 » 2004-05-26 13:31

Dann muss die Kiste eben so weiter laufen, bis die Platte rauchzeichen macht.
Das Märchen mit den anderen Gründen höre ich mir ned nochmal an.

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Server "hängt"

Post by oxygen » 2004-05-26 13:59

Thorsten wrote:Es könnte Leute geben, die sich hier im Forum, oder per google solche I/O Fehlermeldungen suchen würden und dann ihre eigenen Logs faken.
Denn falls die 1&1 Leute auf die Maschine schauen, sollen sie ja auch das richtige sehen.
Sollte einer von den 1&1 Mitarbeiter auf die Maschine schauen, würde er ja sehen, dass was im argen liegt.