MySQL Port 3306 öffnen

MySQL, PostgreSQL, SQLite
andiger.de
Posts: 18
Joined: 2003-07-05 09:27
Location: Neustadt (Pfalz)

MySQL Port 3306 öffnen

Post by andiger.de » 2004-05-08 15:30

Hallo,

wie kann ich das MySQL Port 3306 öffnen?

andiger

bungeebug
Posts: 187
Joined: 2004-04-14 10:08

Re: MySQL Port 3306 öffnen

Post by bungeebug » 2004-05-08 16:09

Hi,

wie öffnen?
Nen Server an den Port binden?

andiger.de
Posts: 18
Joined: 2003-07-05 09:27
Location: Neustadt (Pfalz)

Re: MySQL Port 3306 öffnen

Post by andiger.de » 2004-05-08 16:59

Ich will von extern auf eine Datenbank drauf zu greifen.
Die Datenbank selbst habe ich für den Externen zugriff frei geschalten.

Nur habe ich dann gemerkt, dass das benötigte Port gesperrt ist.

Normal ist das ja auch gut so. Damit ein "Hacker" weniger möglichkeit hat.

Aber eben dieses port soll geöffnet werden und ich weiß beim besten willen nicht wie.

bungeebug
Posts: 187
Joined: 2004-04-14 10:08

Re: MySQL Port 3306 öffnen

Post by bungeebug » 2004-05-08 17:02

Hi,

du musst ihn doch eigendlich auch irgendwie gesperrt haben oder nicht?

antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: MySQL Port 3306 öffnen

Post by antondollmaier » 2004-05-08 17:13

nö.


ich hab hier mysql4 in der standart-install ...

da is nur der socket angegeben und der port ...


die "bind-address=<ip>"-angabe stört den mysqld gar ned ... da wird kein port geöffnet bzw auf listen "gesetzt" ...


so bringt der externe zugriff wenig, wenn man ned drauf zugreifen kann ...


hinweise / tipps?

(google groups bring nur müll bei "mysql 4 bind-address" ... und in der doku is auch nur der befehl drinnen ... )


mfg,
Anton

andiger.de
Posts: 18
Joined: 2003-07-05 09:27
Location: Neustadt (Pfalz)

Re: MySQL Port 3306 öffnen

Post by andiger.de » 2004-05-08 18:08

des ist ja ja grad. gesperrt wurde es von mir nicht. also wurde es vom support gesperrt (wird normalerweise nicht gemacht) oder es ist so Standart.

Ich müsste eben wissen wie man das Port öffnen kann.

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: MySQL Port 3306 öffnen

Post by Outlaw » 2004-05-08 18:47

Hast Du Confixx auf nem Rootie oder geht es um eine normale Linux Kiste ??

Bei den Confixx teilen einfach im Reseller für den WebAccount freigeben und dann im WebAccount freischalten.

Gruß Outi

antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: MySQL Port 3306 öffnen

Post by antondollmaier » 2004-05-08 18:59

eben nicht!

confixx ändert nur den zugriffs-host von "localhost" auf "%" ...


Sonst nix!


das restliche ist mysqld-sache ... und da bind-adresse bzw bind-ip (der alte befehl) nicht geht, suchen wir nach ner anderen methode ...

oder kann man da ned einfach bind-addresse=<myip> schreiben??

andiger.de
Posts: 18
Joined: 2003-07-05 09:27
Location: Neustadt (Pfalz)

Re: MySQL Port 3306 öffnen

Post by andiger.de » 2004-05-08 23:42

Ja Confixx ist auf der Linux Kiste drauf - man muss auch sagen, es handelt sich hier nicht um einen 1und1 schrott.
confixx ändert nur den zugriffs-host von "localhost" auf "%" ...
Das ist richtig. Aber dabei gibt es ein kleines Problem mit der MySQL und PHP Version. Die zugriffsrechte werden dabei nämich so geändert, das man NUR von extern drauf zu greifen kann und nach der änderung nicht mher von intern. Selbst nicht, wenn man anstatt localhost die IP oder Domain angibt.

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: MySQL Port 3306 öffnen

Post by oxygen » 2004-05-09 03:41

skip-network aus der my.cnf entfernen. Steht in jeder Server FAQ auf diesem Planeten.

antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: MySQL Port 3306 öffnen

Post by antondollmaier » 2004-05-09 14:06

server-faq gibts bei meinem reseller nicht, aber habs jetzt bei der 1&1-server-faq gefunden ...

trotzdem danke fürs gleich posten der info, hättest ja auch auf die faqs verweisen können ... ;)

rouven
Posts: 58
Joined: 2002-10-10 15:27

Re: MySQL Port 3306 öffnen

Post by rouven » 2006-07-30 21:27

hallo habe das gleiche problem, und zwar möchte ich einen eigenen datenbank server einrichten, der 2 NICs hat. eine zum internet und eine direktverbindung zu einem anderen "rootserver" ich möchte jetzt den mysql port an die direktverbindung (192.168.0.10) binden.
leider "öffnet" er den port nicht. hab natürlich skip-networking und so entfernt. hier die komplette config:
hab ich was vergessen??

Code: Select all

[client]
character_set         = utf8
default-character-set = utf8 
port            = 3306
socket          = /tmp/mysql.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /tmp/mysql.sock
nice            = 0

[mysqld]
#
# * Basic Settings
#

character-set-server  = utf8
default-character-set = utf8 
user            = mysql
pid-file        = /usr/local/mysql/data/mysqld.pid
socket          = /tmp/mysql.sock
port            = 3306
bind-address    = 192.168.0.10 
bind-address    = 127.0.0.1
log-error       = /var/log/mysql/mysqld.err 
basedir         = /usr
datadir         = /usr/local/mysql/data
tmpdir          = /tmp
language        =  /usr/local/mysql/share/mysql/english/
skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords   = 1
#
# Instead of skip-networking you can listen only on
# localhost which is more compatible and is not less secure.
# bind-address          = 127.0.0.1
#skip-networking
skip-locking
#skip-networking
#skip-name-resolve
skip-external-locking
skip-show-database 

safe-user-create      = 1 
#
# * Fine Tuning
#
key_buffer              = 256M
#max_allowed_packet     = 16M
#thread_stack           = 128K

key_buffer_size       = 128M
sort_buffer_size      = 4M
join_buffer_size      = 4M
read_buffer_size      = 4M
read_rnd_buffer_size  = 8M 
myisam_sort_buffer_size = 64M
max_allowed_packet    = 16M
thread_cache_size     = 8
table_cache           = 256
query_cache_type      = 1
query_cache_size      = 132M
query_cache_limit     = 1M
thread_concurrency    = 8
local-infile          = 0
long_query_time       = 4 
myisam_recover
skip-innodb
innodb_buffer_pool_size = 32M
innodb_additional_mem_pool_size = 4M
innodb_data_home_dir  = /var/lib/mysql/
innodb_log_arch_dir   = /var/lib/mysql/
innodb_log_group_home_dir = /var/lib/mysql/
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
innodb_log_file_size  = 5M
innodb_log_buffer_size = 8M
innodb_log_files_in_group = 2
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50


[mysqlhotcopy]
interactive-timeout 


#
# * Query Cache Configuration
#
query_cache_limit       = 1048576
query_cache_size        = 16777216
query_cache_type        = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log            = /var/log/mysql.log
#log            = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log-slow-queries       = /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id              = 1
#log-bin                        = /var/log/mysql/mysql-bin.log
expire-logs-days        = 20
max_binlog_size         = 104857600
#binlog-do-db           = include_database_name
#binlog-ignore-db       = include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition
character-sets-dir    = utf8
default-character-set = utf8

[isamchk]
character-sets-dir    = utf8 
#key_buffer             = 16M
key_buffer_size       = 128M
sort_buffer_size      = 128M
read_buffer_size      = 4M
write_buffer_size     = 4M 

[myisampack]
character-sets-dir    = utf8 


[myisamchk]
character-sets-dir    = utf8
key_buffer_size       = 128M
sort_buffer_size      = 128M
read_buffer_size      = 4M
write_buffer_size     = 4M 


#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1

[mysqladmin]
character-sets-dir    = utf8
default-character-set = utf8 

[mysqlcheck]
character-sets-dir    = utf8
default-character-set = utf8 


[mysqlimport]
character-sets-dir    = utf8
default-character-set = utf8

[mysqlshow]
character-sets-dir    = utf8

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: MySQL Port 3306 öffnen

Post by oxygen » 2006-07-30 22:57

bind-adress= geht nicht mehrmals. Der letzte Eintrag zählt und das wäre in dem Fall:
bind-adress=127.0.0.1

Überhaupt sieht deine my.cnf sehr wirr aus. Viele Variablen stehen mehrmals drin, teilweise sogar mit verschiedenen und offensichtlich verkehrten Werten. Das solltest du mal komplett überarbeiten.

rouven
Posts: 58
Joined: 2002-10-10 15:27

Re: MySQL Port 3306 öffnen

Post by rouven » 2006-07-31 07:27

hm ne an dem bind adress liegts leider nicht :( welche werte stehen denn doppelt drin?? ich glaub ich bin blind

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: MySQL Port 3306 öffnen

Post by blnsnoopy26 » 2006-07-31 08:40

rouven wrote:hm ne an dem bind adress liegts leider nicht :( welche werte stehen denn doppelt drin?? ich glaub ich bin blind

Code: Select all

character-set-server  = utf8 
default-character-set = utf8 
user            = mysql 
pid-file        = /usr/local/mysql/data/mysqld.pid 
socket          = /tmp/mysql.sock 
port            = 3306 
bind-address    = 192.168.0.10 <--- Hier
bind-address    = 127.0.0.1 <---- Hier 
log-error       = /var/log/mysql/mysqld.err 
basedir         = /usr 
datadir         = /usr/local/mysql/data 
tmpdir          = /tmp 
language        =  /usr/local/mysql/share/mysql/english/ 
skip-external-locking 
schau dir mal das bind-adress an - steht sehr wohl doppelt drinnen.
Kauf dir mal ne Brille und wie bereits gesagt stehn da einige doppelt drinnen.

rouven
Posts: 58
Joined: 2002-10-10 15:27

Re: MySQL Port 3306 öffnen

Post by rouven » 2006-07-31 09:32

ne sorry, da hab ich mich falsch ausgedrückt. das doppelte bind-adress habe ich entfernt daran liegt es leider nicht :(