locale-gen stürzt ab?

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
tic
Posts: 47
Joined: 2003-11-19 13:47

locale-gen stürzt ab?

Post by tic » 2004-05-02 22:22

Ich versuch krampfhaft diese lästigen perl-Meldungen über nicht gesetzte locales durch das setzen ebendieser zu beseitigen :-)

Nun stürzt mir locales-gen dabei regelmässig ab was ich aus der Tatsache ableite dass

1.) folgende Meldung auftaucht
Generating locales...
de_DE.ISO-8859-1.../usr/sbin/locale-gen: line 22: 4672 Killed localedef -i $input -c -f $charset $locale
2.) kern.log sich beschwert dass die zulässige core-filesize nicht ausreicht
kernel: grsec: From 80.136.79.191: attempted resource overstep by requesting 4096 for RLIMIT_CORE against limit 0 by /usr/bin/localedef[localedef:10242]
Wenn ich mich recht erinnere werden diese core-files angelegt wenn der Prozess abstürzt.
Das kann ja nun sonst was sein.

Wer hat sich mit dem Ã?rgernis schon ein paar Stunden um die Ohren gehauen und weiß des Rätsels Lösung?
Dass locale-gen auf woody stabil läuft hätte ich eigentlich vorausgesetzt. :cry:

tic
Posts: 47
Joined: 2003-11-19 13:47

Re: locale-gen stürzt ab?

Post by tic » 2004-05-03 13:08

Oh, schade :?

Irgendwie sind die Mailinglisten und Foren sonstwo in allen möglichen Sprachen voll von dieser Meldung und die Hilfestellungen dort sind auch (soweit mir bekannt) nicht brauchbar.

Das ulimit raufzusetzen finde ich auch nicht brauchbar denn wenn das core-file erstellt wird ist das Kind ja schon in den Brunnen gefallen.

Der Fehler scheint jedoch bei bugs.debian.org sozusagen als erledigt auf. Ich hab mal beim Maintainer nachgefragt (der arme hat ja sonst nichts zu tun :-) ). Mal schaun was er antwortet.

tic
Posts: 47
Joined: 2003-11-19 13:47

Re: locale-gen stürzt ab?

Post by tic » 2004-05-10 12:35

Man lernt nie aus.

Der Grund für das Scheitern von locale-gen liegt in der Konfiguration von grsec.

Ich hab mir vorerst jedoch keine Zeit genommen der Sache vernünftig auf den Grund zu gehen und hab einfach in einen Kernel ohne grsec gebootet, locale-gen ausgeführt (das geht dann wie am Schnürchen :)) und wieder in den eigentlichen Kernel mit dem patch gebootet.

Jetzt läufts wie's soll.

gruß
Manfred