CPAN Fehler

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

CPAN Fehler

Post by adjustman » 2004-04-19 22:27

Hallo, ich habe einen "neuen" Server am Wickel. Da ist offensichtlich etwas kräftig durcheinander. Ich wollte ein paar CPAN Module aktualisieren. Es kommt, unter anderem, folgende Fehlermeldung:

Code: Select all

Checking if your kit is complete...
Looks good
Warning: prerequisite Test::More failed to load: Can't locate Test/More.pm in @INC (@INC contains: /usr/local/lib/perl/5.6.1 /usr/local/share/perl/5.6.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.6.1 /usr/share/perl/5.6.1 /usr/local/lib/site_perl .) at (eval 7) line 3.
Writing Makefile for File::Spec
---- Unsatisfied dependencies detected during [K/KW/KWILLIAMS/File-Spec-0.87.tar.gz] -----

Code: Select all

Running make install
  make had returned bad status, install seems impossible
CPAN.pm panic: deep recursion in color_cmd_tmps depth[100] self[CPAN::Distribution=HASH(0x921d508)] id[M/MS/MSCHWERN/Test-Simple-0.47.tar.gz]
Ich weiss, dass da Abhängigkeitsprobleme sind. Aber wie kann ich sie beseitigen? Danke für die Hilfe.
P.S. OS Debian 3.0

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: CPAN Fehler

Post by captaincrunch » 2004-04-20 08:17

apt-cache search perl | grep -i test
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: CPAN Fehler

Post by adjustman » 2004-04-20 14:17

Da kommt:

Code: Select all

libtest-cmd-perl - perl module to providers testing framework
libtest-simple-perl - Perl modules for writing tests
libtest-unit-perl - a unit testing interface for Perl
libtime-period-perl - Perl library for testing if a time() is in a specific period
libwhisker-perl - Perl module geared for HTTP testing
Das heisst, dass diese Pakete fehlen? :)

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: CPAN Fehler

Post by captaincrunch » 2004-04-20 14:35

Jein: ich würde einfach diese vorgefertigten Pakete nutzen, statt selbst alles aus dem CPAN zu ziehen. ;)
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: CPAN Fehler

Post by adjustman » 2004-04-20 14:51

danke. Es geht im speziellen um Amavisd-new. Das braucht etliche Module extra. Und die wollt ich über CPAN "beziehen".