derbes problem beim installieren von amavisd-new

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
klausi01
Posts: 115
Joined: 2003-05-19 22:28

derbes problem beim installieren von amavisd-new

Post by klausi01 » 2004-04-12 05:02

Moin zusammen.
Nach 4 Stunden erfolglosem Googlen schildere ich hier mal mein Problem :

Ich versuche amavisd-new zu installieren ( habe versch. versionen aus verschiedenen quellen versucht ) erhalte aber folgende meldung :
Starting amavisd: Net::SMTP version 2.24 required--this is only version 2.19 at /usr/sbin/amavisd-new line 2704.
Das komische ist, das mir
grep $VERSION /usr/share/perl5/Net/SMTP.pm
sagt :
use vars qw($VERSION @ISA);
$VERSION = "2.28";
Hat dieses Problem schonmal jemand gehabt oder hat nen ansatz wo ich suchen kann ???

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: derbes problem beim installieren von amavisd-new

Post by captaincrunch » 2004-04-12 10:31

Warum installierst du nicht einfach das passende RPM?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

klausi01
Posts: 115
Joined: 2003-05-19 22:28

Re: derbes problem beim installieren von amavisd-new

Post by klausi01 » 2004-04-12 11:50

ich habe das als deb und per apt versucht ..bekomme leider immer die sélbe meldung ...
Edit :

sehe grad das ich im falschen Forum gelandet bin ..könnte das hier mal jemand verschieben ?

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: derbes problem beim installieren von amavisd-new

Post by olaf.dietsche » 2004-04-12 16:36

Vielleicht hast du in deinem Includepfad noch ein weiteres Net/SMTP.pm. Was liefert

Code: Select all

perl -e 'print "@INCn";'
bzw.

Code: Select all

dpkg -S SMTP.pm

klausi01
Posts: 115
Joined: 2003-05-19 22:28

Re: derbes problem beim installieren von amavisd-new

Post by klausi01 » 2004-04-12 16:51

essen:~# perl -e 'print "@INCn";'
/usr/local/lib/perl/5.6.1 /usr/local/share/perl/5.6.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.6.1 /usr/share/perl/5.6.1 /usr/local/lib/site_perl .
essen:~#
essen:~# dpkg -S SMTP.pm
libnet-perl: /usr/share/perl5/Net/SMTP.pm
essen:~#

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: derbes problem beim installieren von amavisd-new

Post by olaf.dietsche » 2004-04-12 17:07

Dann hilft nur noch in amavisd-new selbst nachsehen.

klausi01
Posts: 115
Joined: 2003-05-19 22:28

Re: derbes problem beim installieren von amavisd-new

Post by klausi01 » 2004-04-12 17:09

ich denke ich werd mal versuchen den aus den sourcen zu´installieren ..

EDIT :

Auch das war keine wirkliche löäsung ...sobald ich den amavisd starte kommt wieder die selbe meldung :-(

klausi01
Posts: 115
Joined: 2003-05-19 22:28

Re: derbes problem beim installieren von amavisd-new

Post by klausi01 » 2004-04-12 20:50

Problem gelöst ..es warn wirklich 2 verschiedene perl versionen installiert ..also ´hab ich nur die falsche smtp.pm gegen die richtige getauscht und schon gings.