/usr/bin/make -- NOT OK

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

/usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-08 15:45

Hallo.

Ich wollte mir gerade ein paar perl-scripts installieren, um einen Spamfilter einzurichten und dann kommt beim ersten Versuch:
Writing Makefile for Mail::SpamAssassin
Makefile written by ExtUtils::MakeMaker 6.03
Makefile:94: *** missing separator. Stop.
/usr/bin/make -- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible
Wie bekomme ich das hin?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: /usr/bin/make -- NOT OK

Post by captaincrunch » 2004-04-08 15:59

Aus der Fehlermeldung lassen sich keinerlie Rückschlüsse ziehen. Vollständiges Log anfertigen, und irgendwo dort ablegen, wo man sich das mal anschauen kann.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: /usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-08 16:04

Wie stell ich das an?
Existiert da jetzt schon ein log?
Wo finde ich das?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: /usr/bin/make -- NOT OK

Post by captaincrunch » 2004-04-08 16:44

Du lässt den Build ein weiteres Mal laufen, und machst Cut and Paste in irgendeine Datei, die du dann auf irgend einen Webspace ablegst.

Tip: Schau dir dazu mal das Kommando tee an.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: /usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-08 17:02


captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: /usr/bin/make -- NOT OK

Post by captaincrunch » 2004-04-08 17:09

Die Lösung steht bereits da:
NOTE: if you get an error like this (the line number may vary):
Makefile:91: *** missing separator
then set the environment variable LC_ALL to "C" and retry
from scratch (re-run perl "Makefile.PL").
Um es dir jetzt gaaaanz einfach zu machen:

Code: Select all

export LC_ALL=C
Danach den Build noch mal starten.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: /usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-08 17:13

Ahhh !!!!!
Hat gefunzt.

jetzt bin ich schon nen ganzen schritt weiter.
Dankeschön. :-D

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: /usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-08 17:17

Tja und schon kommt das nächste Problem:

Jetzt möchte ich den razor-agent installieren, der mir aber sagt, dass er die perl-module, die ich soeben installiert hatte, nicht finden kann.
rpm -Uvh razor-agents-2.36-art.rh9.1.i386.rpm
error: Failed dependencies:
perl(Digest::SHA1) is needed by razor-agents-2.36-art.rh9.1
perl(Time::HiRes) is needed by razor-agents-2.36-art.rh9.1
perl-Digest-SHA1 is needed by razor-agents-2.36-art.rh9.1
perl-Net-DNS is needed by razor-agents-2.36-art.rh9.1
perl-Time-HiRes is needed by razor-agents-2.36-art.rh9.1
Hab ich irgend etwas vergessen?
Die Module sind doch nach dem MAKE-vorgang aktiv, oder?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: /usr/bin/make -- NOT OK

Post by captaincrunch » 2004-04-08 17:28

Aktiv: ja, aber nicht in der RPM-Datenbank.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: /usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-12 16:22

Und wie bring ich die da rein?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: /usr/bin/make -- NOT OK

Post by captaincrunch » 2004-04-12 16:43

rpm -Uvh /wo/auch/immer/das/besch*/paket/liegt.rpm

Oder meinst du die Frage wirklich Ernst?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

ts77
Posts: 15
Joined: 2003-10-13 22:53

Re: /usr/bin/make -- NOT OK

Post by ts77 » 2004-04-12 23:57

ich tipp mal er hat die von hand installiert und rpm findet diese natürlich nicht.
installier razor-agents auch einfach von hand, anstelle als rpm ... dann weiß man wenigstens was man macht ;).

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: /usr/bin/make -- NOT OK

Post by thefreeman » 2004-04-13 09:35

Ich glaube, das trau ich mir noch nicht so ganz zu.
Falls der Server abkackt, hab ich ein Problem, das
mal so richtig Kohle kostet. :(