[Passwort] qmail + vpopmail + confixx

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
gleitz
Posts: 44
Joined: 2004-01-26 21:48

[Passwort] qmail + vpopmail + confixx

Post by gleitz » 2004-03-29 11:23

Es wird ja immer wieder hartnäckig behauptet, das qmail mit vpopmail und Confixx nicht zusammen laufen wollen.
Wenn ich das Problem richtig verstanden habe, liegt das daran das vpopmail seine eigene Benutzerautorisierung benutzt und Confixx die Benutzer in das System schreibt.

Da der Ausspruch "... geht nicht!" nicht zu meinem Vokabular gehört, habe ich mir vpopmail mal näher angesehen. Dabei ist mir aufgefallen, das man vpopmail auch mit folgenden Eigenschaften compilen kann:
[1] --enable-passwd
[2] --enable-learn-passwords

Bei [1] wird die /etc/passwd bzw. shadow genutzt
Bei [2] wird das Passwort genutzt, das beim ersten Aufruf angegeben wird. Diese Möglichkeit wäre halt nur ein Rettungsanker, wenn alles versagt.

Gibt es noch mehr Möglichkeiten die ich jetzt übersehen habe und kann mir jemand bestätigen, das vpopmail mit Confixx mit der Möglichkeit [1] läuft?
Was auch noch interessant wäre, habe ich noch etwas übersehen?

theduke
Posts: 15
Joined: 2003-04-03 09:28
Location: Paderborn

authentifikation geht

Post by theduke » 2004-04-02 10:08

Die Authentifikation klappt mit den Einstellungen wunderbar :-D


Leider habe ich jetzt nur noch ein Problem mit der Mailzustellung. Ich hab qmail nach der Anleitung von debianhowto.de installiert und bei vpopmail jetzt zusätzlich --enable-passwd eingebunden.

Bei Confixx habe ich angegen:
$maildrop = 'HOMEDIR/Maildir/';
$mailBoxName = 'Maildir';
$pop_homeDir = '/var/email';

in der passwd steht auch
web1p1:x:1137:104::/var/email/web1p1:/bin/false

Verzeichnisse existieren auch:
drwxr-x--- 3 web1p1 poponly 4096 Apr 2 08:22 web1p1
-drwx------ 5 web1p1 poponly 4096 Apr 2 08:22 Maildir
--drwx------ 2 web1p1 poponly 4096 Apr 2 08:22 cur
--drwx------ 2 web1p1 poponly 4096 Apr 2 08:22 new
--drwx------ 2 web1p1 poponly 4096 Apr 2 08:22 tmp

Das Problem ist jetzt nur, dass alle Mails in /var/spool/mail ankommen und nich in dem Maildir.

Hat da vielleicht jemand eine Idee?

theduke
Posts: 15
Joined: 2003-04-03 09:28
Location: Paderborn

es geht

Post by theduke » 2004-04-02 11:04

Alles klar, hab den hacken gefunden.

ich musste in der /etc/init.d/qmail

folgendes ändern:

#alias_empty="|/usr/sbin/qmail-procmail" # procmail delivery to /var/spool/mail
alias_empty="./Maildir/" # This uses qmail prefered ~/Maildir/ directory