1&1 slackware server

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
natas
Posts: 22
Joined: 2003-03-25 19:13

1&1 slackware server

Post by natas »

Hallo zusammen,

ich beschäftige mich im Moment ein wenig mit der Installation von slackware auf einem 1&1 rootserver. Das problem dabei ist dass man das slackware setup tool anscheinend nur nach dem booten mit der slackware cds aufrufen kann. Ich habe daher alle setup vorgänge per Hand im Rescue System gemacht stoße jedoch auf ein sehr merckwürdiges Problem. Nach der Installation der ganzen Grundpackete in /mnt/slackware will ich ein chroot /mnt/slackware machen bekomme jedoch die Meldung dass /bin/bash nicht vorhanden sei. Die bash befindet sich in /bin/bash sowie in /mnt/slackware/bin/bash. Bei allen anderen Distributionen (bsp debian) funktioniert das wunderbar. Weshalb bei slackware nicht?

Hat schonmal jemand slackware auf einem Rechner installiert ohne die Möglichkeit einer bootdisk zu haben?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11164
Joined: 2003-02-27 01:00
Location: Hamburg

Re: 1&1 slackware server

Post by Joe User »

Code: Select all

chroot /mnt/slackware /usr/bin/env -i HOME=/root TERM=$TERM PATH=/sbin:/bin:/usr/sbin:/usr/bin /bin/bash --login
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

audio07
Posts: 64
Joined: 2003-12-03 02:32
Location: Mainz

Re: 1&1 slackware server

Post by audio07 »

Ich habe mich damit kürzlich auch befasst, jedoch noch nicht umgestellt. Da ich Kunden auf meinem Server hoste, muß ich die Down-Zeit sehr kurz gestalten. Von daher werde ich dies wohl so machen, dass ich ein solches System hier lokal aufspiele, konfiguriere und dann im Endeffekt nur noch hochlade. Da müßte man vorher die Partition verkleinern, das neue System aufspielen und anschließend wieder umpartitionieren. Ist etwas stressig - jedoch Downtime-technisch sicherlich die schnellste Variante.

Btw: Es handelt sich bei mir um keinen 1&1-Server sondern Strato.

natas
Posts: 22
Joined: 2003-03-25 19:13

Re: 1&1 slackware server

Post by natas »

Code: Select all

rescue:/mnt/slackware# chroot /mnt/slackware /usr/bin/env -i HOME=/root TERM=$TERM PATH=/sbin:/bin:/usr/sbin:/usr/bin /bin/bash --login
chroot: cannot execute /usr/bin/env: No such file or directory
/usr/bin/env
/mnt/slackware/usr/bin/env
existieren aber... 8O

natas
Posts: 22
Joined: 2003-03-25 19:13

Re: 1&1 slackware server

Post by natas »

Ich hab es jetzt, wie audio07 es vorgeschlagen hat ebenfalls gemacht indem ich mir ein laufendes vergleichbares System installiert habe und alle Daten hochgespielt habe (ohne dd, mit scp). Nachm lilo ausführen und der Netzwerkeinstellungen hab ich dann neugestartet aber ich bekomme keine Verbindung.

Code: Select all

Mar 29 17:49:51 p15124461 kernel: klogd 1.4.1, log source = /proc/kmsg started.
Mar 29 17:49:51 p15124461 kernel: BIOS-provided physical RAM map:
Mar 29 17:49:51 p15124461 kernel: 247MB LOWMEM available.
Mar 29 17:49:51 p15124461 kernel: Initializing CPU#0
Mar 29 17:49:51 p15124461 kernel: Memory: 247944k/253888k available (1813k kernel code, 5560k reserved, 614k data, 116k init, 0k highmem)
Mar 29 17:49:51 p15124461 kernel: Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Mar 29 17:49:51 p15124461 kernel: Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mar 29 17:49:51 p15124461 kernel: Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Mar 29 17:49:51 p15124461 kernel: Buffer cache hash table entries: 16384 (order: 4, 65536 bytes)
Mar 29 17:49:51 p15124461 kernel: CPU: Trace cache: 12K uops, L1 D cache: 8K
Mar 29 17:49:51 p15124461 kernel: CPU: L2 cache: 128K
Mar 29 17:49:51 p15124461 kernel: Enabling fast FPU save and restore... done.
Mar 29 17:49:51 p15124461 kernel: Enabling unmasked SIMD FPU exception support... done.
Mar 29 17:49:51 p15124461 kernel: Checking 'hlt' instruction... OK.
Mar 29 17:49:51 p15124461 kernel: PCI: PCI BIOS revision 2.10 entry at 0xfb350, last bus=1
Mar 29 17:49:51 p15124461 kernel: PCI: Using configuration type 1
Mar 29 17:49:51 p15124461 kernel: PCI: Probing PCI hardware
Mar 29 17:49:51 p15124461 kernel: PCI: Using IRQ router default [1106/3148] at 00:00.0
Mar 29 17:49:51 p15124461 kernel: PCI: Via IRQ fixup for 00:10.1, from 255 to 0
Mar 29 17:49:51 p15124461 kernel: Linux NET4.0 for Linux 2.4
Mar 29 17:49:51 p15124461 kernel: Based upon Swansea University Computer Society NET3.039
Mar 29 17:49:51 p15124461 kernel: VFS: Disk quotas vdquot_6.5.1
Mar 29 17:49:51 p15124461 kernel: Journalled Block Device driver loaded
Mar 29 17:49:51 p15124461 kernel: Detected PS/2 Mouse Port.
Mar 29 17:49:51 p15124461 kernel: Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
Mar 29 17:49:51 p15124461 kernel: ttyS00 at 0x03f8 (irq = 4) is a 16550A
Mar 29 17:49:51 p15124461 kernel: Real Time Clock Driver v1.10e
Mar 29 17:49:51 p15124461 kernel: FDC 0 is a post-1991 82077
Mar 29 17:49:51 p15124461 kernel: loop: loaded (max 8 devices)
Mar 29 17:49:51 p15124461 kernel: Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
Mar 29 17:49:51 p15124461 kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Mar 29 17:49:51 p15124461 kernel: VP_IDE: IDE controller at PCI slot 00:11.1
Mar 29 17:49:51 p15124461 kernel: VP_IDE: chipset revision 6
Mar 29 17:49:51 p15124461 kernel: VP_IDE: not 100%% native mode: will probe irqs later
Mar 29 17:49:51 p15124461 kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Mar 29 17:49:51 p15124461 kernel: VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci00:11.1
Mar 29 17:49:51 p15124461 kernel:     ide0: BM-DMA at 0xdc00-0xdc07, BIOS settings: hda:DMA, hdb:pio
Mar 29 17:49:51 p15124461 kernel: hda: 80418240 sectors (41174 MB) w/1863KiB Cache, CHS=5005/255/63, UDMA(100)
Mar 29 17:49:51 p15124461 kernel: Partition check:
Mar 29 17:49:51 p15124461 kernel:  hda: hda1 hda2 hda3 hda4
Mar 29 17:49:51 p15124461 kernel: SCSI subsystem driver Revision: 1.00
Mar 29 17:49:51 p15124461 kernel: md: linear personality registered as nr 1
Mar 29 17:49:51 p15124461 kernel: md: raid0 personality registered as nr 2
Mar 29 17:49:51 p15124461 kernel: md: raid1 personality registered as nr 3
Mar 29 17:49:51 p15124461 kernel: md: raid5 personality registered as nr 4
Mar 29 17:49:51 p15124461 kernel: raid5: measuring checksumming speed
Mar 29 17:49:51 p15124461 kernel: md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
Mar 29 17:49:51 p15124461 kernel: md: Autodetecting RAID arrays.
Mar 29 17:49:51 p15124461 kernel: md: autorun ...
Mar 29 17:49:51 p15124461 kernel: md: ... autorun DONE.
Mar 29 17:49:51 p15124461 kernel: LVM version 1.0.5+(22/07/2002)
Mar 29 17:49:51 p15124461 kernel: Initializing Cryptographic API
Mar 29 17:49:51 p15124461 kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Mar 29 17:49:51 p15124461 kernel: IP Protocols: ICMP, UDP, TCP
Mar 29 17:49:51 p15124461 kernel: IP: routing cache hash table of 2048 buckets, 16Kbytes
Mar 29 17:49:51 p15124461 kernel: TCP: Hash tables configured (established 16384 bind 32768)
Mar 29 17:49:51 p15124461 kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Mar 29 17:49:51 p15124461 kernel: kjournald starting.  Commit interval 5 seconds
Mar 29 17:49:51 p15124461 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Mar 29 17:49:51 p15124461 kernel: Freeing unused kernel memory: 116k freed
Mar 29 17:49:51 p15124461 kernel: Adding Swap: 2097136k swap-space (priority -1)
Mar 29 17:49:51 p15124461 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
Mar 29 17:49:51 p15124461 kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Mar 29 17:49:51 p15124461 kernel: agpgart: Maximum main memory to use for agp memory: 196M
Mar 29 17:49:51 p15124461 kernel: agpgart: Detected Via Apollo P4M266 chipset
Mar 29 17:49:51 p15124461 kernel: agpgart: AGP aperture is 32M @ 0xe8000000
Mar 29 17:49:51 p15124461 kernel: via-rhine.c:v1.10-LK1.1.19  July-12-2003  Written by Donald Becker
Mar 29 17:49:51 p15124461 kernel:   http://www.scyld.com/network/via-rhine.html
Mar 29 17:49:51 p15124461 kernel: eth0: VIA VT6102 Rhine-II at 0xe000, 00:40:63:c4:1d:6a, IRQ 15.
Mar 29 17:49:51 p15124461 kernel: eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.
Mar 29 17:49:51 p15124461 kernel: scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Mar 29 17:49:51 p15124461 kernel: eth0: Setting full-duplex based on MII #1 link partner capability of 41e1.
Mar 29 17:49:51 p15124461 sshd[89]: Server listening on 0.0.0.0 port 22.
Er erkennt die Netzwerkkarte und IP+Host+Gateway sind richtig eingestellt (per netconfig). Weshalb scheint der Server immernoch nicht seine IP anzunehmen?

majortermi
Userprojekt
Userprojekt
Posts: 916
Joined: 2002-06-17 16:09

Re: 1&1 slackware server

Post by majortermi »

NataS wrote:

Code: Select all

rescue:/mnt/slackware# chroot /mnt/slackware /usr/bin/env -i HOME=/root TERM=$TERM PATH=/sbin:/bin:/usr/sbin:/usr/bin /bin/bash --login
chroot: cannot execute /usr/bin/env: No such file or directory
/usr/bin/env
/mnt/slackware/usr/bin/env
existieren aber... 8O
Ich meine mich dunkel daran erinnern zu können mal irgendwo gelesen zu haben, dass die Meldung "No such file or directory" sich nicht notwendigerweise auf das aufgerufene Programm beziehen muss, sondern damit durchaus auch eine Library gemeint sein kann. Ich würde mal mit ldd überprüfen, welche Libraries benötigt werden, und ob diese in der Umgebung vorhanden sind.
Erst nachlesen, dann nachdenken, dann nachfragen... :)
Warum man sich an diese Reihenfolge halten sollte...

natas
Posts: 22
Joined: 2003-03-25 19:13

Re: 1&1 slackware server

Post by natas »

Da scheinst du recht zu haben, da nach dem kopieren des ganzes Sys das chroot ebenfalls geht - nächstemal bin ich gleich schlauer ;)

natas
Posts: 22
Joined: 2003-03-25 19:13

Re: 1&1 slackware server

Post by natas »

gut, routen hat ich mit nem schreibfehler eingerichtet :oops: nu geht alles =)