Probleme beim Mailversand mit smtp_auth und Postfix

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Probleme beim Mailversand mit smtp_auth und Postfix

Post by chris76 » 2004-03-15 21:00

Hi Zusammen, ich habe ein kleines Problem beim versenden meiner Mails.

Ich setzte Cyrus mit Postfix auf dem Server ein.
Wenn ich mit Squirrelmail eine mail Versende geht das eiwandfrei, wenn ich aber den Client (z.b. Thunderbird) verwende kann ich die mails nicht versenden. Er fragt wiederholt nach dem Passwort, aber Fehlermeldung Zeigt er mir im Client keine an.

So sieht meine main.cf aus

Code: Select all

# see /usr/share/postfix/main.cf.dist for a commented, fuller
# version of this file.

# Do not change these directory settings - they are critical to Postfix
# operation.
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
program_directory = /usr/lib/postfix

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
setgid_group = postdrop
biff = no
message_size_limit = 20000000
mydomain = domain.de
myhostname = p15423654.pureserver.info
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, check_relay_domains
append_dot_mydomain = yes
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = domain.de localhost.domain.de p15423654.pureserver.info, p15423654.pureserver.info, localhost.pureserver.info, localhost

relay_domains = $mydestination


#Aenderungen fuer SA
mailbox_command = /usr/bin/procmail
mailbox_transport = procmail


mynetworks_style = host

mailbox_size_limit = 0

# Antivir Einbindung
content_filter = smtp:127.0.0.1:10024
Diese Fehlermeldung taucht dann im mail.log auf

Code: Select all

Mar 15 20:53:39 p15423654 postfix/smtpd[30913]: warning: pD9E95286.dip0.t-ipconnect.de[217.233.82.134]: SASL LOGIN authentication failed
Auf meinem anderen Server (allerdings mit SuSE) läuft alles ohne Probleme. Ich habe die Konfigurationen schon verglichen, leider ohne erfolg.
Könnt ihr mal bitte einen Blick auf die Kofiguration werfen?
Ich sehe keine Fehler, und mir fällt nix ein was ich evtl vergessen habe zu Konfigurieren oder installieren.

Wahrscheinlich habe ich blos mal wieder meine Tomaten :) auf den Augen.

Danke schon mal für die Hilfe
Gruß Christian

michaelzz5
Posts: 14
Joined: 2002-12-07 22:32
Location: Zeitz

Probleme beim Mailversand mit smtp_auth und Postfix

Post by michaelzz5 » 2004-03-16 14:44

Hallo,

Das Versenden mit Squirrelmail funktioniert, weil es auf localhost zu greift. Und von localhost kein smtp auth gefordert wird.
Dein SMTP Auth scheint nicht zu funktionieren, das sagen Dir Deine log auszüge.
Mar 15 20:53:39 p15423654 postfix/smtpd[30913]: warning: pD9E95286.dip0.t-ipconnect.de[217.233.82.134]: SASL LOGIN authentication failed
Was ist das für ein System, Debian ?

mfg. Micha

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: Probleme beim Mailversand mit smtp_auth und Postfix

Post by chris76 » 2004-03-16 15:23

Ja ist ein Debian System,

das SMTP Auth nicht geht ist mir klar, aber ich finde in meiner Config auch leider den Fehler net warum.
Ist dir was augefallen in der Config? oder hast du noch einen Ansatz? So wie ich mich kenne bin ich mir sicher das ich nur wieder eine Kleinigkeit übersehen habe.

Danke,

Ciao Christian

michaelzz5
Posts: 14
Joined: 2002-12-07 22:32
Location: Zeitz

Probleme beim Mailversand mit smtp_auth und Postfix

Post by michaelzz5 » 2004-03-16 15:50

Hallo,

An Deinen Configs ligt es nicht. Bei Debian läuft Postfix Standart mässig in einer Chroot.

http://www.debianforum.de/wiki/?page=Postfix+SMTP-AUTH

Unter diesem Link gibt es ein erstklassiges HowTo zum Thema Debian Woody, Postfix und SMTP Auth. Ich hatte das mal so wie es dort beschrieben ist am laufen, funzt einwandfrei.

mfg. Micha

cybermage
Posts: 158
Joined: 2002-12-10 22:10
Location: Ausgburg (Germany)

Re: Probleme beim Mailversand mit smtp_auth und Postfix

Post by cybermage » 2004-03-16 15:57

wundert mich dass in dem howto von libsasl2 gesprochen wird, denn das ist eindeutig nicht aus woody

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: Probleme beim Mailversand mit smtp_auth und Postfix

Post by chris76 » 2004-03-19 14:55

so nun habe ich mein smtp_auth am laufen. Geht wunderbar. :-D

eine Sache ist allerdings noch etwas komisch, da bin ich aber noch nicht dahinter gekommen.

Wenn ich die mail mit dem Client (Thunderbird) verschicke sieht es im log so aus

Code: Select all

Mar 19 14:29:42 p15423654 postfix/smtpd[6184]: connect from pD9EBC2F8.dip0.t-ipconnect.de[217.235.194.248]
Mar 19 14:29:42 p15423654 postfix/smtpd[6184]: warning: pD9EBC2F8.dip0.t-ipconnect.de[217.235.194.248]: SASL CRAM-MD5 authentication failed
Mar 19 14:29:48 p15423654 postfix/smtpd[6184]: 2195184006: client=pD9EBC2F8.dip0.t-ipconnect.de[217.235.194.248], sasl_method=PLAIN, sasl_username=test

Thunbderbird selbst gibt diese Meldung aus

Code: Select all

Der aktuelle Befehl war nicht erfolgreich. Der Mail-Server antwortete: Permission denied.
Wenn ich die Mails hingegen mit OutlookExpress verschicke, dann geht es ohne jegliche Fehlermeldungen im log oder OE.

Any ideas?

Danke

Ciao Christian

michaelzz5
Posts: 14
Joined: 2002-12-07 22:32
Location: Zeitz

Probleme beim Mailversand mit smtp_auth und Postfix

Post by michaelzz5 » 2004-03-19 15:32

Hallo,

Das liegt daran das Thunderbird den Nutzernamen und das Passwort CRAM-MD5 Verschlüsselt übertragen will. Und das funktioniert bei SMTP Auth über pam (Systemkonten, für z.B. Confixx notwendig) nicht. Plain und Login ist Standart allerdings klartext Ã?bertragung von Nutzernamen und Passwort.

mfg. Micha

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: Probleme beim Mailversand mit smtp_auth und Postfix

Post by chris76 » 2004-03-19 15:40

ok das heiß ich muß damit auch der Thunderbird fehlerfrei sendet von smtp-auth über pam weg.

Nach dem howto habe ich als pwcheck method in der /etc/postfix/sasl/smtpd.conf pwcheck angegeben.

Oder versteh ich da was falsch?

Gruß Christian

michaelzz5
Posts: 14
Joined: 2002-12-07 22:32
Location: Zeitz

Probleme beim Mailversand mit smtp_auth und Postfix

Post by michaelzz5 » 2004-03-19 15:48

Hallo,

pwcheck überprüft die Passwörter gegen pam. Du kannst (glaube ich zumindest) bei Thunderbird Klartext Logins einstellen, musst mal schauen. An Deiner config liegt es jedenfalls nicht.

mfg. Micha