kein Mailversand nach aussen nach PD-Admin Installation

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
daniel2004
Posts: 17
Joined: 2004-03-09 20:48

kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-11 12:34

Hi volks,

ich hab jetzt seit ca. einer woche qmail mit squirrelmail am laufen, nun habe ich versucht den pd-admin nachzuschieben und siehe da, ich kann keine mails mehr nach extern senden :evil:

will ich eine email von z.b. postmaster@mydomain.com an xxx@yahoo.de senden kommt folgende fehlermeldung zurück:

Hi. This is the qmail-send program at mail.mydomain.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<xxxx@yahoo.de>:
Sorry, I couldn't find any host named yahoo.de. (#5.1.2)


Ich kann mails von local zu local, unf von xxx@yahoo.de zu local senden aber NICHT von local zu xxx@yahoo.de.

ich habe keinen eigenen dns server laufen und logfiles in /var/log/qmail/ zeigen keine fehler

mein server mail.mydomain.com ist in /var/qmail/control/me,
rcpthosts and locals eingetragen.

vor pd-admin lief das ganze tadellos.

sollte ich einen eigenen dns laufen lassen ?

darf ich meine logfiles mal posten ?



sollte die frage nerven, bitte nicht gleich schlagen...


daniel

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by kenzo » 2004-03-11 14:23

Hi. This is the qmail-send program at mail.mydomain.com.
Hmm, im Usenet real posten und hier verschleiern? Tststs ;)
Sorry, I couldn't find any host named yahoo.de. (#5.1.2)
Was sagt denn ein

Code: Select all

dig mx yahoo.de
? Ist etwas in der /etc/resolv.conf?
darf ich meine logfiles mal posten ?
Wir bitten darum!

daniel2004
Posts: 17
Joined: 2004-03-09 20:48

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-11 15:41

Hi,


# dig mx yahoo.de



; <<>> DiG 9.2.2-P3 <<>> mx yahoo.de
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57022
;; flags: qr rd; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;yahoo.de. IN MX

;; ANSWER SECTION:
yahoo.de. 706 IN MX 5 mx4.mail.yahoo.com.
yahoo.de. 706 IN MX 1 mx1.mail.yahoo.com.
yahoo.de. 706 IN MX 1 mx2.mail.yahoo.com.

;; Query time: 21 msec
;; SERVER: 194.25.2.129#53(194.25.2.129)
;; WHEN: Thu Mar 11 17:39:14 2004
;; MSG SIZE rcvd: 100




>Ist etwas in der /etc/resolv.conf?
hab ich hier nicht unter Fedora Core 1 :oops:

hier mal der letzte teil des qmail-smtpd log:

@40000000405097ac16b4e39c tcpserver: status: 1/30
@40000000405097ac16b4f724 tcpserver: pid 12041 from 217.186.109.78
@40000000405097ac17ea2b64 tcpserver: ok 12041 in-the-net.com:82.165.25.18:25 :217.186.109.78::3289
@40000000405097ae36295564 tcpserver: status: 2/30
@40000000405097ae36296cd4 tcpserver: pid 12043 from 217.186.109.78
@40000000405097ae3756d4fc tcpserver: ok 12043 in-the-net.com:82.165.25.18:25 :217.186.109.78::3290
@40000000405097b0094d08ec tcpserver: status: 3/30
@40000000405097b009537574 tcpserver: pid 12045 from 217.186.109.78
@40000000405097b00a7b7e9c tcpserver: ok 12045 in-the-net.com:82.165.25.18:25 :217.186.109.78::3291
@40000000405097b105d4a33c tcpserver: end 12045 status 0
@40000000405097b105d4baac tcpserver: status: 2/30
@40000000405097b12c60a244 tcpserver: end 12041 status 256
@40000000405097b12c60aa14 tcpserver: status: 1/30
@40000000405097b40fc5dd5c tcpserver: end 12043 status 256
@40000000405097b40fc5f4cc tcpserver: status: 0/30

-----@40000000405098230bc01c2c tcpserver: status: 1/30
@40000000405098230bc02fb4 tcpserver: pid 12061 from 217.186.109.78
@40000000405098230ce1eb94 tcpserver: ok 12061 in-the-net.com:82.165.25.18:25 :217.186.109.78::3299
@40000000405098240825904c tcpserver: end 12061 status 0
@40000000405098240825a7bc tcpserver: status: 0/30



daniel

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by kenzo » 2004-03-11 16:20

hier mal der letzte teil des qmail-smtpd log:
Das ist uninteressant - wir brauchen die send-logs. Und die tcp.smtp sowie das Startskript - weißt Du, was bei der Installation des ominösen pd-admin alles verändert wurde?

daniel2004
Posts: 17
Joined: 2004-03-09 20:48

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-11 16:49

ok, hier das letzte stück des qmail-send logs:

@40000000405097b1012386dc new msg 34126
@40000000405097b10123a61c info msg 34126: bytes 1341 from <test@in-the-net.com> qp 12047 uid 512
@40000000405097b1015145cc starting delivery 11: msg 34126 to local in-the-net.com-root@in-the-net.com
@40000000405097b1015295bc status: local 1/10 remote 0/255
@40000000405097b101bea5cc delivery 11: success: did_0+0+1/
@40000000405097b101c5dd74 status: local 0/10 remote 0/255
@40000000405097b101c80ff4 end msg 34126
@4000000040509824035cb1e4 new msg 62547
@4000000040509824035cc954 info msg 62547: bytes 1341 from <test@in-the-net.com> qp 12063 uid 512
@40000000405098240387483c starting delivery 12: msg 62547 to remote admin@shstahr.de
@400000004050982403888c74 status: local 0/10 remote 1/255
@40000000405098240733e134 delivery 12: failure: Sorry,_I_couldn't_find_any_host_named_shstahr.de._(#5.1.2)/
@40000000405098240734045c status: local 0/10 remote 0/255
@400000004050982407779924 bounce msg 62547 qp 12065
@40000000405098240777b47c end msg 62547
@4000000040509824077ee83c new msg 72607
@4000000040509824077ef7dc info msg 72607: bytes 1885 from <> qp 12065 uid 511
@400000004050982407ac68ac starting delivery 13: msg 72607 to local in-the-net.com-test@in-the-net.com
@400000004050982407ac8bd4 status: local 1/10 remote 0/255
@400000004050982408269dd4 delivery 13: success: did_0+0+1/
@40000000405098240826ad74 status: local 0/10 remote 0/255
@40000000405098240826b544 end msg 72607



und hier die /etc/tcp.smtp

127.0.0.1:allow,RELAYCLIENT=""
127.:allow,RELAYCLIENT=""




und hier noch das qmailctl start script:

#!/bin/sh

# For Red Hat chkconfig
# chkconfig: - 80 30
# description: the qmail MTA

PATH=/var/qmail/bin:/bin:/usr/bin:/usr/local/bin:/usr/local/sbin
export PATH

QMAILDUID=`id -u qmaild`
NOFILESGID=`id -g qmaild`

case "$1" in
start)
echo "Starting qmail..."
echo ""
if svok /service/qmail-send ; then
svc -u /service/qmail-send /service/qmail-send/log
echo "Starting qmail-send"
else
echo "qmail-send supervise not running"
fi
if svok /service/qmail-smtpd ; then
svc -u /service/qmail-smtpd /service/qmail-smtpd/log
echo "Starting qmail-smtpd"
else
echo "qmail-smtpd supervise not running"
fi
if svok /service/qmail-pop3d ; then
svc -u /service/qmail-pop3d /service/qmail-pop3d/log
echo "Starting qmail-pop3d"
else
echo "qmail-pop3d supervise not running"
fi
if [ -d /var/lock/subsys ]; then
touch /var/lock/subsys/qmail
fi
;;
stop)
echo "Stopping qmail..."
echo ""
echo " qmail-smtpd"
svc -d /service/qmail-smtpd /service/qmail-smtpd/log
echo " qmail-send"
svc -d /service/qmail-send /service/qmail-send/log
echo " qmail-pop3d"
svc -d /service/qmail-pop3d /service/qmail-pop3d/log
if [ -f /var/lock/subsys/qmail ]; then
rm /var/lock/subsys/qmail
fi
;;
stat)
svstat /service/qmail-send
svstat /service/qmail-send/log
svstat /service/qmail-smtpd
svstat /service/qmail-smtpd/log
svstat /service/qmail-pop3d
svstat /service/qmail-pop3d/log
qmail-qstat
;;
doqueue|alrm|flush)
echo "Flushing timeout table and sending ALRM signal to qmail-send."
/var/qmail/bin/qmail-tcpok
svc -a /service/qmail-send
;;
queue)
qmail-qstat
qmail-qread
;;
reload|hup)
echo "Sending HUP signal to qmail-send."
#!/bin/sh

# For Red Hat chkconfig
# chkconfig: - 80 30
# description: the qmail MTA

PATH=/var/qmail/bin:/bin:/usr/bin:/usr/local/bin:/usr/local/sbin
export PATH

QMAILDUID=`id -u qmaild`
NOFILESGID=`id -g qmaild`

case "$1" in
start)
echo "Starting qmail..."
echo ""
if svok /service/qmail-send ; then
svc -u /service/qmail-send /service/qmail-send/log
echo "Starting qmail-send"
else
echo "qmail-send supervise not running"
fi
if svok /service/qmail-smtpd ; then
svc -u /service/qmail-smtpd /service/qmail-smtpd/log
echo "Starting qmail-smtpd"
else
echo "qmail-smtpd supervise not running"
fi
if svok /service/qmail-pop3d ; then
svc -u /service/qmail-pop3d /service/qmail-pop3d/log
echo "Starting qmail-pop3d"
else
echo "qmail-pop3d supervise not running"
fi
if [ -d /var/lock/subsys ]; then
touch /var/lock/subsys/qmail
fi
;;
stop)
echo "Stopping qmail..."
echo ""
echo " qmail-smtpd"
svc -d /service/qmail-smtpd /service/qmail-smtpd/log
echo " qmail-send"
svc -d /service/qmail-send /service/qmail-send/log
echo " qmail-pop3d"
svc -d /service/qmail-pop3d /service/qmail-pop3d/log
if [ -f /var/lock/subsys/qmail ]; then
rm /var/lock/subsys/qmail
fi
;;
stat)
svstat /service/qmail-send
svstat /service/qmail-send/log
svstat /service/qmail-smtpd
svstat /service/qmail-smtpd/log
svstat /service/qmail-pop3d
svstat /service/qmail-pop3d/log
qmail-qstat
;;
doqueue|alrm|flush)
echo "Flushing timeout table and sending ALRM signal to qmail-send."
/var/qmail/bin/qmail-tcpok
svc -a /service/qmail-send
;;
queue)
qmail-qstat
qmail-qread
;;
reload|hup)
echo "Sending HUP signal to qmail-send."
svc -h /service/qmail-send
;;
pause)
echo "Pausing qmail-send"
svc -p /service/qmail-send
echo "Pausing qmail-smtpd"
svc -p /service/qmail-smtpd
echo "Pausing qmail-pop3d"
svc -p /service/qmail-smtpd
;;
cont)
echo "Continuing qmail-send"
svc -c /service/qmail-send
echo "Continuing qmail-smtpd"
svc -c /service/qmail-smtpd
echo "Continuing qmail-pop3d"
svc -c /service/qmail-pop3d
;;
restart)
echo "Restarting qmail:"
echo "* Stopping qmail-smtpd."
svc -d /service/qmail-smtpd /service/qmail-smtpd/log
echo "* Sending qmail-send SIGTERM and restarting."
svc -t /service/qmail-send /service/qmail-send/log
echo "* Sending qmail-pop3d SIGTERM and restarting."
svc -t /service/qmail-pop3d /service/qmail-pop3d/log
echo "* Restarting qmail-smtpd."
svc -u /service/qmail-smtpd /service/qmail-smtpd/log
;;
cdb)
tcprules /etc/tcp.smtp.cdb /etc/tcp.smtp.tmp < /etc/tcp.smtp
chmod 644 /etc/tcp.smtp.cdb
echo "Reloaded /etc/tcp.smtp."
;;
help)
cat <<HELP
stop -- stops mail service (smtp connections refused, nothing goes out)
start -- starts mail service (smtp connection accepted, mail can go out)
pause -- temporarily stops mail service (connections accepted, nothing leaves)
cont -- continues paused mail service
stat -- displays status of mail service
cdb -- rebuild the tcpserver cdb file for smtp
restart -- stops and restarts smtp, sends qmail-send a TERM & restarts it
doqueue -- schedules queued messages for immediate delivery
reload -- sends qmail-send HUP, rereading locals and virtualdomains
queue -- shows status of queue
alrm -- same as doqueue
flush -- same as doqueue
hup -- same as reload
HELP
;;
*)
echo "Usage: $0 {start|stop|restart|doqueue|flush|reload|stat|pause|cont|cdb|queue|help}"
exit 1
;;
esac

exit 0



daniel

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by kenzo » 2004-03-11 18:01

DNS funktioniert, Du hast keinen Fehler in der tcp.smtp, der das begründen könnte - daher sollte alles funktionieren.
Also: Was hat pd-admin verändert? Kannst Du die Ã?nderungen mal nachvollziehbar machen?
Nachtrag: Hast Du qmail nach pd-admin neu gestartet?

daniel2004
Posts: 17
Joined: 2004-03-09 20:48

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-11 18:42

jo, qmailctl stop / start und auch restart



der pd-admin ist nur im bereich apache durchgelaufen, dann kamen haufen fehlermeldungen und dann sollte ich makereseller.pl und vhosts.pl manuell ausführen.

das erstellte einen reseller und in der httpd.conf kamen die zeilen # virtual hosts und # codomains hinzu, mehr kann ich erstmal nicht sagen.


wo ist eigentlich festgelegt, wohin die email versendet wird, wenn ich sie vom server abschicke ?


daniel

daniel2004
Posts: 17
Joined: 2004-03-09 20:48

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-11 18:56

NACHTRAG:


hab grade eine mail bekommen an: caught@in-the-net.com <caught@in-the-net.com>

von

Galen Hand <ytohpsq2pm@Duse.net>



diese emailadresse habe ich definitiev nicht erstellt und warum kommt sie bei mir im Outlook an, diesen user/emailaccount gibt es da auch nicht.

von: Galen Hand <ytohpsq2pm@Duse.net>

datum: Donnerstag, 11. März 2004 17:19

an: caught@in-the-net.com <caught@in-the-net.com>

betreff: Let us show you which 'lifestyle aid' you need.q x d


und so weiter...


kann ich jetzt irgendwie nachvollziehen wie er sie geschickt hat ?



daniel


nochmal Nachtrag:


@40000000405098240826ad74 status: local 0/10 remote 0/255
@40000000405098240826b544 end msg 72607
@400000004050bf1c1f58cd9c new msg 72602
@400000004050bf1c1f58ecdc info msg 72602: bytes 6598 from <ytohpsq2pm@Duse.net> qp 13221 uid 512
@400000004050bf1c1f7fe954 starting delivery 14: msg 72602 to local in-the-net.com-caught@in-the-net.com
@400000004050bf1c1f813944 status: local 1/10 remote 0/255
@400000004050bf1c209c4a1c new msg 72495
@400000004050bf1c209c618c info msg 72495: bytes 520 from <caught@in-the-net.com> qp 13225 uid 512
@400000004050bf1c20d1b9cc starting delivery 15: msg 72495 to remote ytohpsq2pm@Duse.net
@400000004050bf1c20d1d524 status: local 1/10 remote 1/255
@400000004050bf1c210529c4 delivery 14: success: user_does_not_exist,_but_will_deliver_to_/home/vpopmail/domains/in-the-net.com/postmaster//did_0+0+1/
@400000004050bf1c210550d4 status: local 0/10 remote 1/255
@400000004050bf1c210554bc end msg 72602
@400000004050bf1c2446cbec delivery 15: failure: Sorry,_I_couldn't_find_any_host_named_Duse.net._(#5.1.2)/
@400000004050bf1c2446ef14 status: local 0/10 remote 0/255
@400000004050bf1c2494d094 bounce msg 72495 qp 13227
@400000004050bf1c2494f7a4 end msg 72495
@400000004050bf1c2494ff74 new msg 72602
@400000004050bf1c2495035c info msg 72602: bytes 1069 from <> qp 13227 uid 511
@400000004050bf1c24c7e2cc starting delivery 16: msg 72602 to local in-the-net.com-caught@in-the-net.com
@400000004050bf1c24c9425c status: local 1/10 remote 0/255
@400000004050bf1c255bd9b4 delivery 16: success: AUTORESPOND:__Stopping_on_mail_from_[]./did_0+0+1/
@400000004050bf1c256451ac status: local 0/10 remote 0/255
@400000004050bf1c2566748c end msg 72602
@400000004050c69e2b8526c4 new msg 71274
@400000004050c69e2b853e34 info msg 71274: bytes 728 from <root@in-the-net.com> qp 13618 uid 512
@400000004050c69e2bcfb89c starting delivery 17: msg 71274 to remote admin@shstahr.de
@400000004050c69e2bd1182c status: local 0/10 remote 1/255



daniel

daniel2004
Posts: 17
Joined: 2004-03-09 20:48

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-12 09:23

Hi,

habs hinbekommen, aber war das wirklich der fehler ?


also nach nochmaligem kontrollieren der konfigdatein und zig neustarts von qmail ging immer noch nix.

Dann habe ich mir die doku (ja, hab ich erstellt :P ) über die installation des servers bzw. des OS vorgenommen, da sah ich dann das ich anstatt des "richtigen" dns servers den von t-online angegeben hatte, ich vergaß ihn mir zu notieren bevor ich das alte OS platt machte... :oops:

jedenfalls habe ich den t-online dns durch den 82.165.25.251 ersetzt, service network restart ausgeführt, dann noch qmail neu gestartet und das senden in alle richtungen klappte wieder.


kann mir jetzt noch jemand helfen bei dem problem, was ich in der vorigen nachricht beschrieben habe ?



daniel

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by kenzo » 2004-03-12 11:56

habs hinbekommen, aber war das wirklich der fehler ?
Sieht fast so aus.
kann mir jetzt noch jemand helfen bei dem problem, was ich in der vorigen nachricht beschrieben habe ?
Catchall an?

daniel2004
Posts: 17
Joined: 2004-03-09 20:48

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel2004 » 2004-03-12 12:06

jo, catchall war an


nochmal zum pd-admin,


beim aufrufen von http://www.mydomain.com/reseller/
komm ich zum login, gebe entsprechende userdaten ein, dann kommt folgender fehler:

#!/usr/bin/perl my %skin_dir; my $skin_dir; if (defined $skin_dir{$ENV{SERVER_NAME}} and $skin_dir{$ENV{SERVER_NAME}}) { $skin_dir = $skin_dir{$ENV{SERVER_NAME}}; } else { $skin_dir = 'html/'; } $skin_dir =~ s:/$::; print <<_; Content-Type: text/html _


perl ist installiert und läuft, jedenfalls auf der konsole.




daniel

daniel bradler
Posts: 94
Joined: 2002-09-12 12:35

Re: kein Mailversand nach aussen nach PD-Admin Installation

Post by daniel bradler » 2004-03-13 10:33

kenzo wrote:
hier mal der letzte teil des qmail-smtpd log:
Das ist uninteressant - wir brauchen die send-logs. Und die tcp.smtp sowie das Startskript - weißt Du, was bei der Installation des ominösen pd-admin alles verändert wurde?
Das "ominöse" pd-admin ist mit Sicherheit nicht der Grund für eine nicht funktionierende Namensauflösung. In dieser Hinsicht nimmt pd-admin keine Ã?nderungen am System vor.

Viele Grüße,
Daniel Bradler