Login nur nach Authdaemond restart möglich!

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
firefox747
Posts: 52
Joined: 2002-08-22 12:37

Login nur nach Authdaemond restart möglich!

Post by firefox747 » 2002-09-12 14:04

Hallo,
ich habe Qmail, Vpopmail, Courier-Imap, IMP installiert und läuft auch alles prima (nochmals danke an Sartre). Leider habe ich jetzt tags drauf festgestellt, das ich mich nicht mehr einloggen kann. Hier erstmal die letzen Zeilen der /var/log/mail
Sep 12 13:27:14 pxxxxxxxx imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 12 13:27:19 pxxxxxxxx imapd: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Sep 12 13:27:29 pxxxxxxxx last message repeated 2 times
Sep 12 13:27:29 pxxxxxxxx imapd: LOGOUT, ip=[::ffff:127.0.0.1]
Sep 12 13:27:33 pxxxxxxxx imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 12 13:27:38 pxxxxxxxx imapd: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Sep 12 13:27:48 pxxxxxxxx last message repeated 2 times
Sep 12 13:27:48 pxxxxxxxx imapd: LOGOUT, ip=[::ffff:127.0.0.1]

# Ab hier wurde authdaemond neu gestartet.

Sep 12 13:29:06 pxxxxxxxx imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 12 13:29:06 pxxxxxxxx imapd: LOGIN, user=user@testdomain.tld, ip=[::ffff:127.0.0.1]
Sep 12 13:29:06 pxxxxxxxx imapd: LOGOUT, user=user@testdomain.tld, ip=[::ffff:127.0.0.1], headers=0, body=0
Sep 12 13:29:06 pxxxxxxxx imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 12 13:29:06 pxxxxxxxx imapd: LOGIN, user=user@testdomain.tld, ip=[::ffff:127.0.0.1]
Sep 12 13:29:06 pxxxxxxxx imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 12 13:29:06 pxxxxxxxx imapd: LOGIN, user=user@testdomain.tld, ip=[::ffff:127.0.0.1]
Sep 12 13:29:06 pxxxxxxxx imapd: LOGOUT, user=user@testdomain.tld, ip=[::ffff:127.0.0.1], headers=0, body=0
Hier nun die authdaemond

Code: Select all

#! /bin/sh

DIR=`dirname $0`

AUTHDAEMOND=authdaemond.plain

if test -x $DIR/authdaemond.ldap
then
        AUTHDAEMOND=authdaemond.ldap
fi

if test -x $DIR/authdaemond.mysql
then
        AUTHDAEMOND=authdaemond.mysql
fi

if test -x $DIR/authdaemond.pgsql
then
        AUTHDAEMOND=authdaemond.pgsql
fi

. /usr/lib/courier-imap/etc/authdaemonrc
if test "$version" != ""
then
        AUTHDAEMOND="$version"
fi

exec $DIR/$AUTHDAEMOND $1

Während der ganzen Zeit sind alle 5 Instanzen von authdaemond am laufen... laut ps -aux

Wenn ich einen Restart der Authdaemond durchführe funktioniert wieder alles.... zumindest die nächsten paar Stunden.

Eine Möglichkeit wäre jetzt ein Cronjob :) ... kann ja aber nicht des Rätsels Lösung sein.

Habe leider nichts entsprechendes per Google / Rootforum gefunden.
Weiss jemand einen Rat?

sartre
Posts: 327
Joined: 2002-05-12 18:02
Location: Duisburg

Re: Login nur nach Authdaemond restart möglich!

Post by sartre » 2002-09-12 20:01

hmmm, ein aussergewöhnliches Verhalten. Wie gesagt, ich hatte das ja am Anfang auch öfters, dass sich IMP nicht auf dem courier einloggen konnte. Nachdem ich vpopmail gepatcht hatte funnzte das hervorragend bis zum heutigen Tage.

Ich werde mal in mich kehren und noch mal die Problemlösung überdenken

Gruß

firefox747
Posts: 52
Joined: 2002-08-22 12:37

Re: Login nur nach Authdaemond restart möglich!

Post by firefox747 » 2002-09-13 07:19

So,
heute morgen habe ich es normals getestet.
POP3 und IMAP per Outlook, etc funktioniert einwandfrei.
Mit IMP und Squirrelmail komme ich aber nicht rein.
Das funktioniert wiederum nur nach einem restart des
authdaemond.
Das verstehe ich jetzt überhaupt nicht mehr.
Worin liegt denn der Unterschied beim IMAP Zugriff von IMP/Squirrelmail zum dem von Outlook?

majortermi
Userprojekt
Userprojekt
Posts: 930
Joined: 2002-06-17 16:09

Re: Login nur nach Authdaemond restart möglich!

Post by majortermi » 2002-09-13 18:31

Firefox747 wrote:Worin liegt denn der Unterschied beim IMAP Zugriff von IMP/Squirrelmail zum dem von Outlook?
Vielleicht am verwendeten Authentifizierungsverfahren?
Ich hatte Anfangs mit dem Cyrus IMAP Probleme, inzwischen funktioniert er aber gut mit SquirrelMail zusammen.
Erst nachlesen, dann nachdenken, dann nachfragen... :)
Warum man sich an diese Reihenfolge halten sollte...

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: Login nur nach Authdaemond restart möglich!

Post by cipi » 2002-11-28 02:15

hab genau das gleiche problem. gibt es dazu schon ne lösung?

sehr sehr strange ...

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: Login nur nach Authdaemond restart möglich!

Post by cipi » 2002-11-28 02:15

hab genau das gleiche problem. gibt es dazu schon ne lösung?
oder zumindest ne idee, was ich ausprobieren könnte?
vpopmail.c ist schon gepatched, geht aber trotzdem net :(

sehr sehr strange ...

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: Login nur nach Authdaemond restart möglich!

Post by cipi » 2002-11-28 12:53

und was mir noch aufgefallen ist, einige user kønnen sich einloggen, andere wiederum nicht. Obwohl beide korrekt angelegt sind.
Das mail-protokoll sagt dazu auch nur einmal eingeloggt/ausgeloggt und Login Failed zu dem anderen User.

was kann ich da noch machen?

flotte
Posts: 93
Joined: 2002-09-13 23:27

Re: Login nur nach Authdaemond restart möglich!

Post by flotte » 2003-07-30 22:17

Gibt es hier eine Lösung?
Scheint auch mein Problem mit qmail/sqwebmail zu sein.

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Login nur nach Authdaemond restart möglich!

Post by floschi » 2003-07-30 22:21

Das ist jetzt ned euer Ernst, oder?

Gerade zwei oder drei Tage liegt der hier zurück:

http://www.rootforum.org/forum/viewtopic.php?t=11874

*g*


Grüßle

Olfi