transport fehler

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
tonid
Posts: 7
Joined: 2003-10-31 15:19

transport fehler

Post by tonid » 2004-02-26 18:28

Hallo,

seit einigerzeit will mein postfix die mail nich mehr in das zugehörige postfach "sortieren"
also wenn mir jemand eine email schickt bekommt dieser keine fehlermeldung, aber in dem postfach zu der adresse kommt nix an.

wenn ich email per outlook verschicken will kommt diese meldung:
"Der Server hat die verbindung unerwartet beendet. Möglicherweise liegt ein Serverproblem vor, es ist ein Netzwerkproblem aufgetreten oder das Zeitlimit wurde überschritten, Fehlernummer: 0x800CCC0F"

hier mal noch meine main.cf:

Code: Select all

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = h1476.serverkompetenz.net
inet_interfaces = 127.0.0.1
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
content_filter =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,check_relay_domains
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_min_user = yes
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
in_flow_delay = 0
inet_interfaces = 127.0.0.1
mail_owner = postfix
mail_spool_directory = /var/mail
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_exceptions = root
mydestination = $myhostname, localhost.$mydomain
#relay_domains = $mydestination, hash:/etc/postfix/relaydomains
#fast_flush_domains = $relay_domains
virtual_alias_domains = hash:/etc/postfix/confixx_localDomains
virtual_maps = hash:/etc/postfix/virtual



mynetworks_style = host
newaliases_path = /usr/sbin/sendmail
setgid_group = maildrop


#SMTP-AUTH Support
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous
smtpd_sasl_password_maps = hash:/etc/postfix/saslpasswd
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_client_restrictions =
smtpd_recipient_restrictions = permit_mynetworks,check_relay_domains


smtpd_sender_restrictions = hash:/etc/postfix/access
strict_rfc821_envelopes = no
transport_maps = hash:/etc/postfix/transport

#TLS Support
#smtpd_use_tls = yes
#smtpd_tls_auth_only = yes
#smtpd_enforce_tls = no
#
#smtpd_tls_cert_file = /etc/httpd/ssl.crt/server.crt
#smtpd_tls_key_file = /etc/httpd/ssl.key/server.key
#smtpd_tls_loglevel = 1
#smtpd_tls_received_header = yes
#smtpd_tls_session_cache_timeout = 3600s
#tls_random_source = dev:/dev/urandom



##smtpd_tls_cert_file = /etc/httpd/ssl.crt/server.crt
##smtpd_tls_key_file = /etc/httpd/ssl.key/server.key
#
#smtpd_tls_cert_file = /etc/postfix/cert.pem
#smtpd_tls_key_file = /etc/postfix/key.pem

#myhostname = game-code.net
#mydomain = game-code.net
#mail_name = game-code.net
bitte um hilfe

Danke schonmal
tonid

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: transport fehler

Post by squize » 2004-02-26 20:40

Poste dich mal das Log zu dem Fehler, den du im Outlook hast, damit man sehen kann was postfix dazu sagt.

Was heisst ausserdem seit einiger Zeit?
Was hat sich vor einiger Zeit geändert ?

Gruss

Marc

tonid
Posts: 7
Joined: 2003-10-31 15:19

Re: transport fehler

Post by tonid » 2004-02-29 10:34

Im Outlook gibts ja keine Fehlermeldung beim abholen, der meint ja nur das keine mails da sind.
Weil das problem is ja, das die ankommenden Emails nicht in das postfach "sortiert" werden wo sie hin sollen, sondern irgendwo gespeichert werden, ich weiß jedenfalls net wo die sind.
Aber wenn mir jemand ne Email schreibt dann bekommt der auch keine meldung das die adresse nich existiert oder so.

Naja das ganze lief ja ne weile gut, aber dann plötzlich gings netmehr, wüsste aber net was ich verstellt haben sollte.

Ich weiß echt net weiter.


tonid

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: transport fehler

Post by squize » 2004-02-29 15:34

Ich meinte ja auch die Logs von deinem Server :)

Gruss

Marc

tonid
Posts: 7
Joined: 2003-10-31 15:19

Re: transport fehler

Post by tonid » 2004-03-01 16:40

achso jo hätt ich mir auch denken können.

also ich weiß nu net genau welche logs, gibt soviele mit irgendwelchen fehlern*g

hier mal nen auszug aus der /var/log/warn:

Code: Select all

Feb 23 16:31:24 h1476 named[703]: /etc/named.conf:98: couldn't open include file '/etc/named.confixx'
Feb 23 16:31:24 h1476 named[722]: check_hints: A records for B.ROOT-SERVERS.NET class 1 do not match hint records
Feb 23 16:31:24 h1476 named[722]: check_hints: A records for J.ROOT-SERVERS.NET class 1 do not match hint records
Feb 26 16:32:12 h1476 inetd[27394]: ftp/tcp: bind: Address already in use
Feb 26 16:32:12 h1476 inetd[27394]: telnet/tcp: bind: Address already in use
Feb 26 16:32:12 h1476 inetd[27394]: http-rman/tcp: bind: Address already in use
Feb 26 16:32:12 h1476 inetd[27394]: ftp/tcp: bind: Address already in use
Feb 26 16:32:12 h1476 inetd[27394]: pop3/tcp: bind: Address already in use
Feb 26 16:32:12 h1476 inetd[27394]: imap/tcp: bind: Address already in use
also anch der named.confixx hab ich gesucht, is aber nirgens auf dem server zu finden

so welche logs wären noch relevant dafür?

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: transport fehler

Post by squize » 2004-03-01 19:49

Dein Log sieht ja schon einmal ganz schön beschissen aus. Du solltest alle Dienste in inetd deaktivieren, die bei dir standalone laufen.

Das Log um das es geht wird wahrscheinlich /var/log/mail heisen.

Du machst einfach ne console auf, dann ein tail -f /var/log/mail und dann rufst du mit Outlook deine Mails ab. Das was dann ins Log geschrieben wird postest du :).

Gruss

Marc

tonid
Posts: 7
Joined: 2003-10-31 15:19

Re: transport fehler

Post by tonid » 2004-03-02 15:16

hm ok, also hier der log auszug (die IP hab drin gelassen da die eh nichmehr stimmt ;) ) :

Code: Select all

Mar  2 02:01:37 h1476 postfix/pickup[22708]: 022ED51C001: uid=0 from=<root>
Mar  2 02:01:37 h1476 postfix/cleanup[23699]: 022ED51C001: message-id=<20040302010136.022ED51C001@h1476.serverkompetenz.net>
Mar  2 02:01:37 h1476 postfix/qmgr[18021]: 022ED51C001: from=<root@h1476.serverkompetenz.net>, size=702, nrcpt=1 (queue active)
Mar  2 02:01:37 h1476 postfix/local[23701]: 022ED51C001: to=<root@h1476.serverkompetenz.net>, relay=local, delay=1, status=sent (mailbox)
Mar  2 14:47:03 h1476 popper[30429]: Stats: web1p1 0 0 0 0 ACB6387F.ipt.aol.com 172.182.56.127 [pop_updt.c:296]
Mar  2 14:47:17 h1476 popper[30437]: Stats: web4p1 0 0 0 0 ACB6387F.ipt.aol.com 172.182.56.127 [pop_updt.c:296]
Die postfächer die auf dem server laufen und die abgefragt werden sind web1p1 (da läuft eine adresse drauf) und web4p1 (und hier 4 adressen) mehr net.

tonid
Posts: 7
Joined: 2003-10-31 15:19

Re: transport fehler

Post by tonid » 2004-03-11 15:14

also ich bekomm das einfach nich gebacken.

Kann mir da mal einer helfen, also per ICQ oder ich geb ihm mal zugriff auf den server. wär echt super, bin hier am verzweifeln

mein icq nr.: 120439183


danke
tonid