Kompilieren von Postfix 2.0.18

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
schl
Posts: 343
Joined: 2003-02-05 11:26
Location: München/Unterschleißheim

Kompilieren von Postfix 2.0.18

Post by schl » 2004-02-23 21:25

Hallo zusammen,

ich schaffe es nicht, den postfix 2.0.18 zu kompilieren. folgendes habe ich gemacht:

Code: Select all

make tidy 
make makefiles CCARGS="-DHAS_LDAP -DHAS_PCRE -DUSE_SASL_AUTH -DHAS_SSL " AUXLIBS="-lldap -llber â??lpcre -lsasl -lssl -lcrypto" 
make 
nach dem make kommt dann folgender fehler:

Code: Select all

[src/master]
gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DHAS_PCRE -DUSE_SASL_AUTH -DHAS_SSL  -g -O -I. -I../../include -DLINUX2 -o master master.o master_conf.o master_ent.o master_sig.o master_avail.o master_spawn.o master_service.o master_status.o master_listen.o master_vars.o master_wakeup.o master_flow.o ../../lib/libglobal.a ../../lib/libutil.a -lldap -llber .lpcre -lsasl -lssl -lcrypto -ldb -lnsl -lresolv
gcc: .lpcre: Datei oder Verzeichnis nicht gefunden
make: *** [master] Fehler 1
make: *** [update] Fehler 1
habe hier im forum gelesen, dass es meistens am fehlenden zlib-devel lag, aber das ist bei mir installiert. hat jemand eine idee?

danke

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Kompilieren von Postfix 2.0.18

Post by captaincrunch » 2004-02-23 21:28

Die PCRE-Library (Perl Compatible Regular Expressions, bzw. dessen Devel-Paket) ist in diesem Fall gemeint.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

schl
Posts: 343
Joined: 2003-02-05 11:26
Location: München/Unterschleißheim

Re: Kompilieren von Postfix 2.0.18

Post by schl » 2004-02-23 21:34

also pcre 3.9 war installiert

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Kompilieren von Postfix 2.0.18

Post by captaincrunch » 2004-02-23 21:38

Ich wusste, dass ich die Geschichte mit dem devel-Paket schon vorher hätte fett machen sollen. ;)
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

User avatar
Joe User
Project Manager
Project Manager
Posts: 11578
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Kompilieren von Postfix 2.0.18

Post by Joe User » 2004-02-23 21:45

LDAP-libs und -devel benötigst Du ebenfalls...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Kompilieren von Postfix 2.0.18

Post by captaincrunch » 2004-02-23 21:47

Und noch dazu solltest du den "." vor dem lpcre vielleicht in ein "-" umwandeln... ;)
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

schl
Posts: 343
Joined: 2003-02-05 11:26
Location: München/Unterschleißheim

Re: Kompilieren von Postfix 2.0.18

Post by schl » 2004-02-23 21:55

naja, ldap und das ganze zeugs waren installiert (da gibt es hier im forum ein howto) und für pcre bietet yast leider kein devel an.

es war der punkt :-)