Installation de PHP 4.3.3 - Neue Intallation für PHP 4.3.3

Bash, Shell, PHP, Python, Perl, CGI
oxooxo
Posts: 10
Joined: 2003-11-20 12:13
Location: Frankreich

Installation de PHP 4.3.3 - Neue Intallation für PHP 4.3.3

Post by oxooxo »

Bonjour,
Cela fait depuis deux jours que je cherche sur ce forum tous les messages parlant de la mise à jour de PHP pour des serveurs de 1&1.
J'ai trouvé de très bon messages qui disaient comment faire.
Pas de problèmes j'ai fait comme dans les documents, j'ai mis à jour ce qu'iol fallait pour les RPM.
Mais à un moment avec le ./configure il me donnait une erreur sur libpng.
J'ai remis à jour la librairie avec un .rpm
Ensuite il me donne une autre erreur et quand j'essaie de mettre a jour avec un autre RPM il me dit:

Code: Select all

p15148839:/usr/local/src/php-4.3.3 # rpm -Uvh libpng-1.2.5-25.i586.rpm
Segmentation fault
p15148839:/usr/local/src/php-4.3.3 #
Et j'ai cette erreur pour beaucoup de RPM maintenant.

Voici le code de mon .configure

Code: Select all

./configure --prefix=/usr/share --datadir=/usr/share/php --bindir=/usr/bin --libdir=/usr/share --includedir=/usr/include --with-_lib=lib --with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-ftp --enable-force-cgi-redirect --enable-gd-imgstrttf --enable-gd-native-ttf --enable-inline-optimization --enable-magic-quotes --enable-mbstr-enc-trans --enable-mbstring --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-bz2 --with-dom=/usr/include/libxml2 --with-ftp --with-gdbm --with-gettext --with-gmp --with-imap=yes --with-iodbc --with-jpeg-dir=/usr --with-ldap=yes --with-mcal=/usr --with-mcrypt --with-mysql=/usr --with-ndbm --with-pgsql=/usr --with-png-dir=/usr --with-qtdom=/usr/lib/qt2 --with-snmp --with-t1lib --with-tif-dir=/usr --with-ttf --with-freetype-dir --with-xml --with-swf=/usr/include/swf --with-xpm-dir=/usr/X11R6 --with-zlib=yes --with-gd=shared --with-openssl --with-curl --with-imap-ssl --enable-xslt --with-xslt-sablot --with-pdflib=/usr/lib/pdflib/bind/c --with-mm --with-apxs=/usr/sbin/apxs i586-suse-linux
Et voici l'erreur qu'il me donne à la fin du message d'installation:

Code: Select all

Configuring extensions
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... no
checking for gzgets in -lz... yes
checking whether to enable bc style precision math functions... yes
checking for BZip2 support... yes
checking for BZip2 in default path... found in /usr
checking for BZ2_bzerror in -lbz2... yes
checking whether to enable calendar conversion support... yes
checking for cpdflib support... no
checking for CRACKlib support... no
checking whether to enable ctype functions... yes
checking for CURL support... yes
checking for CURL in default path... found in /usr
checking for cURL 7.9.8 or greater... libcurl 7.9.8
checking for curl_easy_perform in -lcurl... yes
checking for curl_version_info in -lcurl... no
checking for cyrus imap support... no
checking for xDBM support... no
checking whether to enable DBA... no
checking for gdbm_open in -lgdbm... yes
checking for GDBM support... yes
checking for dbm_open in -lndbm... yes
checking for NDBM support... yes
checking for Berkeley DB4 support... no
checking for Berkeley DB3 support... no
checking for Berkeley DB2 support... no
checking for DBM support... no
checking for CDB support... builtin
checking for INI File support... builtin
checking for FlatFile support... builtin
checking whether to enable DBA interface... yes
checking whether to enable dbase support... yes
checking whether to enable dbx support... no
checking whether to enable direct I/O support... no
checking for DOM support... yes
not found
configure: error: Please reinstall the libxml >= 2.4.14 distribution
p15148839:/usr/local/src/php-4.3.3 #
Quelqu'un pourrait m'aider car la je ne sais plus quoi faire je suis bloquer, et plus aucun RPM ne s'install, j'ai toujours l'erreur qui revient.
Même en faisant

Code: Select all

shutdown-r now
cela n'arrange pas le problème.

Merci pour votre aide.
oxooxo
Posts: 10
Joined: 2003-11-20 12:13
Location: Frankreich

Re: Installation de PHP 4.3.3 - Neue Intallation für PHP 4.3.3

Post by oxooxo »

Guten Tag,
Das sorgt seit zwei Tagen dafür, daß ich auf diesem Forum alle Mitteilungen suche, die über die Aktualisierung PHP für 1&1.hosts sprechen
Ich habe von sehr gut gefunden Mitteilungen, die sagten, wie zu machen.
Nicht Probleme machte ich wie in den Dokumenten, ich habe auf den neuesten Stand gebracht, was iol für die RPM. notwendig war
Aber zu einem Zeitpunkt mit/stellt. er dar gab mir einen Fehler auf libpng.
Ich habe die Buchhandlung mit einem rpm aktualisiert
Danach gibt er mir einen anderen Fehler, und wenn ich versuche zu stellen, Tag mit einem anderen RPM hat er sagt mir:

Code: Select all

p15148839:/usr/local/src/php-4.3.3 # rpm -Uvh libpng-1.2.5-25.i586.rpm 
Segmentation fault 
p15148839:/usr/local/src/php-4.3.3 #
Und ich habe diesen Fehler für viele RPM jetzt.

Hier der Code von mein configure

Code: Select all

./configure --prefix=/usr/share --datadir=/usr/share/php --bindir=/usr/bin --libdir=/usr/share --includedir=/usr/include --with-_lib=lib --with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-ftp --enable-force-cgi-redirect --enable-gd-imgstrttf --enable-gd-native-ttf --enable-inline-optimization --enable-magic-quotes --enable-mbstr-enc-trans --enable-mbstring --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-bz2 --with-dom=/usr/include/libxml2 --with-ftp --with-gdbm --with-gettext --with-gmp --with-imap=yes --with-iodbc --with-jpeg-dir=/usr --with-ldap=yes --with-mcal=/usr --with-mcrypt --with-mysql=/usr --with-ndbm --with-pgsql=/usr --with-png-dir=/usr --with-qtdom=/usr/lib/qt2 --with-snmp --with-t1lib --with-tif-dir=/usr --with-ttf --with-freetype-dir --with-xml --with-swf=/usr/include/swf --with-xpm-dir=/usr/X11R6 --with-zlib=yes --with-gd=shared --with-openssl --with-curl --with-imap-ssl --enable-xslt --with-xslt-sablot --with-pdflib=/usr/lib/pdflib/bind/c --with-mm --with-apxs=/usr/sbin/apxs i586-suse-linux
Und hier der Fehler, den er mir zum Schluß der Einrichtungsmitteilung gibt:

Code: Select all

Configuring extensions 
checking for ZLIB support... yes 
checking if the location of ZLIB install directory is defined... no 
checking for gzgets in -lz... yes 
checking whether to enable bc style precision math functions... yes 
checking for BZip2 support... yes 
checking for BZip2 in default path... found in /usr 
checking for BZ2_bzerror in -lbz2... yes 
checking whether to enable calendar conversion support... yes 
checking for cpdflib support... no 
checking for CRACKlib support... no 
checking whether to enable ctype functions... yes 
checking for CURL support... yes 
checking for CURL in default path... found in /usr 
checking for cURL 7.9.8 or greater... libcurl 7.9.8 
checking for curl_easy_perform in -lcurl... yes 
checking for curl_version_info in -lcurl... no 
checking for cyrus imap support... no 
checking for xDBM support... no 
checking whether to enable DBA... no 
checking for gdbm_open in -lgdbm... yes 
checking for GDBM support... yes 
checking for dbm_open in -lndbm... yes 
checking for NDBM support... yes 
checking for Berkeley DB4 support... no 
checking for Berkeley DB3 support... no 
checking for Berkeley DB2 support... no 
checking for DBM support... no 
checking for CDB support... builtin 
checking for INI File support... builtin 
checking for FlatFile support... builtin 
checking whether to enable DBA interface... yes 
checking whether to enable dbase support... yes 
checking whether to enable dbx support... no 
checking whether to enable direct I/O support... no 
checking for DOM support... yes 
not found 
configure: error: Please reinstall the libxml >= 2.4.14 distribution 
p15148839:/usr/local/src/php-4.3.3 #
Jemandes könnte mir helfen, denn es weiß ich nicht mehr, das zu machen ich mich zu blockieren bin und mehr kein RPM install ich habe immer den Fehler, der zurückkommt.
Indem man sogar macht

Code: Select all

shutdown -r now
das richtet das Problem nicht ein.

Danke für Ihre Hilfe.
evoluzzer
Posts: 90
Joined: 2002-09-08 19:33
Location: www.internetists.de/index.php?s=14

Re: Installation de PHP 4.3.3 - Neue Intallation für PHP 4.3.3

Post by evoluzzer »

Bon jour,

selbes Problem hatte ich bei einem Testlauf mit einem Testrechner....hatte heute aber keine Zeit das Problem genauer zu untersuchen.

evtl. hilft
disablen von dom und xml, falls es nicht benötigt wird, das reinstall von libxml2 hat bei mir auch nicht geholfen.

Gruss Christoph