SSH-Login bei extra User funktioniert nicht

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
linuxdepp
Posts: 33
Joined: 2003-09-17 03:56

SSH-Login bei extra User funktioniert nicht

Post by linuxdepp »

Habe mit

Code: Select all

useradd username -g users -s /bin/bash -d /home/username -p passwort
unter Debian einen User angelegt. Anmelden kann ich mich mit selbigem aber nicht.
Wo liegt das Problem ?
Er meldet in auth.log ein Authentication failure. (Passwort 100% richtig.)

dodolin
Posts: 3840
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: SSH-Login bei extra User funktioniert nicht

Post by dodolin »

Eventuell ist Password-Auth deaktiviert? Aber das ist ja alles nur Rätselraten, darauf hab ich keine Lust.

Außerdem hättest du wohl besser adduser genommen.

linuxdepp
Posts: 33
Joined: 2003-09-17 03:56

Re: SSH-Login bei extra User funktioniert nicht

Post by linuxdepp »

sshd_config

Code: Select all

# Package generated configuration file
# See the sshd(8) manpage for defails

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# ...but breaks Pam auth via kbdint, so we have to turn it off
# Use PAM authentication via keyboard-interactive so PAM modules can
# properly interface with the user (off due to PrivSep)
PAMAuthenticationViaKbdInt no
# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 600
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# rhosts authentication should not be used
RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Uncomment to disable s/key passwords
#ChallengeResponseAuthentication no

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes


# To change Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#AFSTokenPassing no
#KerberosTicketCleanup no

# Kerberos TGT Passing does only work with the AFS kaserver
#KerberosTgtPassing yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
#PrintLastLog no
KeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net
#ReverseMappingCheck yes

Subsystem       sftp    /usr/lib/sftp-server

linuxdepp
Posts: 33
Joined: 2003-09-17 03:56

Re: SSH-Login bei extra User funktioniert nicht

Post by linuxdepp »

komisch mit adduser statt useradd klappts - versteh ich nicht - die Parameter sind doch die gleichen ?