Probleme auf meinen Rootserver mit Open Relay

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
light
Posts: 10
Joined: 2004-02-14 22:54

Probleme auf meinen Rootserver mit Open Relay

Post by light » 2004-02-14 23:01

hi hab schon alle MTA durch hab auch alles am laufen nur eins bekomm irgentwie nicht hin, bekomm meinen mailserver nicht dich, hießt das nur die user zugriff haben die auf meinen system gereggt sind also ist mein Mailserver offenes Relay hab deswegen auch schon ne mail bekommen von meinen isp, derzeit verwende ich Exim was muss ich wo einstellen damit er dicht ist danke für schnelle hilfe.

darkspirit
RSAC
Posts: 568
Joined: 2002-10-05 16:39
Location: D'dorf

Re: Probleme auf meinen Rootserver mit Open Relay

Post by darkspirit » 2004-02-14 23:03

SMTP-Auth eingestellt? Poste mal deine exim.conf (ohne Kommentare bitte).

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Probleme auf meinen Rootserver mit Open Relay

Post by light » 2004-02-14 23:10

Hier meine Conf:

spool_directory = /var/spool/exim_incoming
queue_only = true

qualify_domain = pure-bnet.de

local_domains = localhost:p15106483.pureserver.info:pure-bnet.de

local_domains_include_host = true
local_domains_include_host_literals = true

relay_domains = *


host_lookup = *

headers_check_syntax


host_accept_relay = 127.0.0.1:pure-bnet.de:p15106483.pureserver.info : ::::1

trusted_users = mail

smtp_verify = true

gecos_pattern = ^([^,:]*)
gecos_name = $1

smtp_accept_queue_per_connection = 100

freeze_tell_mailmaster = true

received_header_text = "Received:
${if def:sender_rcvhost {from ${sender_rcvhost}nt}
{${if def:sender_ident {from ${sender_ident} }}
${if def:sender_helo_name {(helo=${sender_helo_name})nt}}}}
by ${primary_hostname}
${if def:received_protocol {with ${received_protocol}}}
(Exim ${version_number} #${compile_number} (Debian))nt
id ${message_id}
${if def:received_for {ntfor <$received_for>}}"

receiver_try_verify = true


local_delivery:
driver = appendfile
group = mail
mode = 0660
mode_fail_narrower = false
envelope_to_add = true
return_path_add = true
file = /var/spool/mail/${local_part}

address_pipe:
driver = pipe
path = /usr/bin:/bin:/usr/local/bin
return_output


address_file:
driver = appendfile
envelope_to_add = true
return_path_add = true


address_directory:
driver = appendfile
no_from_hack
prefix = ""
suffix = ""

address_reply:
driver = autoreply

procmail_pipe:
driver = pipe
command = "/usr/bin/procmail"
return_path_add
delivery_date_add
envelope_to_add
# check_string = "From "
# escape_string = ">From "
suffix = ""



remote_smtp:
driver = smtp
# authenticate_hosts = pure-bnet.de
#smarthost.isp.com


defer_director:

driver = smartuser
new_address = :defer: All deliveries deferred
verify = false



real_local:
prefix = real-
driver = localuser
transport = local_delivery


system_aliases:
driver = aliasfile
file_transport = address_file
pipe_transport = address_pipe
file = /etc/aliases
search_type = lsearch
# user = list
# Uncomment the above line if you are running smartlist



userforward:
driver = forwardfile
file_transport = address_file
pipe_transport = address_pipe
reply_transport = address_reply
no_verify
check_ancestor
check_local_user
file = .forward
modemask = 002
filter


procmail:
driver = localuser
transport = procmail_pipe
require_files = ${local_part}:+${home}:+${home}/.procmailrc:+/usr/bin/procmail
no_verify


localuser:
driver = localuser
transport = local_delivery

end



defer_router:

driver = domainlist
self = defer
route_list = "* 127.0.0.1 byname"
verify = false



lookuphost:
driver = lookuphost
transport = remote_smtp


literal:
driver = ipliteral
transport = remote_smtp

end



# Domain Error Retries
# ------ ----- -------

* * F,2h,15m; G,16h,2h,1.5; F,4d,8h

end



*@p15106483.pureserver.info ${lookup{$1}lsearch{/etc/email-addresses}
{$value}fail} frFs

end


# plain:
# driver = plaintext
# public_name = PLAIN
# server_condition = "${if crypteq{$2}{${extract{1}{:}{${lookup{$1}lsearch{/etc/exim/passwd}{$value}{*:*}}}}}{1}{0}}"
# server_set_id = $1
#
login:
driver = plaintext
public_name = LOGIN
server_prompts = "Username:: : Password::"
server_condition = "${if crypteq{$2}{${extract{1}{:}{${lookup{$1}lsearch{/etc/exim/passwd}{$value}{*:*}}}}}{1}{0}}"
server_set_id = $1

# These examples below are the equivalent for client side authentication.
# They assume that you only use client side authentication to connect to
# one host (such as a smarthost at your ISP), or else use the same user
# name and password everywhere

# plain:
# driver = plaintext
# public_name = PLAIN
# client_send = "^username^password"
#
# login:
# driver = plaintext
# public_name = LOGIN
# client_send = ": username : password"
#
# cram_md5:
# driver = cram_md5
# public_name = CRAM-MD5
# client_name = username
# client_secret = password

# End of Exim configuration file

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Probleme auf meinen Rootserver mit Open Relay

Post by captaincrunch » 2004-02-14 23:49

DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Probleme auf meinen Rootserver mit Open Relay

Post by light » 2004-02-15 11:56

Irgentwie komm keine abfrage wenn über einen fake account gehe ich und versuche eine mail zu versenden

woran kann das liegen?

bei der emails abhohlen verwende ich popa3d das funktioniert das mit dem auth

wenn das pw nicht stimmt oder benutzer name ist aus im geläde, aber beim versenden ist wesendlich interessanter

aber das funktioniert nicht

Bitte helft mir

thx im vorraus

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Probleme auf meinen Rootserver mit Open Relay

Post by dodolin » 2004-02-15 14:49

relay_domains = *
Kein Wunder. -> Ã?ndern!

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Probleme auf meinen Rootserver mit Open Relay

Post by light » 2004-02-15 18:31

ja aber in was ? soll ich das ändern das es daran liegt hatte mitlerweile aus rausbekommen nur wenn dort die domain eintrage vom server dann kann nur noch über server versenden und nicht mehr über outlook z.b

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Probleme auf meinen Rootserver mit Open Relay

Post by dodolin » 2004-02-16 00:27

ja aber in was ?
relay_domains =

So!

Und für den Rest: Befasse dich mit SMTP AUTH, es wird allerhöchste Zeit.