GMX + Spamfilter + RootServer

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
projekt2501
Posts: 92
Joined: 2003-08-14 08:23

GMX + Spamfilter + RootServer

Post by projekt2501 » 2004-02-14 18:44

Hi,

ich hab auf dem Rootie, per Confixx ne Mailweiterleitung gemacht. Hat bisher auch alles gut funktioniert. Seit neuestem kommen die mails, die auf diese Weise weitergeleitet werden nicht mehr durch den Spamfilter von GMX. Folgende Begründung:

Code: Select all

GMX Spamschutz Spamserver-Blocker: Diese e-mail wurde nicht über den tatsächlichen Mailserver des Absenderdienstes eingeliefert. 
Jetzt stellt sich mir die Frage, wie ich dem Mailserver beibiege, dass der das so macht, der Spam-Filter sich nicht dran stört.

Der Server ist KEIN Open-Relay. Hab das auch nochmal mit dem Check von 1&1 validiert.[/code]

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: GMX + Spamfilter + RootServer

Post by captaincrunch » 2004-02-14 19:17

Mach doch mal ein nslookup auf die IP-Adresse deines Servers.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: GMX + Spamfilter + RootServer

Post by dodolin » 2004-02-14 19:46

Bringt alles nichts. Der "GMX-Spamserver-Blocker" ist merkbefreit, aber leider per Default aktiviert. Die jeweiligen GMX-Kunden können ihn aber abschalten, wenn sie wollen. Wer ihn - wissentlich oder unwissentlich (die Mehrheit, vermutlich) - aktiviert hat, ist selbst schuld, anders kann man das nicht nennen...

projekt2501
Posts: 92
Joined: 2003-08-14 08:23

Re: GMX + Spamfilter + RootServer

Post by projekt2501 » 2004-02-14 20:37

nslookup auf dem eigenen Server:

Code: Select all

p15147309:~ # nslookup 217.160.205.43
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server:         217.160.205.251
Address:        217.160.205.251#53

** server can't find 43.205.160.217.in-addr.arpa.: NXDOMAIN

nslookup auf meinem lokalen rechner

Code: Select all

C:Dokumente und EinstellungenProjekt2501>nslookup 217.160.205.43
*** Der Servername für die Adresse 192.168.1.1 konnte nicht gefunden werden:
Non-existent domain
*** Die Standardserver sind nicht verfügbar.
Server:  UnKnown
Address:  192.168.1.1

*** 217.160.205.43 wurde von UnKnown nicht gefunden: Non-existent domain
sieht für mich so aus, als ob ich da nen problem mit der config vom bind nameserver habe, irgendwelche vorschläge was ich vergessen habe ?

tischi
Posts: 215
Joined: 2003-10-26 17:57

Re: GMX + Spamfilter + RootServer

Post by tischi » 2004-02-14 20:57

mh, lass doch erstmal mal die config files sehen, dann können wir dir ja vielleicht sagen, was du vergessen hast :wink:

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: GMX + Spamfilter + RootServer

Post by dodolin » 2004-02-14 21:27

Du hast nichts vergessen, 1und1 hat den RDNS vergessen oder benötigt noch ein paar Tage, bis er funktioniert. Wenn du den Server neu hast oder in den letzten Tagen die Hauptdomain gewechselt, umgezogen oder whatever hast, würde ich einfach noch ein paar Tage warten, ansonsten den Support anmailen, dass man dir den RDNS richten möge...

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: GMX + Spamfilter + RootServer

Post by floschi » 2004-02-14 21:31

RDNS-Probs - gibt's derzeit anscheinend häufiger.

projekt2501
Posts: 92
Joined: 2003-08-14 08:23

Re: GMX + Spamfilter + RootServer

Post by projekt2501 » 2004-02-14 21:31

so... hier mal die configs... wenn ihr noch was braucht will ich das wohl posten

/etc/named.conf

Code: Select all

options {
    directory "/var/named";
#    forwarders { 195.20.224.234; 195.20.224.99; };
    listen-on port 53 { 127.0.0.1; 217.160.205.43; };
#    listen-on-v6 { none; };
    allow-transfer { 195.20.224.97; 195.20.225.34; };
    allow-query { 127.0.0.1; 217.160.205.43; 195.20.224.97; 195.20.225.34; };
    notify no;
    auth-nxdomain no;
    allow-recursion { 127.0.0.1; 217.160.205.43; };
};

zone "localhost" in {
    type master;
    file "/var/named/localhost.zone";
};

zone "0.0.127.in-addr.arpa" in {
    type master;
    file "/var/named/127.0.0.zone";
};

zone "." in {
    type hint;
    file "/var/named/root.hint";
};

zone "griese-medien.de" { type master; file "/var/named/griese-medien.de.zone"; allow-query { any; }; };

zone "griese-verlag.de" { type master; file "/var/named/default.zone"; allow-query { any; }; };
/var/named/griese-medien.de.zone

Code: Select all

$TTL 1W
@               IN      SOA     ns.griese-medien.de. webmaster.griese-medien.de. (
                                2004012601      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                11h )           ; minimum

;
; Zone name server records
;
@       IN      NS      ns;
@       IN      NS      ns.schlund.de.;

;
; Zone records
;
@       IN      A       217.160.205.43
*       IN      A       217.160.205.43
www     IN      A       217.160.205.43
mail    IN      A       217.160.205.43
ns      IN      A       217.160.205.43
/var/named/default.zone

Code: Select all

$TTL 1W
@               IN      SOA     ns.griese-medien.de. webmaster (
                                2004010802      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                11h )           ; minimum

;
; Zone name server records
;
@       IN      NS      ns.griese-medien.de.;
@       IN      NS      ns.schlund.de.;

;
; Zone records
;
@       IN      A       217.160.205.43
*       IN      A       217.160.205.43
www     IN      A       217.160.205.43
/var/named/127.0.0.zone

Code: Select all

$TTL 1W
@               IN SOA          localhost.   root.localhost. (
                                42              ; serial (d. adams)
                                2D              ; refresh
                                4H              ; retry
                                6W              ; expiry
                                1W )            ; minimum

                IN NS           localhost.
1               IN PTR          localhost.
/var/named/localhost.zone

Code: Select all

$TTL 1W
@               IN SOA  @   root (
                                42              ; serial (d. adams)
                                2D              ; refresh
                                4H              ; retry
                                6W              ; expiry
                                1W )            ; minimum

                IN NS           @
                IN A            127.0.0.1

projekt2501
Posts: 92
Joined: 2003-08-14 08:23

Re: GMX + Spamfilter + RootServer

Post by projekt2501 » 2004-02-14 21:33

dodolin wrote:Du hast nichts vergessen, 1und1 hat den RDNS vergessen oder benötigt noch ein paar Tage, bis er funktioniert. Wenn du den Server neu hast oder in den letzten Tagen die Hauptdomain gewechselt, umgezogen oder whatever hast, würde ich einfach noch ein paar Tage warten, ansonsten den Support anmailen, dass man dir den RDNS richten möge...
Bin wirklich mit dem Server umgezogen, von dem alten Rootie auf den neuen. :)
Das ist aber schon einen Monat her!

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: GMX + Spamfilter + RootServer

Post by floschi » 2004-02-15 11:27

olfi wrote:RDNS-Probs - gibt's derzeit anscheinend häufiger.
Ich wiederhol mich gerne, d.h. beim Support nachfragen, was da los ist.