Postfix & smtp-auth --- mal wieder

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
scrounger
Posts: 8
Joined: 2003-07-05 13:00
Location: Köln, München

Postfix & smtp-auth --- mal wieder

Post by scrounger » 2004-02-10 11:50

Hi,
ich habe die letzten paar Tage damit zugebracht mich in diesem und vergleichbaren Foren umzusehen udn auch hunderte Hilfen gefuden, aber entweder ich bin zu blöd dazu oder ich übersehe immer was.

Ich habe einen Server mit Suse 8.1 auf dem Postfix mit SMTP AUTH arbeiten soll.

Imemrhin fragt er inzwischen nach ne PW, aber das klappt nich.
Hier der Auszug aus dem log:

Code: Select all

Feb 10 11:44:18 linux postfix/smtpd[13756]: connect from dsl-213-023-013-244.arcor-ip.net[213.23.13.244]
Feb 10 11:44:21 linux postfix/smtpd[13756]: warning: dsl-213-023-013-244.arcor-ip.net[213.23.13.244]: SASL CRAM-MD5 authentication failed
Feb 10 11:44:26 linux postfix/smtpd[13756]: warning: dsl-213-023-013-244.arcor-ip.net[213.23.13.244]: SASL PLAIN authentication failed
Feb 10 11:44:31 linux postfix/smtpd[13756]: warning: dsl-213-023-013-244.arcor-ip.net[213.23.13.244]: SASL LOGIN authentication failed

hier die entsprechenden Passagen aus der main.conf

Code: Select all

smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination, check_sender_access hash:/etc/postfix/access, reject_maps_rbl, reject_unknown_sender_domain
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtp_sasl_password_maps = /etc/sasldb
die /etc/postfix/sasl/smtpd.conf sieht so aus:

Code: Select all

pwcheck_method: sasldb
mech_list: plain login


Wenn jemand ne Idee hat wäre ich doch sehr dankbar, verliere langsam die Hoffnung ;>[/code]

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Postfix & smtp-auth --- mal wieder

Post by squize » 2004-02-10 13:54

Ein Grund warum es oft in die Hose geht, ist die der fehlende Realm :)

Wenn du mit sasldblistusers mal die Liste deiner User anschaust, dann wird dir auffallen, dass es da etwas gibt, dass sich realm nennt.
Du musst also nicht nur deinen User angeben, sondern auch den korrekten realm ( user@realm).
Falls dir das zu blöd ist, dann kannst du in der main.cf mit dem Parameter

smtp_sasl_local_domain = sasl_domain

postfix anweisen, diese Domain als standard zu nehmen. Dann reicht es nur den user beim Login anzugeben.Wenn es dann immernochnicht geht, dann ist den backend irgenwie noch nicht richtig konfiguriert.

scrounger
Posts: 8
Joined: 2003-07-05 13:00
Location: Köln, München

Re: Postfix & smtp-auth --- mal wieder

Post by scrounger » 2004-02-10 16:24

Danke schonma.

sasldblistusers bringt folgendes:.

Code: Select all

user: scrounger realm: linux mech: PLAIN
user: scrounger realm: linux mech: CRAM-MD5
user: scrounger realm: linux mech: DIGEST-MD5
demnach müsste ich dann den authuser scrounger@linux nennen?

und in der main.cf einfach genau die Zeile von dir, oder für sasl_domain die echte domain eintragen?

Weil auch nach dieser Ã?nderung und nem postfix reload bei neuen Usern weiterhin als realm linux in der db steht und ich auch mit @linux zu keinem besseren Ergebniss komme.

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Postfix & smtp-auth --- mal wieder

Post by squize » 2004-02-10 18:02

Da werden nur Logs weiterhelfen.

Die Sache mit mech_list: plain login funktioniert nur bei SASL Version 2, also mal überprüfen, ob du auch Version 2 installiert hast, obwohl, wenn der befehl sasldblistusers funktoniert, dann hast du Version 1.

Also
mech_list: plain login <- mal rausnehmen
smtp_sasl_password_maps = /etc/sasldb <- auch rausnhemen
broken_sasl_auth_clients = yes <- einfügen sonst macht Outlook Probleme

Auth Howto

Gruss

Marc

scrounger
Posts: 8
Joined: 2003-07-05 13:00
Location: Köln, München

Re: Postfix & smtp-auth --- mal wieder

Post by scrounger » 2004-02-12 16:17

thx