Kein pop3s nach Postfix-update

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
fob
Posts: 18
Joined: 2003-05-01 00:37

Kein pop3s nach Postfix-update

Post by fob » 2004-02-09 23:20

Guten Abend!

Ich habe mir mal vor 2 Tagen die Mühe gemacht und Postfix auf meinem 1&1 Rootserver nach der Anleitung in den FAQs vom rootforum geupdated.

Ging auch alles wunderbar und einfach (danke nochmal fürs Tut) ausser dem folgenden Problem:

Ich kann nicht mehr per SSL zum Popserver verbinden. (ja, wurde mit SSL-Support compiled)
/var/log/mail zeigt keine Einträge also hab ich mir mal die xinetd logs angeguckt und folgendes gefunden:

Code: Select all

04/2/9@23:05:59: START: pop3 pid=13665 from=127.0.0.1
04/2/9@23:06:00: EXIT: pop3 status=0 pid=13665 duration=1(sec)
Daraufhin hab ich mal probiert von Hand zum POP3S Port 995 zu connecten und stiess auf folgende Message:

Code: Select all

fob@server:~> netcat localhost 995
2004.02.09 23:05:17 LOG3[13664:1024]: qpopper: No such file or directory (2)

Syntax:
stunnel [filename] | -help | -version | -sockets
    filename    - use specified config file instead of /etc/stunnel/stunnel.conf
    -help       - get config file help
    -version    - display version and defaults
    -sockets    - display default socket options
Also liegts höchstwahrscheinlich an der Config vom xinetd, darum zeig ich euch mal meine Config für POP3S:

Code: Select all

service pop3
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/sbin/popper
        server_args = qpopper -s
        log_on_success  = HOST PID EXIT DURATION
        log_on_failure  = HOST ATTEMPT
}

# *grrr* SuSE-8.1: qpopper.rpm compiled without ssl/tls-support
service pop3s
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/sbin/stunnel
        server_args = qpopper -l /usr/sbin/popper -- -R -s
        log_on_success  = HOST PID EXIT DURATION
        log_on_failure  = HOST ATTEMPT
}
Ich denke mal dass es einfach an der Config von "server_args" bei pop3s liegt, aber auch der Kommentar "# *grrr* SuSE-8.1: qpopper.rpm compiled without ssl/tls-support" macht mir etwas Sorgen.

Hier noch n paar Infos zum Server selber:
1&1 Rootserver L mit Suse 8.1 und Celeron CPU 2.00GHz
Postfix version: 2.0.18
Popper version: Qpopper Modified by SuSE version 4.0.4 (non-standalone)

Ich hoffe, dass damit fast alle Infos da sind die ihr so braucht um mir zu helfen und ihr eure Glaskugeln nicht strapazieren müsst :-D

Danke schonmal im Vorraus
fob

fob
Posts: 18
Joined: 2003-05-01 00:37

Re: Kein pop3s nach Postfix-update

Post by fob » 2004-02-10 17:19

Update:

Nachdem ich aus der xinetd.conf den pop3s abschnitt rausgeworfen hab und in der stunneld.conf wie in einem anderen Thread beschrieben pop3s gemappt habe geht der pop3s zugang nun endlich.

Jedoch geht der connect zum smtps über SSL immernoch nicht.

Vielleicht weiss ja jemand ne Antwort.