Image Magick lässt sich nicht kompilieren

Bash, Shell, PHP, Python, Perl, CGI
moppi
Posts: 368
Joined: 2003-02-15 11:16

Image Magick lässt sich nicht kompilieren

Post by moppi »

Ich habe gerade die Source Distribution heruntergeladen
es handelt sich um Version 5.5.7 Stable
folgende Meldung mach "./configure"

Code: Select all

jp2.c: In function `ReadJP2Image':
jp2.c:343: warning: implicit declaration of function `jas_clrspc_fam'
jp2.c:343: warning: implicit declaration of function `jas_image_clrspc'
jp2.c:345: `JAS_CLRSPC_FAM_RGB' undeclared (first use in this function)
jp2.c:345: (Each undeclared identifier is reported only once
jp2.c:345: for each function it appears in.)
jp2.c:347: warning: implicit declaration of function `jas_image_getcmptbytype'
jp2.c:348: warning: implicit declaration of function `JAS_IMAGE_CT_COLOR'
jp2.c:348: `JAS_CLRSPC_CHANIND_RGB_R' undeclared (first use in this function)
jp2.c:350: `JAS_CLRSPC_CHANIND_RGB_G' undeclared (first use in this function)
jp2.c:352: `JAS_CLRSPC_CHANIND_RGB_B' undeclared (first use in this function)
jp2.c:361: `JAS_IMAGE_CT_OPACITY' undeclared (first use in this function)
jp2.c:369: `JAS_CLRSPC_FAM_GRAY' undeclared (first use in this function)
jp2.c:372: `JAS_CLRSPC_CHANIND_GRAY_Y' undeclared (first use in this function)
jp2.c:382: `JAS_CLRSPC_FAM_YCBCR' undeclared (first use in this function)
jp2.c: In function `WriteJP2Image':
jp2.c:751: warning: implicit declaration of function `jas_image_setclrspc'
jp2.c:751: `JAS_CLRSPC_SGRAY' undeclared (first use in this function)
jp2.c:752: warning: implicit declaration of function `jas_image_setcmpttype'
jp2.c:753: `JAS_CLRSPC_CHANIND_GRAY_Y' undeclared (first use in this function)
jp2.c:760: `JAS_CLRSPC_SRGB' undeclared (first use in this function)
jp2.c:762: `JAS_CLRSPC_CHANIND_RGB_R' undeclared (first use in this function)
jp2.c:764: `JAS_CLRSPC_CHANIND_RGB_G' undeclared (first use in this function)
jp2.c:766: `JAS_CLRSPC_CHANIND_RGB_B' undeclared (first use in this function)
jp2.c:769: `JAS_IMAGE_CT_OPACITY' undeclared (first use in this function)
make[1]: *** [jp2.lo] Error 1
make[1]: Leaving directory `/tmp/ImageMagick-5.5.7/coders'
make: *** [all-recursive] Error 1
jasper libs sind alle installiert auch "./configure" meldet bereits fehler:

Code: Select all

checking if JPEG package is complete... yes checking for JPEG version 2 support ...
checking jasper/jasper.h usability... no checking jasper/jasper.h presence... yes
configure: WARNING: jasper/jasper.h: present but cannot be compiled
configure: WARNING: jasper/jasper.h: check for missing prerequisite headers?
configure: WARNING: jasper/jasper.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING:     ## ------------------------------------ ##
checking for jasper/jasper.h... yes
checking for jas_stream_fopen in -ljasper... yes checking if JPEG version 2 support package is complete... yes
Vielen Dank für jede Hilfe
moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: Image Magick lässt sich nicht kompilieren

Post by moppi »

ich habe gerade versucht diese lib nicht zu benutzen:

Code: Select all

./configure --with-ljasper=no --with-ljasper2=no
leider alles erfolglos.
moppi
Posts: 368
Joined: 2003-02-15 11:16

Re: Image Magick lässt sich nicht kompilieren

Post by moppi »

Problem gelöst:

jasper jpeg lib oder so ähnlich muss neu werden :)

hier der link:
http://www.ece.uvic.ca/~mdadams/jasper/

jasper installieren, evtl. zlib, dann imagemagik installieren.
zlib kann mit yast eingespielt werden.

Wer sich die sucherei sparen will kann es hier alles downloaden:
http://www.rindt.name/im_jj.tgz
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Image Magick lässt sich nicht kompilieren

Post by captaincrunch »

-> Scripting
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc