SpamAssassin Header Konfiguration

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
arnee
Posts: 54
Joined: 2003-09-30 21:32

SpamAssassin Header Konfiguration

Post by arnee » 2004-02-03 20:34

Hallo,

ich habe das Gefühl, dass die local.cf von SpamAssassin immer noch nicht richtig erkannt wird.

Meine Konfiguration:
Auszug aus der master.cf:
smtp inet n - n - - smtpd
-o content_filter=postfixfilter:
[...]
postfixfilter unix - n n - - pipe
flags=Rq user=amavis argv=/var/amavis/filter.sh -f ${sender} -- ${recipient}
/var/amavis/filter.sh:
#!/bin/bash

# /usr/local/bin/spamassassin -P | /usr/sbin/sendmail -i "$@"
/usr/local/bin/spamc | /usr/sbin/sendmail -i "$@"

exit $?
Auszug aus der /etc/mail/spamassassin/local.cf:
# clear_headers
add_header spam FLAG _YESNOCAPS_
add_header all Status _YESNO_, hits=_HITS_ required=_REQD_ version=_VERSION_
add_header all Level _STARS(*)_
add_header all Level _TESTS(,)_
add_header all Level _TESTSCORES(,)_
add_header all Checker-Version SpamAssassin _VERSION_ on _HOSTNAME_
fold_headers 1
Wenn ich jetzt eine eMail an einen Account des Systems schicke, wird SpamAssassin zwar aktiv, aber nicht ganz so, wie ich es möchte:
X-Spam-Status: No, hits=0.3 required=5.0 version=2.63
X-Spam-Level:
X-Spam-Checker-Version: SpamAssassin 2.63 on srv1.domain.lan

Und so stelle ich mir es vor (vorallem die Auflistung mit den Sternen):
X-Spam-Status: No, hits=0.2 required=5.0
tests=HTML_70_80,HTML_FONT_COLOR_BLUE,HTML_MESSAGE,IN_REP_TO
version=2.55
X-Spam-Level:
X-Spam-Checker-Version: SpamAssassin 2.55 (1.174.2.19-2003-05-19-exp)
X-Spam-Report: ---- Start SpamAssassin results
0.20 points, 5 required;
* -0.5 -- Has a In-Reply-To header
* 0.1 -- BODY: HTML included in message
* 0.1 -- BODY: HTML font color is blue
* 0.5 -- BODY: Message is 70% to 80% HTML
---- End of SpamAssassin results
X-Spam-Processed: domain.de, Sat, 31 Jan 2004 19:41:57 +0100

Jemand eine Idee, was ich korrigieren muss ?

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: SpamAssassin Header Konfiguration

Post by dodolin » 2004-02-03 20:49

Jemand eine Idee, was ich korrigieren muss ?
clear_headers aktivieren (Kommentarzeichen entfernen)?
spamd neu starten (HUP Signal schicken) nicht vergessen?

arnee
Posts: 54
Joined: 2003-09-30 21:32

Re: SpamAssassin Header Konfiguration

Post by arnee » 2004-02-03 21:16

Hallo,

Neustarten der Dienste ist klar. :)

clear_headers hat aber auch keinen Erfolg gebracht. :(
Hast du oder jemand anderes sonst noch eine Idee?

Vielen Dank

ego
Posts: 87
Joined: 2003-07-21 10:18

Re: SpamAssassin Header Konfiguration

Post by ego » 2004-02-04 14:34

Du mußt zuerst den Standard-Header mit Remove_Header entfernen. Dann fügst du deinen eigenen Header mittels Add_Header hinzu.
Wie das geht steht in der Doku von SA -> http://www.spamassassin.org/doc/Mail_Sp ... %20options

So hab ich es gemacht:
remove_header all Status _YESNO_, hits=_HITS required=_REQD_ tests=_TESTS_ autolearn=_AUTOLEARN_ version=_VERSION_
remove_header all Level _STARS(*)_
remove_header all Checker-Version SpamAssassin _VERSION_ (_SUBVERSION_) on _HOSTNAME_
clear_headers
add_header all Status _YESNO_
add_header all Checker-Version SpamAssassin _VERSION_

arnee
Posts: 54
Joined: 2003-09-30 21:32

Re: SpamAssassin Header Konfiguration

Post by arnee » 2004-02-06 15:31

Hat leider auch keinen Erfolg gebracht ....