problem mit script

MySQL, PostgreSQL, SQLite
schorsch
Posts: 43
Joined: 2003-01-28 02:42

problem mit script

Post by schorsch » 2004-02-02 21:08

hallo,

benutze hivemail, allerdings funktioniert der mail empfang damit nicht, die mails kommen einfach nicht an (ohne fehlermeldung)

habe dann mal die hivemail_process.php manuell in SSH ausgeführt, dabei kam dann folgende fehlermeldung raus:
<b>Fatal error</b>: Call to undefined function: mysql_connect() in <b>/var/www/mail/includes/db_mysql.php</b> on line <b>80</b><br />
php4-mysql ist installiert und extension=mysql.so ist auch in der php.ini eingetragen.
benutze debian 3 'woody'.

habe mal gelesen das mysql (? )bei debian chrooted (im 'jail') ausgeführt wird.

kann es was damit zu tun haben? wie bekomm ich das zum laufen??

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: problem mit script

Post by lufthansen » 2004-02-02 21:34

läuft das vllt als php4-cgi
den da ist kein mysql modul drin

schorsch
Posts: 43
Joined: 2003-01-28 02:42

Re: problem mit script

Post by schorsch » 2004-02-02 22:24

nein läuft nicht als php4-cgi

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: problem mit script

Post by oxygen » 2004-02-02 23:33

Klar, wenn du es manuelle auführst läuft es über cgi/cli und in der zuständigen php.ini wird das modul nicht geladen.

schorsch
Posts: 43
Joined: 2003-01-28 02:42

Re: problem mit script

Post by schorsch » 2004-02-03 00:22

ich habe das modul dort aber auch eingetragen, geht trotzdem nicht