libmysqlclient.so.10 Problem

MySQL, PostgreSQL, SQLite
blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

libmysqlclient.so.10 Problem

Post by blnsnoopy26 » 2004-01-31 17:46

Hi,

Ich habe nun auch das selbe Problem wie es hier beschrieben ist:
http://www.rootforum.org/forum/viewtop ... ysqlclient

Aber ich habe dort leider die Lösung nicht gefunden :(

Code: Select all

Can't load '/root/confixx/mysql.so' for module DBD::mysql: libmysqlclient.so.10: cannot load shared object file: No such file or directory at PERL2EXE_STORAGE/DynaLoader.pm line 206.
 at confixx_counterscript.pl line 37
Compilation failed in require at confixx_counterscript.pl line 37.
BEGIN failed--compilation aborted at confixx_counterscript.pl line 37.
Aber ich habe weder hier im Forum noch via Google eine Lösung gefunden.
Kann mir dabei jemand helfen das Problem zu lösen??


All das passierte als ich auf mysql 4.0.17 upgedatet hatte.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: libmysqlclient.so.10 Problem

Post by Joe User » 2004-01-31 21:21

Installiere die MySQL-compat-libs...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: libmysqlclient.so.10 Problem

Post by blnsnoopy26 » 2004-01-31 22:21

Joe User wrote:Installiere die MySQL-compat-libs...
Die sind Installiert, aber dennoch kommt der Fehler :(

Hier die Paketauskunft meiner installierten rpms
MySQL-client MySQL - Client
MySQL-devel MySQL - Development header files and libraries
MySQL-server MySQL: a very fast and reliable SQL database server
MySQL-shared-compat MySQL shared libraries for MySQL 4.0.17 and 3.23.58

und ein locate ergibt:
locate libmysqlclient.so
/usr/lib/libmysqlclient.so
/usr/lib/libmysqlclient.so.10
/usr/lib/libmysqlclient.so.10.0.0
/usr/lib/mysql/libmysqlclient.so
also alles da, daher verstehe ich das ja nicht.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: libmysqlclient.so.10 Problem

Post by Joe User » 2004-02-02 21:23

Installiere Confixx neu, die compat-libs scheinen für Confixx zu aktuell zu sein...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: libmysqlclient.so.10 Problem

Post by blnsnoopy26 » 2004-02-02 21:27

Hi,

Ok ich werde es mal versuchen und mal sehn was dann passieren wird :wink:

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: libmysqlclient.so.10 Problem

Post by blnsnoopy26 » 2004-02-04 23:37

Also mit Confixx neu installieren is da nicht mehr :(
Perl ist wohl total zerschossen :(

Wenn ich z.b die admin.pl aufrufen möchte im confixx Ordner, dann folgendes:

Code: Select all

Can't locate DBI.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i586-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at ./admin.pl line 12.
BEGIN failed--compilation aborted at ./admin.pl line 12.
Hab alles versucht es wieder hinzubekommen, aber ohne erfolg.
Habe vor Perl komplett zu deinstallieren und neu aufzusetzen, aber ich habe weder passende rpms gefunden noch ein deutsches howto und hier im Forum auch nix zu gefunden :(

In den Howtos hier im Forum, wird zwar beschrieben wie php und apache installiert wrd, aber nicht Perl.

Hatte mir auch von http://www.perl.com das teil gesaugt und versucht zu installieren, aber auch ohne Erfolg.

Gibs denn irgendwo eine deutsche Anleitung für eine neuinstallation von Perl? Also alte Löschen und neu aufsetzen?

Wäre cool wenn da einer was weiss!

Ich arbeite noch mit SuSe 7.2.