Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by Outlaw » 2004-01-16 17:40

Hallo Leute,

ich habe heute einen Kernel Update gemacht, seit dem geht der Mailversand nicht mehr (Empfang geht einwandfrei), woran kann das liegen ??

1&1 PS Server
SuSE 8.2
Postfix 2.0.1x
Kernel 2.4.24

Ich musste die XINETD.CONF anpassen (RECORD raus), ich weis nicht, obs daran lag aber XINETD läuft jetzt wieder und ich weiss auch nicht, ob das irgendwie damit zusammenhängt.

Webmail geht, auch das Senden.

Gruß Outi

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by dodolin » 2004-01-16 17:47

seit dem geht der Mailversand nicht mehr
Der Anzahl Postings nach sollte man annehmen, du solltest wissen, dass man mit dieser "Fehlerbeschreibung" genau gar nichts anfangen kann!

Also dann rück mal raus mit den Details? Was funktioniert nicht, was sagen die Logs, hast du den Kernel irgendwie anders konfiguriert (Sicherheitspatches, etc.)? Iptables geladen?

Hatte ich schonmal erwähnt, dass es mir auf den Keks geht, wenn man die Informationen erst aus der Nase rausziehen muss?!

r00ty
Posts: 747
Joined: 2003-03-17 15:32

Re: Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by r00ty » 2004-01-16 18:05

lol, hab selten so gelacht als ich den Beitrag von dir gelesen habe...
es ist traurig aber wahr :)
da muss jemand heute echt genervt sein

also Outlaw, rück raus mit den logs (und vielleicht nem Portscan von intern und extern)

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by Outlaw » 2004-01-16 20:37

Aua und danke für die Blumen ....

Ich dachte, das wäre so ne Art Standardproblem. Kernel geupdated, Mail empfangen geht aber nicht senden, ergo Schraube 388,56 und alles wird gut.

Also, habe den Fehler beheben können.

Mit

Code: Select all

saslauthd -a pam
geht es wieder.
Der Anzahl Postings nach sollte man annehmen, du solltest wissen, dass man mit dieser "Fehlerbeschreibung" genau gar nichts anfangen kann!
Die Anzahl der Postings sagt doch gar nix aus .... ;):D
(Nääää, ich gebs zu, ich war etwas "daneben", steckt halt an.)
Also dann rück mal raus mit den Details? Was funktioniert nicht, was sagen die Logs, hast du den Kernel irgendwie anders konfiguriert (Sicherheitspatches, etc.)? Iptables geladen?
Was nicht funktioniert, habe ich doch geschrieben, der Mailversand über SMTP ging nicht. Logs hatte ich durchgecheckt aber ich muss mal wieder Tomaten auf den Augen haben. Kernel ist 1:1 unverändert von 1&1, wie gesacht, ich hab nix gemacht, ausser den Kernel geupdated.
Hatte ich schonmal erwähnt, dass es mir auf den Keks geht, wenn man die Informationen erst aus der Nase rausziehen muss?!
Kann ich verstehen, sorry. Ich dachte nur, die Infos reichen aber bitte nicht mehr schlagen, ich versuche es das nächste mal besser, ehrlich.

Nunja, geht ja wieder alles. Würde mich aber trotzdem interessieren, wie es dazu kam. Verm. wird saslauthd nicht automatisch gestartet, kann ich aber damit leben, jetzt weis ich es ja.

Danke und Gruß Outi

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by dodolin » 2004-01-17 14:08

Was nicht funktioniert, habe ich doch geschrieben, der Mailversand über SMTP ging nicht. Logs hatte ich durchgecheckt aber ich muss mal wieder Tomaten auf den Augen haben.
Nun, nenn mich blauäugig, aber ich bin der Meinung, wenn "der Mailversand nicht geht" und der MTA aber läuft, dann sollte dieser zu diesen Problemen auch etwas in seinen Logs festhalten.

Aber ist ja gut, wenn du das Problem inzwischen schon selbst beheben konntest, freut mich.

Nimms nicht so hart, dass ich etwas barsch war, aber wenn man immer wieder solche Postings mit zu wenig Infos liest, staut sich da mit der Zeit was bei mir auf (ist so ähnlich wie nen Samenstau, der muss auch irgendwann mal raus ;) ), und da ich dachte, dass du das "verkraften" kannst, hatte ich halt mal dich als Opfer ausgewählt, um meinen gestressten Nerven etwas Luft zu machen... :) Peace!

PS: Ich bin halt der Meinung, dass man sich ruhig gegenseitig (in Maßen) anpflaumen sollte (sofern gerechtfertigt), sich dafür aber hinterher auch wieder vertragen sollte (sofern möglich).

phpman
Posts: 66
Joined: 2003-11-02 23:06

Re: Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by phpman » 2004-01-19 22:14

Hallo,

ich weiss nicht wie sich Dein Problem äussert, ich habe nämlich ein ähnliches:

Mail kommt für web2p2 rein und wird jedoch von postfix 2.0.16 an web1p1 weitergeleitet und somit falsch einsortiert.

Ausser den "online Updates" für das XINETD und Apache, und die installation von "Postfix habe ich auch nichts geändert.

Auf einem anderen Server mit Postfix 1.x.12 läuft alles wie es soll.

Im Mail Log steht so kein fehler (siehe mein anderes Posting!)

Im WarnLog hingegen das:

Jan 19 12:20:00 postfix/trivial-rewrite[6964]: warning: do not list domain domain.de in BOTH mydestination and virtual_alias_domains

Was macht das aus? Liegt hier der Fehler?

Da ALLES !! egal was nicht dort landet wo es soll.

Sorry, hoffe Ihr könnt helfen!

Danke!

Gruß, PHPman

P.S. Ein "rück Update auf v2.0.14" half auch nicht!

michas.
Posts: 109
Joined: 2003-03-08 13:08

Re: Kernel Update durchgeführt, jetzt geht kein Mailversand mehr

Post by michas. » 2004-02-22 08:25

Outlaw wrote: Also, habe den Fehler beheben können.

Mit

Code: Select all

saslauthd -a pam
geht es wieder.
Super, nur weiss ich jetzt überhaupt nicht, wo ich das eingeben soll, bzw. was da eigentlich gemacht wird. An meiner Telnetconsole kam folgende Meldung:

p15112116:~ # saslauthd -a pam
-bash: saslauthd: command not found
p15112116:~ #