Leider mal wieder LOAD DATA INFILE

MySQL, PostgreSQL, SQLite
Anonymous

Leider mal wieder LOAD DATA INFILE

Post by Anonymous » 2004-01-12 14:13

Hallo, sorry wegen diesem leidigen Thema, aber gleich vorweg, ich habe die Suche benutzt.
Ich bekomme eine andere Fehlermeldung als alle anderen:

LOAD DATA INFILE '/srv/www/htdocs/confixx/tmp/phpDMD56g' REPLACE INTO TABLE `test`
FIELDS TERMINATED BY ';'
ENCLOSED BY '"'
ESCAPED BY '\'
LINES TERMINATED BY 'rn'

MySQL meldet:

#1045 - Access denied for user: 'web6@localhost' (Using password: YES)

Das LOAD DATA LOCAL INFILE nicht geht damit habe ich mich abgefunden, habe auch keine Lust MySql neu zu kompilieren.
Aber warum dieser Fehler, das müsste eigentlich gehen.

Ich versuche das ganze über PhpMyAdmin.

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: Leider mal wieder LOAD DATA INFILE

Post by flo » 2004-01-12 15:00

schon wieder Du ;-)

Hast Du -L schon probiert?

flo.

Anonymous

Re: Leider mal wieder LOAD DATA INFILE

Post by Anonymous » 2004-01-12 15:20

bitte nähere beschreibung...
bist überall crack oder was :lol:

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: Leider mal wieder LOAD DATA INFILE

Post by flo » 2004-01-12 16:10

Sorry, nicht -L, weiß nciht, wie ich darauf komme, wahrscheinlich der Befehl für den Daemon ...

Mit phpmyadmin weiß ich das nicht hundertprozentig, aber

Code: Select all

mysql --local-infile <... authentifizierungskram ...>
schaltet die Option aber ein.

Lt. PHPmyadmin bzw. der ANNOUNCE.txt meiner Version (2.5.4) ist dies als Bugfix aufgeführt, probier doch mal eine neuere Version davon aus.

Ansonsten teste, ob Du das ins Startscript von mysql einfügen kannst.

flo.

Ã?brigens: Nicht überall Crack, aber der jetzige Server ist nicht mein erster ... ;-)

Anonymous

Re: Leider mal wieder LOAD DATA INFILE

Post by Anonymous » 2004-01-12 17:46

die startoption von Mysql kenn ich schon...aber das geht nicht, ohne das Mysql auch mit dieser option compiliert wurde.
Leider ist meine Mysql Version nicht damit gebacken worden. Somit ist auch das ein / ausschalten nicht möglich.
Das bezieht sich aber auch auch nur auf Load Data Local infile, soweit ich weiss. Der Befehl Load Data infile sollte eigentlich gehen.
Ich check das mal mit der neuen Version.

geht das bei dir?

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: Leider mal wieder LOAD DATA INFILE

Post by flo » 2004-01-12 17:55

also ich habe 4.0.16 hier, rufe ich den Client mit "--local-infile" auf oder mysqlimport mit "-L" stellt er das Local richtigerweise auf "TRUE".

Mein MySQL ist nicht mit Local konfiguriert ...

flo.

Anonymous

Re: Leider mal wieder LOAD DATA INFILE

Post by Anonymous » 2004-01-12 18:04

kannst du mal die ganze befehlszeile posten

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: Leider mal wieder LOAD DATA INFILE

Post by flo » 2004-01-12 18:17

Code: Select all

mysqlimport -r -L -uuser -ppass -hdb.domain.de --fields-terminated-by=';' database datei tbl_table

Code: Select all

with options "'--enable-assembler' '--with-comment' '--with-charset=german1' '--with-extra-charsets=all' '--with-mysqld-user=mysql' '--with-unix-socket-path=/tmp/mysql.sock' '--without-innodb' '--without-debug' '--without-bench' '--with-extra-tools' '--with-docs'
'--with-client-ldflags=-all-static' '--with-mysqld-ldflags=-all-static'
'--prefix=/usr/local' '--sysconfdir=/usr/local/conf'"

flo.

Anonymous

Re: Leider mal wieder LOAD DATA INFILE

Post by Anonymous » 2004-01-12 18:37

hast du das gerade in die shell eingegeben, oder steht der befehl bei dir irgendwo drin, wenn ja wo denn?

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: Leider mal wieder LOAD DATA INFILE

Post by flo » 2004-01-12 22:08

Das erste wird bei mir innerhalb eines PHP-SCriptes ausgeführt, udn das zweit war ein Auszug aus der config.status ...

flo.

Anonymous

Re: Leider mal wieder LOAD DATA INFILE

Post by Anonymous » 2004-01-13 12:33

bei mir gibt es leider keine config.status..auch nicht wenn ich mich mit mysql -p einlogge.
hast du denn schon mal probiert von extern auf deine Datenbank via phpmyadmin zuzugreifen und hast mit Load Data Local Infile eine .csv Datei reingeschoben in eine Tabelle?
Und am besten auch nochmal nur mit Load Data Infile ( ohne local )?

Ich habe die phpMyAdmin Version 2.5.5 oder so....ist die aktuellste.

Ich glaube ja eigentlich immernoch das es eine Frage von den nötigen berechtigungen ist. Sonst würde er mir doch die oben beschriebene Fehlermeldung nicht bringen.