Mailserver funktioniert plötzlich nicht mehr

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
warstein
Posts: 8
Joined: 2003-04-10 23:17
Location: NRW

Mailserver funktioniert plötzlich nicht mehr

Post by warstein » 2004-01-08 21:37

Ich bin "stolzer" Besitzer eines Rootservers bei 1 & 1

Mein OS : SuSe 8.1

zu meinen Problem:

Ich führte ein Online-Update durch und einen reboot ...

seit dem funktioniert der Mailserver nicht mehr ... er nimmt keine Mails mehr an und man kann sich nicht mehr einloggen ...

was kann passiert sein ?

Was kann man machen ohne das die Accounts verloren gehen ?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Mailserver funktioniert plötzlich nicht mehr

Post by captaincrunch » 2004-01-08 21:44

Stichworte für die Forensuche: xinetd und RECORD
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

warstein
Posts: 8
Joined: 2003-04-10 23:17
Location: NRW

Re: Mailserver funktioniert plötzlich nicht mehr

Post by warstein » 2004-01-08 21:53

Danke ;)

Hat mir sehr geholfen :)

Also für alle die das selbe Problem nach einen Update haben ...

also alle RECORD einträge in der /etc/xinetd auskommentieren

Code: Select all

/etc/init.d/xinet.d restart
dann funktioniert alles wieder ... :wink:

warstein
Posts: 8
Joined: 2003-04-10 23:17
Location: NRW

Re: Mailserver funktioniert plötzlich nicht mehr

Post by warstein » 2004-01-09 11:00

*arg*

doch zu früh gefreut ...

Jetzt besteht wieder das gleiche Problem

Wenn ich zum Server maile bekomm ich diese Nachricht zurück:

Code: Select all

----- The following addresses had permanent fatal errors -----
warstein@warx.de
(reason: 554 <warstein@warx.de>: Recipient address rejected: Relay access denied)

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: Mailserver funktioniert plötzlich nicht mehr

Post by chris76 » 2004-01-09 11:09

Das ist ein relay access Denied und das ist gut so.
hast du dein Mailporgramm richtig konfiguriert, fehlt da kein häckchen?

Ciao Christian

warstein
Posts: 8
Joined: 2003-04-10 23:17
Location: NRW

Re: Mailserver funktioniert plötzlich nicht mehr

Post by warstein » 2004-01-09 11:20

Also ... wenn ich vom meiner Webmail von web.de zu dem Server hinmaile bekomm ich diese Fehler meldung ....

Und sobald ich ein Mail über den Server abschicken will dann kommt diese meldung:

Code: Select all

Die Nachricht konnte nicht gesendet werden, weil der Empfänger vom Server zurückgewiesen wurde. Serverantwort: "554 <***.***@web.de >:
Recipient address rejected: Relay access denied".  

Also vor dem Online-Update hatte ja alles funktioniert ...

und den smtp zugang benütz ich ja mit authentifizierung ...


Hier die aktuelle xinetd.conf:

Code: Select all

#
# xinetd.conf
#
# Copyright (c) 1998-2001 SuSE GmbH Nuernberg, Germany.
# Copyright (c) 2002 SuSE Linux AG, Nuernberg, Germany.
#

defaults
{
        log_type        = FILE /var/log/xinetd.log
        log_on_success  = HOST EXIT DURATION
#        only_from       = localhost
        instances       = 10
}

service ftp
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/vsftpd
#       server_args     = -a
        log_on_success  = HOST PID EXIT DURATION
}


service pop3
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/sbin/popper
        server_args = qpopper -s
        log_on_success  = HOST PID EXIT DURATION
}

# *grrr* SuSE-8.1: qpopper.rpm compiled without ssl/tls-support
service pop3s
{
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/sbin/stunnel
        server_args = qpopper -l /usr/sbin/popper -- -R -s
        log_on_success  = HOST PID EXIT DURATION
}

#service ident
#{
#       socket_type     = stream
#       protocol        = tcp
#       wait            = no
#       user            = nobody
#       server          = /usr/sbin/in.identd
#       server_args     = -w -t120
#}

service smtp
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/sendmail
        server_args     = -bs B/B7BIT
}

# includedir /etc/xinetd.d

Den service smtp hab ich hinzugefügt, da er nicht eingetragen war .... aber troztdem funktioniert alles irgentwie nicht ...

Hier die alte xinetd.conf:

Code: Select all

#
# xinetd.conf
#
# Copyright (c) 1998-2001 SuSE GmbH Nuernberg, Germany.
# Copyright (c) 2002 SuSE Linux AG, Nuernberg, Germany.
#

defaults
{
        log_type        = FILE /var/log/xinetd.log
        log_on_success  = HOST EXIT DURATION
        log_on_failure  = HOST ATTEMPT
#        only_from       = localhost
        instances       = 2

#
# The specification of an interface is interesting, if we are on a firewall.
# For example, if you only want to provide services from an internal
# network interface, you may specify your internal interfaces IP-Address.
#
#       interface       = 127.0.0.1
#

#
# If you want to enable one of the following services, you only have to
# comment it out. After that, send SIGUSR1 to xinetd to force a
# reload of it's configuration
#

#       disabled        = ftp
        disabled        = rstatd
#       disabled        = telnet
        disabled        = shell
#       disabled        = login
        disabled        = finger
#       disabled        = imap
        disabled        = pop3
        disabled        = comsat
        disabled        = ntalk
        disabled        = talk
        disabled        = discard-stream
        disabled        = discard-dgram
        disabled        = chargen-stream
        disabled        = chargen-dgram
       disabled        = chargen-dgram
        disabled        = daytime-stream
        disabled        = daytime-dgram
        disabled        = time-stream
        disabled        = time-dgram
        disabled        = echo-stream
        disabled        = echo-dgram
        disabled        = smtp
        disabled        = ident
        disabled        = nntp

}

##
## Now the definitions of the different services
##
##

service ftp
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/in.ftpd
#       server_args     = -a
        instances       = UNLIMITED
}



service telnet
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/in.telnetd
        server_args     = -n
#       only_from       = localhost
        no_access       =
}


service shell
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/in.rshd
        server_args     = -L
}


service login
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/in.rlogind
        server_args     = -n
}


service finger
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/sbin/in.fingerd
        server_args     = -w
}

service imap
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = cyrus
        server          = /usr/lib/cyrus/bin/imapd
        server_args     = imapd
}



service pop3
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/ipop3d
        server_args     = -s
}

#service comsat
#{
#       socket_type     = dgram
#       protocol        = udp
#       wait            = yes
#       user            = root
#       server          = /usr/libexec/comsat
#}


service ntalk
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        server          = /usr/sbin/in.talkd
}

service talk
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        server          = /usr/sbin/in.talkd
}


service echo
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        type            = INTERNAL
        id              = echo-stream
}


service echo
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        type            = INTERNAL
        id              = echo-dgram
}




service discard
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        type            = INTERNAL
        id              = discard-stream
}

service discard
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        type            = INTERNAL
        id              = discard-dgram
}

service chargen
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        type            = INTERNAL
        id              = chargen-stream
}


service chargen
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        type            = INTERNAL
        id              = chargen-dgram
}


service daytime
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        type            = INTERNAL
        id              = daytime-stream
}

service daytime
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        type            = INTERNAL
        id              = daytime-dgram
}

service time
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        type            = INTERNAL
        id              = time-stream
}

service time
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = root
        type            = INTERNAL
        id              = time-dgram
}

service smtp
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/sendmail
        server_args     = -bs B7BIT
}

service ident
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/sbin/in.identd
        server_args     = -w -t120
}

service nntp
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = news
        server          = /usr/sbin/leafnode
}


includedir /etc/xinetd.d
Vielen Dank noch mals ;)

warstein
Posts: 8
Joined: 2003-04-10 23:17
Location: NRW

Re: Mailserver funktioniert plötzlich nicht mehr

Post by warstein » 2004-01-09 12:38

Also ne neu installation mit Yast hat auch nix gebracht ???


Hat jemand einen anderen rat ???

Also mein Problem der Mailserver nimmt keine mails mehr an und sendet auch keine mails mehr ...

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: Mailserver funktioniert plötzlich nicht mehr

Post by olaf.dietsche » 2004-01-09 15:51

Ich denke mal, daß deine xinetd.conf hier nichts nützt, weil dein MTA antwortet schließlich auf deine Anfrage.
Interessanter wäre z.B. welchen MTA du benutzt und was in den Logdateien zu deinem Problem steht. Außerdem habe ich den Eindruck, daß du hier zwei verschiedene Probleme schilderst.

warstein
Posts: 8
Joined: 2003-04-10 23:17
Location: NRW

Re: Mailserver funktioniert plötzlich nicht mehr

Post by warstein » 2004-01-09 18:20

Hab mir wohl die ganzen Verknüpfungen mit Confixx geschossen ...

Hab den Server neumachen lassen :(

Naja jetzt hab ich es direkt hin bekommen wie oben beschrieben ...

Danke nochmals ;)