Qmail Problem! Sehr komisch!

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
deeluxe
Posts: 35
Joined: 2004-01-05 20:11

Qmail Problem! Sehr komisch!

Post by deeluxe » 2004-01-08 16:55

Moin Leute!

Ich hoffe einer von euch kann mir helfen! Habe mein mail system nach dem debianhowto.de howto aufgestellt! Zuerst ging auch alles, ich konnte senden und empfangen! Doch jetzt auf einmal, empfange ich keine mail mehr!

Dabei in den logs folgendes steht:
Jan 8 16:49:59 hubert qmail: 1073576999.147220 new msg 1622305
Jan 8 16:49:59 hubert qmail: 1073576999.147338 info msg 1622305: bytes 1658 from <TTT@TTT.TT> qp 11992 uid 64011
Jan 8 16:49:59 hubert qmail: 1073576999.237157 starting delivery 1: msg 1622305 to local ZZZ@ZZZ.ZZ
Jan 8 16:49:59 hubert qmail: 1073576999.237246 status: local 1/10 remote 0/20
Jan 8 16:49:59 hubert qmail: 1073576999.254686 delivery 1: success: did_0+0+1/
Jan 8 16:49:59 hubert qmail: 1073576999.254787 status: local 0/10 remote 0/20
Jan 8 16:49:59 hubert qmail: 1073576999.254808 end msg 1622305

Hat vielleicht irgendjemand mal das gleiche Problem gehabt?

mfg deeluxe

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Qmail Problem! Sehr komisch!

Post by floschi » 2004-01-08 18:21

Wieso, da steht doch, dass du sie empfangen hast?

deeluxe
Posts: 35
Joined: 2004-01-05 20:11

Re: Qmail Problem! Sehr komisch!

Post by deeluxe » 2004-01-08 19:30

ich blicke da aber nicht mehr durch! Ich sehe ja selber das ich die empfangen haben muss, aber sobald ich sie irgendwie abufen will mit pop oder imap, krieg ich nichts. Habe schon nach geguckt pop und imap laufen!

mfg deeluxe

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Qmail Problem! Sehr komisch!

Post by floschi » 2004-01-08 19:34

Landen die E-Mails denn in den passenden Verzeichnissen (/var/vpopmail/domains/.../Maildir/...)? Sind Textdateien, die sich mittels cat anzeigen lassen.

deeluxe
Posts: 35
Joined: 2004-01-05 20:11

Re: Qmail Problem! Sehr komisch!

Post by deeluxe » 2004-01-08 19:37

nein da ist nichts drin was ich mit cat öffnen kann! wo sind die mails denn dann geblieben? wo stell ich ein wo qmail die hinpacken soll?

mfg deeluxe

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Qmail Problem! Sehr komisch!

Post by floschi » 2004-01-08 19:40

Zuerst schaut er, wo die Domain drin steht, also lokale Systemuser (/etc/qmail/{me,local}), dann noch ob es eine virtuelle Domain ist (virtualdomain) und in dieser Konfigdatei sind weitere Einstellungen.

Danach übernimmt vpopmail und wird noch durch eine .qmail-sowieso im jeweiligen Domainverzeichnis gelenkt.

Aber wo genau der Haken liegt, wenn die Mails laut Log ankommen, aber nie ihr Ziel erreichen, ist mir auch nicht klar.

Hast du mal ein weiteres Postfach testweise angelegt? Und evtl. eine weitere Domain?

deeluxe
Posts: 35
Joined: 2004-01-05 20:11

Re: Qmail Problem! Sehr komisch!

Post by deeluxe » 2004-01-08 19:41

alles schon getestet, geht einfach nicht! trotzdem danke für die hilfe!

mfg deeluxe

deeluxe
Posts: 35
Joined: 2004-01-05 20:11

Re: Qmail Problem! Sehr komisch!

Post by deeluxe » 2004-01-08 19:45

die domains sollten eigentlich richtig eingestellt sein! wie sieht denn deine .qmail-default aus? liegt in /var/vpopmail/domains/domain*/

mfg deeluxe

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Qmail Problem! Sehr komisch!

Post by floschi » 2004-01-08 19:45

Sehr seltsam...

Ich würde jetzt an deiner Stelle sämtliche Dateien, die ich im Zusammenhang mit qmail verändert habe, nochmals genau prüfen... v.a. das Startskript, die gesetzten Rechte usw.

Aber wenn es bereits einwandfrei funktioniert hat :-/ seltsam.

Was steht denn in deiner /etc/qmail/{me,local}?

deeluxe
Posts: 35
Joined: 2004-01-05 20:11

Re: Qmail Problem! Sehr komisch!

Post by deeluxe » 2004-01-08 19:48

in der qmail me steht mail.gv-n.de und in der local(bei mir heißt die locals) gv-n.de. nur es lief gestern ja noch, habe nichts an den rechten gemacht!

mfg deeluxe

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Qmail Problem! Sehr komisch!

Post by floschi » 2004-01-08 20:06

Hast du zwischenzeitlich etwas am DNS gedreht oder kurz vorher?