RedHat 9 SSLeay.pm Installation funzt nicht

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

RedHat 9 SSLeay.pm Installation funzt nicht

Post by thefreeman »

Hallo.

Ich möchte gerne meinen Webmin unter SSL laufen lassen.
Dieser hat mir beim Umstellen folgende Meldung gebracht:

Code: Select all

Can't locate Net/SSLeay.pm in @INC (@INC contains: /usr/libexec/webmin /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .)
Dann hab ich folgendes gemacht:

Code: Select all

perl -MCPAN -e shell
Hat gut gefunzt.
Dann hab ich im CPAN folgendes gemacht:

Code: Select all

install Net::SSLeay
So.
Und jetzt hat er nach etlichen Fehlermeldungen der Installation folgenden Fehler gebracht:

Code: Select all

make: *** [SSLeay.o] Error 1
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
Das File /usr/bin/make ist aber da.
Was passt denn nicht???

Danke schonmal

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: RedHat 9 SSLeay.pm Installation funzt nicht

Post by captaincrunch »

Und wieso installierst du nicht einfach das zuständige RPM?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

thefreeman
Posts: 84
Joined: 2003-04-24 18:58
Location: Bayern

Re: RedHat 9 SSLeay.pm Installation funzt nicht

Post by thefreeman »

Weil nur das Perl-Modul fehlt.
SSL läuft schon.