SMTP_AUTH != Spamschutz ?

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
nurre
Posts: 10
Joined: 2003-06-22 15:39

SMTP_AUTH != Spamschutz ?

Post by nurre » 2004-01-08 13:22

Hallo!

Ich habe bei mir SMTP_AUTH am Laufen, d.h. wenn ich im Outlook einstelle dass der Server keine Anmeldeinformationen bekommt und eine eMail sende kommt folgene eMail vom System:

Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.

Betreff: blubber
Gesendet am: 08.01.2004 13:22

Folgende Empfänger konnten nicht erreicht werden:

'xxxxxxxxx@gmx.net' am 08.01.2004 13:23
554 <xxxxxxxxx@gmx.net>: Relay access denied


Das heisst ja eigentlich dass niemand über den Server Mails versenden kann der nicht explizit ein dem System bekannter Mail-Benutzer ist?

Es sind aber doch in letzter Zeit eMails über den Server geflossen, die von Adressen wie BILL@p12345678.pureserver.info oder sowas kamen...

Wie kann sowas sein? Was mache ich falsch? Hat jemand mein PW?

Viele Fragen.... Danke für jeden Hinweis!

Flo

cfuchs
Posts: 30
Joined: 2003-06-18 21:50

Re: SMTP_AUTH != Spamschutz ?

Post by cfuchs » 2004-01-08 13:27

Vielleicht war das eine Mail, die an dich oder ein lokales Postfach gerichtet war?

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: SMTP_AUTH != Spamschutz ?

Post by flo » 2004-01-08 13:28

localhost oder Servernamen in Relaydomains eingetragen?

flo.

nurre
Posts: 10
Joined: 2003-06-22 15:39

Re: SMTP_AUTH != Spamschutz ?

Post by nurre » 2004-01-08 13:46

@cfuchs:
wenn die mail an mich/ein postfach auf dem server ging, warum hat der absender dann meine domain als absender? mit nem namen den ich nicht eingetragen hab?

@flo
# The default relay_domains value is $mydestination.
#
# In addition to the above, the Postfix SMTP server by default accepts mail
# that Postfix is final destination for:
# - destinations that match $inet_interfaces,
# - destinations that match $mydestination
# - destinations that match $virtual_maps.
# These destinations do not need to be listed in $relay_domains.
#
# Specify a list of hosts or domains, /file/name patterns or type:name
# lookup tables, separated by commas and/or whitespace. Continue
# long lines by starting the next line with whitespace. A file name
# is replaced by its contents; a type:name table is matched when a
# (parent) domain appears as lookup key.
#
# NOTE: Postfix will not automatically forward mail for domains that
# list this system as their primary or backup MX host. See the
# permit_mx_backup restriction in the file sample-smtpd.cf.
#
#relay_domains = $mydestination, hash:/usr/local/etc/postfix/relaydomains

...
# In the case of SMTP, specify a domain, host, host:port, [host]:port,
# [address] or [address]:port; the form [host] turns off MX lookups.
#
# If you're connected via UUCP, see also the default_transport parameter.
#
#relayhost = $mydomain
#relayhost = gateway.my.domain
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

ist es das was du meinst? oder was anderes?

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: SMTP_AUTH != Spamschutz ?

Post by flo » 2004-01-08 13:59

Jep, damit wird standardmäßig alles relayed, was von Deinem Host kommt bzw. sagt, es käme von Deinem Host ... Mach das am besten zu Deiner IP oder zur localhost-IP.

Grüße,

flo.

nurre
Posts: 10
Joined: 2003-06-22 15:39

Re: SMTP_AUTH != Spamschutz ?

Post by nurre » 2004-01-08 14:14

ähm.... d.h. genau ich muss WO meine IP eintragen, damit keiner von ausserhalb des Servers Mails schicken kann?

erklär mir das bitte ein bisschen näher, ich blick da nicht so wirklich durch jetzt...

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: SMTP_AUTH != Spamschutz ?

Post by flo » 2004-01-08 14:41

Also erst einmal ist es so, daß generell Mails angenommen werden, die an eins Deiner Postfächer gehen (lokaler User, alias, oder virtueller Eintrag). Da kanst Du nichts machen, das ist durchaus so gewollt, und das passt so.

Wenn nicht, dann vesuche

Code: Select all

telnet relay-test.mail-abuse.org
und schau mal, was dabei rauskommt.

Ein relay existiert nur dann, wenn über Deinen Rechner von einem fremden Rechner aus an eine fremde eMail-Adresse gemailt wird.

Grüße,

flo.

nurre
Posts: 10
Joined: 2003-06-22 15:39

Re: SMTP_AUTH != Spamschutz ?

Post by nurre » 2004-01-08 15:30

Danke, habs gleich versucht...
hier das Ergebnis:

Tested host banner: 220 pXXXXXXXX.pureserver.info ESMTP Postfix
System appeared to reject relay attempts
Connection closed by foreign host.

Das heisst ja wohl dass das Teil sicher ist... aber was bedeutet das jetzt für die eMails dies ja eigentlich nicht geben dürfte?

flo

vratislav
Posts: 118
Joined: 2002-05-05 12:05

Re: SMTP_AUTH != Spamschutz ?

Post by vratislav » 2004-01-08 16:11

Dann solltest du die Mail von "BILL@p12345678.pureserver.info" unter die Lupe nehmen und schauen, ob diese tatsächlich über deinen Server abgesendet wurde (header).

Ich denke nicht.

Solange nur gefälschte Absender an Dich Mails versenden ist alles im grünen Bereich - schlecht ist nur, wenn beliebige Absender über deinen Server an dritte Mails versenden.

Björn

matze
Posts: 23
Joined: 2002-05-09 16:02
Location: Friedberg (Hessen)

Re: SMTP_AUTH != Spamschutz ?

Post by matze » 2004-01-08 16:16

dagegen solls aber auch bald abhilfe geben...
wenn es denn wirklich genutzt wird:
http://www.rootforum.org/forum/viewtopic.php?t=21403