Qmailtoaster - Imap - SSL

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
redhat99
Posts: 112
Joined: 2003-02-17 12:58
Location: Meckenheim

Qmailtoaster - Imap - SSL

Post by redhat99 » 2004-01-08 10:09

Hallo!

Ich habe den qmailtoaster (1.Teil) installiert, und er geht auch so weit.

Nur habe ich probleme mit Imap-SSL.

Ich denke es liegt an meiner: /etc/courier-imap/imap-ssl Datei. Ich habe ein selber zertifiziertes Cert.

Meine Datei:

SSLPORT=993
SSLADDRESS=0
SSLPIDFILE=/var/run/imapd-ssl.pid
IMAPDSSLSTART=YES
IMAPDSTARTTLS=YES
IMAP_TLS_REQUIRED=0
COURIERTLS=${bindir}/couriertls
TLS_PROTOCOL=SSL3
TLS_STARTTLS_PROTOCOL=TLS1
TLS_CERTFILE=/var/qmail/control/servercert.pem
TLS_CACHEFILE=/var/spool/couriersslcache
TLS_VERIFYPEER=NONE


Was ich festgestellt habe, wenn ich die Zeile:

COURIERTLS=${bindir}/couriertls

auskommentiere, startet imap-ssl (der port ist da) aber mein Outlook meckert mit einer Fehlermeldung (x354 bla bla ... sch .. Win :-) )

Hatte jemand das selbe Problem, oder weiss Rat? Wie sieht eure Datei aus, oder liegts ganz an was anderem?

Wenn ich die Zeile: COURIERTLS=${bindir}/couriertls richtig deute, will er doch die Datei couriertls haben, die gibts nirgens auf dem System. Oder ist die Datei nur in der laufzeit vorhanden?

Ach so: Ich habe Debian 3.0 woody

Danke im voraus, grüsse Mario

redhat99
Posts: 112
Joined: 2003-02-17 12:58
Location: Meckenheim

SSl

Post by redhat99 » 2004-01-08 17:39

So habs selber hinbekommen,


bei mir fehlte wirklich die Datei /usr/bin/couriertls ...

keine ahnung warum. Ich habe einfach mal per apt courier-base + courier-ssl installiert und siehe da es ging.

Habe danach die couriertls gesichert, die beiden Pakete entfernt und die Datei wieder nach /usr/bin kopiert.

Nicht gerade die "sauberste" Lösung, aber funktioniert ... 8)


Gruss Mario :P