mysqld, Optionen

MySQL, PostgreSQL, SQLite
cfuchs
Posts: 30
Joined: 2003-06-18 21:50

mysqld, Optionen

Post by cfuchs » 2004-01-07 14:56

Habe heute morgen bemerkt, dass mein mysqld nach einem Reboot nicht mehr auf die Beine wollte. Es gab in /var/lib/mysql/pXXXX.pureserver.info.err den Hinweis, dass er den Parameter "key_buffer = 16M" nicht kennt.

Ich habe die entsprechende Zeile dann in /etc/mysql/my.cnf auskommentiert und den Dienst neu gestartet. Dann kam in der gleichen Datei die Meldung, dass er "max_allowed_packet = 1M" nicht mag (steht direkt unter Key_buffer) und dann auch noch "thread_stack = 128 K" -jedesmal unrecognized option.

Als ich alle drei Werte auskommentiert hatte, startete mysqld auch wieder.
Komisch ist, dass er jetzt für die Werte default-werte verwendet:

mysqld --help:

...
max_allowed_packet current value: 1048576
thread_stack current value: 65536
key_buffer_size current value: 8388600
....

Wieso kann ich diese Optionen nicht per Hand setzen?
Es mag sich blöd anhören, aber ich habe wirklich nichts am mysqld rumgefummelt. Die Maschine habe ich neu gestartet, um den Kernel 2.4.24 einzuspielen (mremap-Bug).
Vorher lief 2.4.23 (aus offiziellen Quellen) unter Debian Woody.

Hier meine /etc/mysql/my.cnf (mit den auskommentierten Werten):

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#

# This will be passed to all mysql clients
[client]
#password = my_password
port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
err-log = /var/log/mysql/mysql.err
socket = /var/run/mysqld/mysqld.sock

[mysqld]
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306

#

#
# You can also put it into /var/log/mysql/mysql.log but I leave it in /var/log
# for backward compatibility. Both location gets rotated by the cronjob.
#log = /var/log/mysql/mysql.log
log = /var/log/mysql.log
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-locking
#
# The skip-networkin option will no longer be set via debconf menu.
# You have to manually change it if you want networking i.e. the server
# listening on port 3306. The default is "disable" - for security reasons.
skip-networking
#key_buffer = 16M
#max_allowed_packet = 1M
#thread_stack = 128K
#
# Here you can see queries with especially long duration
#log-slow-queries = /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication
#server-id = 1
#log-bin = /var/log/mysql/mysql-bin.log
#binlog-do-db = include_database_name
#binlog-ignore-db = include_database_name
#
# Read the manual if you want to enable InnoDB!
skip-innodb
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
max_allowed_packet = 1M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer = 16M



Vielen Dank für eure Hilfe,
Christoph

cheops
Posts: 8
Joined: 2002-12-01 15:54

Re: mysqld, Optionen

Post by cheops » 2004-01-15 18:28

Da fehlt jeweils ein "set-variable =" vor den Einträgen.

Code: Select all

set-variable   = key_buffer = 16M 
set-variable   = max_allowed_packet = 1M 
set-variable   = thread_stack = 128K 
Gruß
Martin