qmail probleme mit CRAM MD5 beim Versenden

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

qmail probleme mit CRAM MD5 beim Versenden

Post by cipi » 2004-01-04 17:23

Hi,

nachdem ich meinem Debian ein upgrade gegönnt habe, ging mein qMail nicht mehr korrekt. Es konnten keine Mails mehr verschickt werden.

Nun habe ich nach Anleitung von debianhowto.de Qmail neu aufgesetzt, auch mit dem auth-smtp-Patch.

Verschicken geht nun wieder, nur leider ohne authenticating (software CRAM-MD5). Wenn ich dies einschalte, bekomme ich im Logfile folgende Fehlermeldung:

Code: Select all

vpopmail[4824]: vchkpw-smtp: password fail (pass: '<4823.1073231467@xxxxx.biz>') testuser@xxxxx.biz:80.111.111.111
Dieser Fehlercode wird 2x angezeigt und die Mail nicht versendet.

Wenn ich jedoch MD5 ausschalte, wird die Mail mit dem Hinweistext (siehe oben) versandt.

Hat jemand eine Idee, wo ich den Fehler suchen könnte?
Hat das grundsätzlich was mit vpopmail zu tun, oder eher nicht?

Vielen Dank für eure Antworten!

ffl
Userprojekt
Userprojekt
Posts: 269
Joined: 2002-10-23 08:28
Location: Karlsruhe

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by ffl » 2004-01-04 23:57

Ich schätze mal, dass da ein PAM Modul geupdatet wurde und dass es deswegen nicht mehr geht.

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by cipi » 2004-01-05 00:01

gut dann suche ich mal auf dieser schiene.

hat vielleicht noch jemand dieses problem? ich dachte so ein upgrade macht doch wohl jeder mal, oder?

ich hab auch gerad nochmal einen neuen user angelegt, bei dem dies aber auch nicht funktioniert mit dem verschicken.

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by floschi » 2004-01-05 07:41

Was genau hast du denn upgedated? Das ganze System oder nur apt-get update && apt-get upgrade? Und wo ist der Zusammenhang zu qmail?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by cipi » 2004-01-05 11:12

ein einfaches "apt-get update && apt-get upgrade" er hat dann zig pakete erneuert. Wo genau der Zusammenhang mit Qmail ist, weiß ich leider auch nicht. Anscheinend hat er da was mit geupdated, was er nicht sollte?!

Kann man das ganze auf einen Schlag wieder rückgängig machen? Dann könnte ich ja testen, woran es liegen könnte ....

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by floschi » 2004-01-05 11:27

Nein :(

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by kenzo » 2004-01-05 12:06

Wenn ich jedoch MD5 ausschalte, wird die Mail mit dem Hinweistext (siehe oben) versandt.
Heißt das, wenn Du MD5 ausschaltest wird trotzdem die Fehlermeldung angezeigt?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by cipi » 2004-01-10 08:27

Ja, in den Logfiles steht diese trotzdem drin, nur versenden klappt in diesem Fall trotzdem. (Also ich schalte MD5 bei Client aus, in diesem Fall The Bat).

Sagt dir das was?

Was mich gerade auch noch interessiert, in welchem Programmteil kann den der Fehler liegen? Mit vpopmail hat das nichts zu tun, oder?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Nachtrag

Post by cipi » 2004-01-10 17:54

Angeblich sollte aber md5 installiert sein:


mozart:~ # telnet xxx.xx 25
Trying 217.160.xxx.xxx...
Connected to xxx.xx.
Escape character is '^]'.
220 xxx.xx ESMTP
EHLO
250-xxx.xx
250-AUTH LOGIN CRAM-MD5 PLAIN
250-AUTH=LOGIN CRAM-MD5 PLAIN
250-PIPELINING
250 8BITMIME

Sieht ja erstmal gut aus, oder?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

was mir aufgefallen ist

Post by cipi » 2004-01-10 20:31

es gibt die Datei
/opt/vpopmail/domains/xxx.xx/vpasswd

dort stehen ja die ganzen User drin, die Popboxen haben.
bei einem User steht das Passwort in der letzten Spalte im Klartext, bei den anderen nicht. Aber genau bei diesem einen User funktioniert das MD5-Verfahren noch.

Kann ich das irgendwie irgendwo einstellen?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by cipi » 2004-01-12 02:50

Ist gefixed.

Hab vpopmail nochmal frisch installiert und dabei --enable-clear-passwd auf y gesetzt. Nun gehts wieder ... oder ist das gar nicht angeschaltet?

Fehlermeldungen kommen jedenfalls im Logfile nicht mehr!

dimaki
Posts: 66
Joined: 2002-11-07 14:45

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by dimaki » 2004-01-14 09:15

Also zumindest in der neuesten vpopmail version (5.4.0-rc1) gibt es den Schalter --enable-clear-passwd gar nicht mehr.
Das ist jetzt immer aktiviert.
Du kannst es bei Bedarf ausschalten mit --disable-clear-passwd.
Ob das allerdings was mit Deinem Problem zutun hatte, wage ich zu bezweifeln. Denke eher, dass vpopmail mit irgendeiner neuen lib (z.B. MD5) nicht klarkam, deshalb gehts jetzt auch nach dem neukompilieren.

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by kenzo » 2004-01-14 13:41

Hab vpopmail nochmal frisch installiert und dabei --enable-clear-passwd auf y gesetzt. Nun gehts wieder ... oder ist das gar nicht angeschaltet?
Welche vpopmail-Version(en) hast Du probiert?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by cipi » 2004-01-14 13:44

ich hatte das mit der 5.4.RC probiert, da gings nicht. Dann bin ich wieder zurück auf die 5.3.30 mit dem entsprechenden Schalter und da ging es.

Wie gesagt, jetzt läuft alles wieder, so wie es soll :)

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: qmail probleme mit CRAM MD5 beim Versenden

Post by kenzo » 2004-01-14 13:53